1. 012anonymousxyz's Avatar
    Hello! Firstly, this is not a throw-away account! I simply picked an unfortunate name.

    My problem: I am trying to get internet access through my Kyocera Rise C5156. Note that I am Canadian and this is NOT C5155. Public mobile does not allow me to enable hotspots and it has actually completely removed that feature from my settings. So I did a lot of reading and I initially tried PDAnet and Foxfi to no avail.
    It is worth noting that previously, in devices, I had under 'unknown devices' 'Kyocera Modem' or something like that. I later figured out that the American drivers I tried to install (from their website) did not work specifically because they don't want to allow hotspots. Apparently in America a court ruling said Sprint and companies were not allowed to block hotspots but that is not the case in Canada. PDAnet cleared that up though. They installed the modem drivers. Now there is no yellow caution triangle and I see 'android device' and a quick adb devices shows my device connected (previously it was not).
    Continuing on, I learned about something called 'Wired tether for Root Users.' So I figured out how to root my phone and installed the app. I change device mode to 'generic,' and 'Generic ICS/JB (wlan0) and I see the SSID and it says I'm connected and have internet access but when I open a webpage, I get "this webpage is unavailable.' Worth noting that with foxfi and PDAnet, I would get "no data received.' I could connect to the SSID but it would say 'no internet access.'

    There ARE other settings like change setup-method, send Netd Max Client Cmd, change channel, wifi-driver reload, wifi-driver reload 2, dns configurations and LAN settings but I do not know the details and none of them SEEM like they would be useful

    I am so close but I cannot figure this out. I really need help. I know the internet is slow but I live in a very small closet and I cannot afford internet. I appreciate your time! If anything tell me if this is possible or not because I have spent 4 hours trying different apps.
    01-20-2014 11:19 AM
  2. zkSharks's Avatar
    Unfortunately I'm not familiar enough with your device and setup to offer much specific help. It sounds like the mobile data isn't being passed through to the local network being created, and it's possible this is due in part to how tethering was restricted on your Rise. I'll see if anyone else has any ideas.
    01-20-2014 01:00 PM
  3. 012anonymousxyz's Avatar
    Thank you so much for the fast reply! I really appreciate it.
    01-20-2014 03:48 PM
  4. 012anonymousxyz's Avatar
    I tried re-installing everything but to no avail. I don't know what I was expecting though. Albert Einstein would call me crazy.
    01-22-2014 09:24 PM

Similar Threads

  1. Air Command on S-pen for 2014 Note? So can the S-pen button be customized in apps?
    By MissStreelight in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 2
    Last Post: 02-10-2015, 07:02 AM
  2. Tethering an iPhone 5
    By gtcharlie in forum Google Nexus 7 Tablet (2013)
    Replies: 6
    Last Post: 01-21-2014, 01:40 PM