03-19-2017 05:19 PM
61 123
tools
  1. joe_fresh's Avatar
    I just went into Google settings app on my phone, hit the 3 dots on upper right corner and hit clear app data on both accounts I have in there and play store seems to be working again. Unless they released an update and I didn't see it.

    Posted via Android Central App nexus 7
    03-04-2014 05:54 PM
  2. joe_fresh's Avatar
    I just went into Google settings app on my phone, hit the 3 dots on upper right corner and hit clear app data on both accounts I have in there and play store seems to be working again. Unless they released an update and I didn't see it.

    Posted via Android Central App nexus 7
    NOPE broke again
    03-05-2014 05:18 AM
  3. Nathaniel Graham's Avatar
    I'm having the same problem. Had it with my GS3, my Nexus 7,and yesterday I upgraded my GS3 to a Note 3 and guess what? Same problem. I've tried everything, it's getting old quick. How do you contact Google to tell them about this? I can't seem to find a way to communicate with them.

    Posted via Android Central App
    03-05-2014 02:01 PM
  4. tiddyt's Avatar
    Just thought I'd add myself to the list of those experiencing the same thing. Didn't notice it until today, but then again, I don't go to play store every day. Having problem on both my Nexus 5 and 1st Gen Nexus 7. Noticed today on my Nexus 5 while I was away from home, and figured maybe it was just a issue of play store not playing nice with T-Mobile network, but get home and not only is it also happening on wi-fi, but it's also affecting my Nexus 7. I can still get it to open to a particular app or search query by searching or clicking a link in a browser, and can bring up menu by changing screen orientation and get to "My Apps" from there. But no matter what I do it won't open to "Store Home". I've tried all the fixes and nothing has worked. Very strange.
    03-06-2014 04:27 PM
  5. tiddyt's Avatar
    I'm having the same problem. Had it with my GS3, my Nexus 7,and yesterday I upgraded my GS3 to a Note 3 and guess what? Same problem. I've tried everything, it's getting old quick. How do you contact Google to tell them about this? I can't seem to find a way to communicate with them.

    Posted via Android Central App
    Go to - Google Play Help. Click "Contact Us" in upper right corner. Navigate through several questions until "Call Us" appears as an option on the bottom. You can fill out the form and they'll contact you.
    03-06-2014 04:42 PM
  6. Androyds's Avatar
    If any of u guys are rooted download rom manager go to etc then host then text editor and make sure it look somethin like this 127.0.0.1 localhost
    #127.161.224.129 android.clients.google.com mtalk.google.com
    127.196.200.123 android.clients.google.com mtalk.google.com
    Then reboot an it chould work
    03-10-2014 07:31 PM
  7. Nathaniel Graham's Avatar
    Go to - Google Play Help. Click "Contact Us" in upper right corner. Navigate through several questions until "Call Us" appears as an option on the bottom. You can fill out the form and they'll contact you.
    Thanks for responding, I forgot I even posted this question and just saw your reply today. I eventually figured out how to contact them and while they were very nice over the phone, they couldn't figure out what was going on. They e-mailed me a couple times and in the last one said that they would get a specialist to get back to me, that was about a week or so ago and nothing yet. I will say though that it now works every once in a while, like if I'm really determined and keep pressing "retry" it will sometimes open the app store home page. Doesn't make much sense to me but working sometimes is better than never I guess.
    03-16-2014 01:28 AM
  8. MoDebt's Avatar
    Under Settings/Date&Time, uncheck the "Automatic date & time - Use Network-provided Time" and "Automatic time zone - Use network-provided time zone".

    One retry for the Play Store and it's now working.

    Not ideal, but it worked for me.
    03-17-2014 02:42 PM
  9. TRACYSRAIL's Avatar
    This has to be the most frustrating thing second to having no or slow internet. I have tried everything suggested. Nothing is working. What the hell Google?!?! Does anyone know if they are working on this or maybe if it has to do with the new OS update? It just started happening for me about four days ago.
    03-19-2014 05:49 PM
  10. readhpr's Avatar
    This has to be the most frustrating thing second to having no or slow internet. I have tried everything suggested. Nothing is working. What the hell Google?!?! Does anyone know if they are working on this or maybe if it has to do with the new OS update? It just started happening for me about four days ago.
    It has been happening for me for a month. I've tried everything, and nothing fixes it. It's equally frustrating that there doesn't seem to be a way to report it to Google via email. I really don't want to call on the phone.
    03-19-2014 10:23 PM
  11. jabwtv's Avatar
    I still do not have the latest version of Google Play Store on my Sprint HTC One and 2012 Nexus 7, is this unusual?
    03-21-2014 01:21 AM
  12. joe_fresh's Avatar
    Seems mine has been working properly today.


    and broke again this morning.
    Posted via Android Central App nexus 7
    03-24-2014 04:57 PM
  13. metalfan78's Avatar
    Mine won't work today, tried all the fixes I could find, no luck.
    03-28-2014 03:25 PM
  14. bumpandrun's Avatar
    Some days mine works, but most of the time it doesn't (I did the fix provided a few weeks ago and it worked after a couple of refreshes). Google really needs to fix this!!
    03-28-2014 03:34 PM
  15. lrm537's Avatar
    There's a Google groups page for this issue. Not that it's helped any. I've started using a second account, which is far from an ideal solution.

    productforums.google.com/forum/?nomobile=true#!msg/nexus/GVEoXmDBJWg/FXmy6pftr8cJ


    Sent from my Nexus 5 using Tapatalk
    04-06-2014 04:46 AM
  16. readhpr's Avatar
    There's a Google groups page for this issue. Not that it's helped any. I've started using a second account, which is far from an ideal solution.

    productforums.google.com/forum/?nomobile=true#!msg/nexus/GVEoXmDBJWg/FXmy6pftr8cJ
    Thanks for the Google forum link. Someone there suggested opening up the Play Magazines (actually it's Play Newstand now) and Play Movies apps, and then try opening up the Play Store. I use Play Movies all the time so I didn't think that would do it for me, but I opened up Play Newstand on my Moto X, then opened up the Play Store, and after a slight delay it actually opened up the Play Store home screen. Then I tried opening Play Store on my Nexus 7, and it was still timing out. So I opened up Play Newstand on the Nexus 7, and now the Play Store is working there too. Whether it will stay fixed is an open question, but give this a try.
    04-06-2014 10:23 AM
  17. lrm537's Avatar
    Thanks for the Google forum link. Someone there suggested opening up the Play Magazines (actually it's Play Newstand now) and Play Movies apps, and then try opening up the Play Store. I use Play Movies all the time so I didn't think that would do it for me, but I opened up Play Newstand on my Moto X, then opened up the Play Store, and after a slight delay it actually opened up the Play Store home screen. Then I tried opening Play Store on my Nexus 7, and it was still timing out. So I opened up Play Newstand on the Nexus 7, and now the Play Store is working there too. Whether it will stay fixed is an open question, but give this a try.
    I've tried all the suggested fixes and none have worked for me. Must people do find a fix, but there's a group of users that just cannot find a solution for this. I've resorted to using a 2nd account on my devices.

    Sent from my Nexus 5 using Tapatalk
    04-16-2014 05:56 AM
  18. Genielinda's Avatar
    Definitely sounds like a Google problem
    I did all the settings and resets.. still same issue
    turned off Wifi, Blue Tooth.. powered down Galaxy Note
    Powered up again turned on Wifi and Blue tooth.. powered down
    Powered up again, tried Google Play GOT IN.. went to download free app.. loses connection .. in the meantime it is updating a program already.. which I think is the issue at the moment. At least I got in. so I told it to wait and POOF the Android Torque Lite program installed... yeah husband is messing with my car.. but it did work.. finally
    05-06-2014 11:19 AM
  19. readhpr's Avatar
    Mine was broken for close to 2 months, but it has been working fine for the last few weeks since there was an update.
    05-06-2014 09:09 PM
  20. Muhammad Haroon2's Avatar
    Make sure to close the play store app from the task manager before
    If your phone is rooted then
    1. Download any root expolorer.
    2. Navigate to system/etc.
    3. Now you wil find the 'hosts' file.
    4. Delete that hosts file.
    5. Try to open the play store again.
    It worked for me.
    Wish you good luck!
    08-06-2014 01:59 AM
  21. Sammy Yu's Avatar
    Just for the information of anyone who needs it.

    I'm using a Nexus 4 with android 4.4.4 kitkat build KTU84P. I also have the Connection time-out retry problem. I've been using all the advises I could find including on this thread and I was able to find a work-around on this problem. Not a permanent fix though. But being able to access Play Store and download apps and update apps any way possible is all that matters.

    First as suggested by someone in this thread I believe, go to settings -> date & time, uncheck both the Automatic date & time box and the Automatic time zone box. In essence, using the manual settings. (Make sure you have the right manual time-zone.
    (I don't know if this is necessary or if it helps fix the problem but I did it anyway).

    When you're wifi is on and you're connected, go to Play Store. When you see the Connection Time Out Retry message. Go to the Search section and search for any android app. Then select that app. If you're lucky like me, you should be able to go to that particular android app. (You should be able to download the app to your Android unit.)

    Now, try to get out of that selected app (I believe it's called the "back and up" arrow symbol?) If you're lucky, you should get back to the Play Store Home screen.

    Now I seem to get connection problems every now and then. But trying to move back and forth in Play Store as well as to my installed apps and doing more Searches sometimes helps. Not the most effective solution but hopefully a useful one nonetheless. I don't know if this will work for others or how long it will work. For me, it's just been for a few days. But hopefully it will work for others as well. There are still times when it is slow. My guess is that Play Store has not optimize its app when the updated one was implemented. I remember having the same problem when I switch from Google Play to Play Store. Good Luck.
    11-12-2014 10:01 AM
  22. Jenson Pcs's Avatar
    Found this in another thread, worked like a charm for me:-

    1. Switch off wifi
    2. switch on your flight mode
    3. Switch on your wifi
    4. Restart your mobile with ACTIVATED FLIGHT MODE & WIFI.
    5.KEEP flight mode On
    6. OPEN GOOGLE PLAY.
    ITS WORK
    7. Then Switch off flight mode
    12-30-2014 09:33 AM
  23. Alagesan murali's Avatar
    The same happens to my MI REDMI Note also i had a problem for last three days then only i understood that DATA connection is over.. Then i activated DATA connection after activated its works normally...
    02-17-2015 12:17 AM
  24. Kgabo Leso's Avatar
    I'm having same issues but mine is bit strange, when am at my home network(Wifi) thats when I get connection time and I tried almost all suggestions of clearing the data, the cache for the app, but what I noticed is that I do have internet access and I can open google play store via chrome and works fine, but apps like Google now and Gmail they also fail to connect, the minute I connect to Wifi at work everything works fine even on 3G everything works fine, so is it possible that there must be a configuration on my wifi that block me from connection to google services via apps, this issue is on both my phone and tablet.

    After i cleared data on Google Play store, I'm leave with zero applications under 'Installed' tab, how do I get my application back to display without having to uninstall and install again, now whats happening I dont get update on out dated applications.
    03-01-2015 11:46 PM
  25. Ganesh M1's Avatar
    My apps are waiting to Google Update but my Google play store not working. I try to open sy connection time out! What i can do
    07-16-2015 12:22 AM
61 123

Similar Threads

  1. Default number for Google Now?
    By jerethi in forum General Help and How To
    Replies: 7
    Last Post: 12-15-2017, 08:42 PM
  2. Google voice typing option is missing
    By Ra Do in forum Verizon Galaxy S III
    Replies: 10
    Last Post: 08-18-2016, 06:59 AM
  3. Google+ Notifications not working properly
    By Nano Ruibal in forum General Help and How To
    Replies: 5
    Last Post: 08-08-2015, 01:15 AM
  4. Please help... Play Store HOME PAGE will not load
    By Arielle Williams in forum Samsung Galaxy S4 Mini
    Replies: 1
    Last Post: 02-22-2014, 02:47 PM
  5. Has Google Music All Access data usage gotten better?
    By BlackLS3 in forum General News & Discussion
    Replies: 0
    Last Post: 02-22-2014, 12:25 PM
LINK TO POST COPIED TO CLIPBOARD