1. BQSOnAQuest's Avatar
    I have what most would call econmy tablet. That runs the latest KitKAt 4.4.2 (stock) so if the google plays says it requires android 2.0 or higher, then why does it say my devices are not compatiable.

    1) Brand/model:iRulu eXpro X1a Series
    CPU Processor:Allwinner A33, Quad core A7 1.3GHz
    Operating System:Google Android 4.4.2 KitKat
    Camera:Dual Cameras, 0.3M Front 2.0MP Back(With Flash Lamp)
    Network Communiction: Wifi,External 3G

    ----------------------------------------

    2) Brand/model: Yuntab7
    Processor Model: A23 {Quadcore} - (Allwinner)
    Network Communiction: Wifi,External 3G
    Touch Screen Type:Capacitive Screen
    Feature: Multi Touch,G Sensor,FM,OTG,Ultra Slim,Dual Cameras
    04-13-2015 07:09 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Those requirements are necessary, but not sufficient. There can be other hardware factors that are more obscure, like the chipset.

    Google Play Store can sometimes be more conservative than other sources. If Google Play says it's incompatible, check other app stores like Amazon Appstore, GetJar, or SlideMe.
    04-13-2015 11:37 PM

Similar Threads

  1. is this normal? ram usage
    By Sander1101 in forum Samsung Galaxy S6 edge
    Replies: 7
    Last Post: 04-14-2015, 11:04 PM
  2. How do I find the minimum requirements of Bank of America's Android app?
    By BQSOnAQuest in forum General Help and How To
    Replies: 1
    Last Post: 04-13-2015, 11:39 PM
  3. Has anyone tried this method of rooting the Turbo?
    By Bleezy in forum Motorola Droid Turbo
    Replies: 2
    Last Post: 04-13-2015, 10:30 PM
  4. Backing up a Moto G... with no screen.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-13-2015, 07:06 PM
  5. Replies: 0
    Last Post: 04-13-2015, 06:59 PM
LINK TO POST COPIED TO CLIPBOARD