1. garrettvp9's Avatar
    I have a Verizon lg g3 and for a while Google plus and Google plus photos (which is now just photos) instantly crash when I open them. I managed to get Google plus to work by restoring it to the factory version but the updated ones won't work. I thought the update to lollipop might fix it but it didn't. It wasn't a huge deal because all my photos would still back up. Now I am really disappointed because I want to use the new photos app unveiled at IO but I can't. I can view photos with it like from my camera roll but can't open the app itself. Does anyone have a solution and know why the issue is only specific to photos and Google plus?

    Posted via Android Central App
    05-30-2015 08:29 PM
  2. B. Diddy's Avatar
    Have you already tried going to Settings>Apps>All, selecting Photos, and Clearing Cache/Data, then Force Stopping? Do the same for Google+ as well. Now open them again and see if they work properly.
    05-31-2015 01:07 AM
  3. garrettvp9's Avatar
    Yes, I've done that plenty of times.

    Posted via Android Central App
    05-31-2015 10:54 AM
  4. Javier P's Avatar
    Check something. Go to the "all" tab in your settings - apps and scroll down until you find photos. Do you have one or two different apps with the same name?

    If you have two, check the different versions and sizes.
    05-31-2015 11:43 AM
  5. Javier P's Avatar
    A time ago the Photos app was part of Google+ and now it's completely independent. The old one was pretty small (32 kb) almost a shortcut to the feature included in G+. Maybe that's the app that you're trying to open and it doesn't work anymore.
    05-31-2015 12:06 PM
  6. garrettvp9's Avatar
    Thanks for the input but that wasn't the issue either.

    Posted via Android Central App
    05-31-2015 12:29 PM
  7. garrettvp9's Avatar
    The issue came long before the updat that separated the two.

    Posted via Android Central App
    05-31-2015 12:29 PM
  8. Javier P's Avatar
    Thanks for the input but that wasn't the issue either.

    Posted via Android Central App
    Oh well, it was a long shot anyway. Strike one then

    It seems you've tried anything in book about errors in the apps themselves so let's try with other things they share.

    Your media files. Do you have an SD card? Take it out and see if things are different.

    Some weird conflict with another app. Install the latest version for both apps but don't open them yet. Boot your phone into safe mode and see how it goes just opening those two apps.

    Some problem with your Google account, used by them to sign in and backup your files. Remove your Google account and sign in back. I know, it's a lot of work for such a long shot.

    Ok then. Just waiting for strike two
    05-31-2015 02:30 PM
  9. garrettvp9's Avatar
    Let me give it a shot

    Posted via Android Central App
    05-31-2015 09:16 PM
  10. garrettvp9's Avatar
    Haha, I took out my SD card and the photos startup animation started to run. I thought it was going to work but then it crashed. Gonna try safemode now, I can't remember if I've tried that before.

    Posted via Android Central App
    05-31-2015 09:19 PM
  11. garrettvp9's Avatar
    Ahh, what is happening. My phone is fine but as soon as I open the accounts tab in settings it lags like crazy.

    Posted via Android Central App
    05-31-2015 09:34 PM
  12. garrettvp9's Avatar
    Well I did all of it and I actually managed to get into Google+ and with Photos I got all the way up to the step where I had to log in and then when I said I didn't want to log in, it crashed.

    Posted via Android Central App
    05-31-2015 09:56 PM
  13. B. Diddy's Avatar
    Can you try booting into Safe Mode? If it's some 3rd party app that's causing the problems, then the Settings>Accounts menu should work fine in Safe Mode. If Google+ was preinstalled on the phone, then that should also work fine in Safe Mode if the culprit is a 3rd party app. If the problems persist, then I'd wonder if something has gone wrong with the phone's firmware.
    06-01-2015 12:16 AM
  14. garrettvp9's Avatar
    So as I said I did manage to get Google+ to work finally, even though I had tried that method before. The bigger issue is photos because I actually need the app. Unfortunately, it is new so I can't use it in safemode. It does appear though that the issue that I had with Google plus is what photos is experiencing as well.
    06-01-2015 12:19 AM
  15. garrettvp9's Avatar
    How could something go wrong with my firmware?
    06-01-2015 12:19 AM
  16. B. Diddy's Avatar
    ROMs can sometimes become corrupt. On Nexus or Samsung devices, it's relatively straightforward to re-flash the firmware, but I'm not sure about the G3.

    What version of Google Play Services do you have? I'm on 7.5.71.
    06-01-2015 02:53 AM
  17. Javier P's Avatar
    Ok, first base

    B. Diddy's suggestion is a good call. The Play services is kind of a supermanager for most Gapps. If you don't have the latest version there's an easy way to force the update. Go to the Play Store and download Android wear. Once installed the Play Services will be updated in a little while. You can uninstall the wear app after GPS are updated.

    And back to our list. Have you transferred any app to your SD card? Try to check in your computer if there's any corrupted file in that card.

    I didn't understand a couple of things. You managed to get Google+ working, but is it still working after you exit safe mode? Do you still have the same lag after removing your Google account and adding it back?

    That lag means that there's a problem with your accounts or a weird conflict with some app or something wrong with your rom, as B. Diddy said.

    Check all your accounts (no Google included). Do you have any battery saver, ram booster, app killer, antivirus or any app with a name beginning with smart? You'd be amazed how many problems in this forum are fixed after you disable that kind of apps.
    B. Diddy likes this.
    06-01-2015 06:11 AM
  18. garrettvp9's Avatar
    I'll try uninstalling some apps like that. Also, Google+ is entirely fixed and the account lag issues stopped. Also, I use android wear so Google p)a services should be updated but I will still check. I'm pretty sure my SD card is fine but ill check again.
    06-01-2015 09:24 AM
  19. Javier P's Avatar
    That's good then. Sometimes when you uninstall an app some residual files are left behind. Usually that's not a problem but worth a try anyway. You could try this. Download ES File Explorer and open it to activate. Exit. Go to your settings - apps and clear data for Photos and uninstall. ES will check for residual files, if it finds any you'll be prompted to confirm delete. Reboot your phone and install Photos back.
    06-01-2015 09:59 AM
  20. garrettvp9's Avatar
    Oh I've already done that
    06-01-2015 12:43 PM

Similar Threads

  1. Replies: 2
    Last Post: 05-31-2015, 06:11 PM
  2. How to transfer text threads phone one phone to another and vice versa?
    By CynicalLoner in forum General Help and How To
    Replies: 2
    Last Post: 05-31-2015, 01:06 PM
  3. Google is turd now. wtf?
    By Alan Tait in forum Legacy Android & Other OS's
    Replies: 2
    Last Post: 05-31-2015, 02:06 AM
  4. Replies: 1
    Last Post: 05-31-2015, 01:09 AM
  5. Multiple addresses in contacts profile?
    By rpoli86 in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 05-30-2015, 07:19 PM
LINK TO POST COPIED TO CLIPBOARD