1. jhav16's Avatar
    PLZ HELP!!! Today I have received my brand new pair of snapchat spectacles from snap inc. I opened the canister they came in, and took the plastic off the port and button. I wanted to try them out so I pressed the button but the led blinked red with 1 white dot pulsing on the front led. So I charged them in the case for about 2-3 hours and the case is fully charged but the spactacle have made no progress at all. Ihave reset them and done everything I can think of. If anyone can help, plz reply!!!
    03-13-2017 10:26 PM
  2. Matthewguy's Avatar
    PLZ HELP!!! Today I have received my brand new pair of snapchat spectacles from snap inc. I opened the canister they came in, and took the plastic off the port and button. I wanted to try them out so I pressed the button but the led blinked red with 1 white dot pulsing on the front led. So I charged them in the case for about 2-3 hours and the case is fully charged but the spactacle have made no progress at all. Ihave reset them and done everything I can think of. If anyone can help, plz reply!!!
    Same thing happen to me yesterday. I just emailed back and forth with support and they finally said I'll have to send them back and exchange. I got teal ones.
    03-14-2017 11:14 AM
  3. Matthewguy's Avatar
    This guy was having the same problem.

    You can see when he does the charge check it shows a full circle. Mine never got past the one dot and just blinks red.
    03-14-2017 11:17 AM
  4. M0G0's Avatar
    This guy was having the same problem.

    You can see when he does the charge check it shows a full circle. Mine never got past the one dot and just blinks red.

    Same here, I got mine from the Venice storefront this afternoon. Took them out paired them, used them for about 2 videos before the turned off due to low battery. The case is fully charged and when I put the glasses in the case nothing comes on at all. Then I tried charging direct from the cable to the glasses and the same result, no light, nothing. When I press the power button it blinks one dot and red.
    03-15-2017 02:57 AM
  5. milkeu's Avatar
    PLZ HELP!!! Today I have received my brand new pair of snapchat spectacles from snap inc. I opened the canister they came in, and took the plastic off the port and button. I wanted to try them out so I pressed the button but the led blinked red with 1 white dot pulsing on the front led. So I charged them in the case for about 2-3 hours and the case is fully charged but the spactacle have made no progress at all. Ihave reset them and done everything I can think of. If anyone can help, plz reply!!!
    Hello! I had the same problem and then I found out that there's a small piece of plastic on the charging part of the glasses to protect it. Take it off and I think should be good to go
    03-18-2017 02:43 AM
  6. bedo300's Avatar
    Hey there,

    Try the below, mine has the same issue and it works now.

    Plug in your Specs for 60-90 minutes. It's okay if you don't see any LEDs changing, just let your Specs sit on the charger for a full hour!
    Unplug your Specs.
    Press and hold the button on Specs for 55 seconds, until you see 1 bottom LED illuminate. We recommend using a timer for this step
    Remove your finger from the button. You should see 3 LEDs in an upside down triangle pattern illuminate.
    Tap the button again. You should see the 3 LEDs start to spin. All of the LEDs will slowly illuminate one by one.
    You should see all LEDs flash once step 5 is complete - this may take a few minutes.

    If you didn't see the behavior explained in steps 4, 5 or 6 happen - don't worry! Try Step 3 at least 3 times. Sometimes the 55 second button hold takes a few tries
    ashleySR, Karnidge and belodion like this.
    03-20-2017 11:31 AM
  7. ashleySR's Avatar
    Thank you so much for this, i had almost given up on my spectacles and since i did not buy directly from snapchat i was almost certain $120 were down the drain. Tried your fix and they are working now yay!!!
    04-11-2017 07:40 PM
  8. Karnidge's Avatar
    Thank you! I just bought these for my daughter and we had the same issue. They wouldn't connect to her phone and we only saw 1 LED when charging. After completing the steps you listed, they are working. Woot!!
    06-03-2017 03:31 PM

Similar Threads

  1. Replies: 2
    Last Post: 03-14-2017, 01:02 PM
  2. Another fast charge issue
    By Tome1 in forum Samsung Galaxy S6 edge
    Replies: 0
    Last Post: 03-13-2017, 08:51 PM
  3. Why won't my Samsung Galaxy Note 5 screen turn on?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 03-13-2017, 07:17 PM
  4. I am attempting to hard reset my LG V10 and it won't work
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-13-2017, 05:15 PM
LINK TO POST COPIED TO CLIPBOARD