1. milleniumdroid's Avatar
    My phone (Alcatel Idol X+) is having some odd issue as follows:

    1) Extremely sluggish 3G. Cannot get above 0.16Mbps on download. Putting the SIM in another device gives high speed, so something is probably wrong with my phone. Is there any way to fix this unfortunate issue? My network provider thinks that the issue is either in the SIM card (obviously it is not, according to my tests) or the phone itself.

    2) Occasional spontaneous restarts happened 3 times in last 6 months. First time it happened after I unplugged that charger from the phone. I cannot remember what happened the second time, but the third reboot happened when I opened opera mini a few weeks ago. After rebooting, everything would work just fine. I suspect a soon-to-happen hardware failure but am not 100% sure.

    I am thinking about getting a new phone at some point, but I would still like to get some more life out of my existing one. Any help would be hugely appreciated.
    12-29-2017 07:14 AM
  2. RumoredNow's Avatar
    I'd do a factory reset and DO NOT restore from backup afterward. Start fresh with the "clean install" and see how it runs. A PITA to be sure, but the best way to flush out any software anomalies.
    12-29-2017 07:23 AM
  3. Rukbat's Avatar
    1. It still could be in the SIM area. Your phone may have a bad SIM port. If another SIM also gives you slow speed, it's the phone.

    2. The phone is 3-1/2 years old. It's probably time for a new battery. Unfortunately that means a trip to the repair shop, so it might not pay.

    (And if you're going to do a factory reset, see Backing up an Android Device.)
    12-29-2017 04:22 PM
  4. milleniumdroid's Avatar
    My phone will be 3 years old at the end of January and the battery is still lasting pretty long (heavy gaming takes 1% of battery each minute). I do have a damaged unused secondary sim port. Would that cause 3G slowdowns? The slow 3G issue, which is far more irritating than an occasional reboot every 3 months, started last fall (shortly after I got this phone as a hand down from my father). I had enabled a setting in Mediatek EngineerMode called "Mobile data service prefered". It instantly tripled my 2G and 3G download speeds and I almost exploded from joy, only to experience massive slowdowns a few days later. I tried disabling the option, but I kept getting crappy connection speeds. My father thinks that the cell provider may have blacklisted my phone by IMEI number and throttled down my speeds. I personally think that his assumption is a bit of a stretch, but not impossible. Could that weird setting have damaged my hardware by any chance?
    12-31-2017 01:54 PM

Similar Threads

  1. annoyed with my ipad from rca voyagar 7
    By Android Central Question in forum Ask a Question
    Replies: 7
    Last Post: 12-30-2017, 06:35 AM
  2. The ear phone is
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-29-2017, 04:58 PM
  3. Can I sell a leases I phone 8 plus from sprint while still owing on the device
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 12-29-2017, 04:27 PM
  4. phone shuts down at 70%
    By Vkiiy in forum Ask a Question
    Replies: 0
    Last Post: 12-29-2017, 06:57 AM
  5. I have nokia 2 android phone its not possible to login
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-29-2017, 06:23 AM
LINK TO POST COPIED TO CLIPBOARD