07-24-2017 04:52 AM
35 12
tools
  1. mvasquez009's Avatar
    Ok so when I turn my tv to the input that it's plugged into my tv says ready to cast so say I go into YouTube play a video then decide to go into the chrome cast app I downloaded through Google play it tries to search for chrome cast devices that are on my wifi network but it can never find it? Then I get a screen on my phone that says can't find any connected chromecasts on your networks even though I'm still able to cast things

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
    08-11-2013 10:50 PM
  2. icebike's Avatar
    Encountered this same problem for the first time today.
    Its worked perfectly up to now.
    No clue what went wrong.
    Powered off chromecast and rebooted, still nothing.

    Wait, per another thread, i rebooted the wifi router and Bam, it works.
    08-12-2013 02:37 AM
  3. mvasquez009's Avatar
    Thanks I'll give it a try.. I'm using an apple airport extreme.

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
    08-12-2013 09:06 PM
  4. Farish's Avatar
    Thanks I'll give it a try.. I'm using an apple airport extreme.

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
    Are you on the 5ghz network, that won't work and will cause you issues. I had to connect to my 2.4ghz network to program everything.
    08-12-2013 09:54 PM
  5. Fres9056's Avatar
    Sorry bump an old thread but I finally got my chromecast after months of back order and now I wish I never got it. I am not sure how to switch my wifi from 5ghz to 2.4ghz but I have the same problem. Chromecast says ready to cast on tv but none of my devices can find it, Google chrome on my laptop, my iPad, nor my nexus 7. After 10 minutes or so of searching for chromecast over and over again, one device may finally find it and start working but that only if I'm lucky. What am I doing wrong? Or is this just a horrible product?
    09-12-2013 11:59 PM
  6. icebike's Avatar
    Reboot your router.
    Sad to say, this is Google's last resort recommendation.

    Sent from my HTC One X using Tapatalk 2
    09-13-2013 01:05 AM
  7. Devlyn16's Avatar
    Sorry bump an old thread but I finally got my chromecast after months of back order and now I wish I never got it. I am not sure how to switch my wifi from 5ghz to 2.4ghz but I have the same problem. Chromecast says ready to cast on tv but none of my devices can find it, Google chrome on my laptop, my iPad, nor my nexus 7. After 10 minutes or so of searching for chromecast over and over again, one device may finally find it and start working but that only if I'm lucky. What am I doing wrong? Or is this just a horrible product?
    What brand and model router do you have? Perhaps one of us can help you figure it out.

    You may want to run a wi fi analyzer app on a mobile device to check the signal strength by the Chrome cast device.
    09-14-2013 06:02 AM
  8. Farish's Avatar
    Sorry bump an old thread but I finally got my chromecast after months of back order and now I wish I never got it. I am not sure how to switch my wifi from 5ghz to 2.4ghz but I have the same problem. Chromecast says ready to cast on tv but none of my devices can find it, Google chrome on my laptop, my iPad, nor my nexus 7. After 10 minutes or so of searching for chromecast over and over again, one device may finally find it and start working but that only if I'm lucky. What am I doing wrong? Or is this just a horrible product?
    All 5ghz routers have 2 wifi networks for backwards compatible. One should be 2.4ghz the other 5ghz. If you can't tell the difference you need to go into your router's wifi settings to find out.
    09-15-2013 09:50 PM
  9. icebike's Avatar
    If your Chromecast says it is on the network and ready to cast then you Don't have a 5ghz problem.
    The chromecast has already connected to the 2.4 ghz network.

    Your other devices don't have to be on 2.4. They don't even have to be wireless. That is the job of the router.
    Power off your router and power it back on as has been pointed out above.
    That is Google's official solution till they get this fixed.

    Sent from my A700 using Tapatalk 2
    09-15-2013 10:38 PM
  10. KristiK2's Avatar
    I'm having a similar issue and have almost given up on my Chromecast. Sometimes it works and most of the time it doesn't. I get the message that my device cannot connect with my Chromecast because they must be on two different networks. Not sure how it can work sometimes if the network is an issue. I have rebooted my router twice and that did seem to make it work temporarily, but my router is located inconveniently in a closet nook on the second floor and so I can't reboot every time I want to cast. Any other ideas out there?
    09-15-2013 10:52 PM
  11. Farish's Avatar
    I'm having a similar issue and have almost given up on my Chromecast. Sometimes it works and most of the time it doesn't. I get the message that my device cannot connect with my Chromecast because they must be on two different networks. Not sure how it can work sometimes if the network is an issue. I have rebooted my router twice and that did seem to make it work temporarily, but my router is located inconveniently in a closet nook on the second floor and so I can't reboot every time I want to cast. Any other ideas out there?
    What do you mean by two different networks?
    09-15-2013 10:54 PM
  12. KristiK2's Avatar
    Not sure. That is the explanation my phone gives me during set up. It connects to my network (I see my network name pop up on my phone screen), but then after about 15 seconds of spinning, the app says it could not connect to my Chromecast because the two devices may be on different networks that can't communicate. This happens about 80% of the time I've tried to use it. I only have one network.
    09-15-2013 11:00 PM
  13. Farish's Avatar
    Not sure. That is the explanation my phone gives me during set up. It connects to my network (I see my network name pop up on my phone screen), but then after about 15 seconds of spinning, the app says it could not connect to my Chromecast because the two devices may be on different networks that can't communicate. This happens about 80% of the time I've tried to use it. I only have one network.
    What router are you using?
    09-15-2013 11:06 PM
  14. KristiK2's Avatar
    Cisco Valet Plus
    09-15-2013 11:08 PM
  15. Farish's Avatar
    Cisco Valet Plus
    Have you tried setting it up with a pc?
    09-15-2013 11:13 PM
  16. KristiK2's Avatar
    I have a MacBook, but I am 2 OS updates behind for it to work on Chrome. I'm holding off upgrading because I may get a new MacBook soon. I'm just perplexed how it can work and then not work.
    09-15-2013 11:30 PM
  17. Farish's Avatar
    I have a MacBook, but I am 2 OS updates behind for it to work on Chrome. I'm holding off upgrading because I may get a new MacBook soon. I'm just perplexed how it can work and then not work.
    Well the cisco valet does offer a guest network feature but I am not sure if that is the actual problem or a wireless signal issue. If the Chromecast is far from the router, this would happen also as the signal fluctuates especially with interference from other channels.

    One other suggestion is if possible change the channel of your router to 9 or greater(up to 11 is the option). But it may not work that great still.
    09-15-2013 11:34 PM
  18. KristiK2's Avatar
    Thanks for the suggestion. I will definitely give it a shot!
    09-15-2013 11:52 PM
  19. KristiK2's Avatar
    FWIW, my Chromecast only seems to work immediately after rebooting my router. After a day or two, it can't communicate over my network. Hm.
    09-17-2013 12:22 AM
  20. icebike's Avatar
    FWIW, my Chromecast only seems to work immediately after rebooting my router. After a day or two, it can't communicate over my network. Hm.
    Its a known bug. Google is working on it.
    Some say unplugging the power to chromecast when not using it prevents having to reboot the router.
    Whichever is easier.

    Sent from my A700 using Tapatalk 2
    Tanooki2 likes this.
    09-17-2013 12:36 AM
  21. Donald ORourke's Avatar
    my computer and tv connect fine with chromecast but my smart phone just says it si ready to cast and stops working there
    11-12-2013 03:42 PM
  22. 914werke's Avatar
    Its a horrible product!: mad:
    12-27-2013 12:49 AM
  23. Cristian Solano-Cordova's Avatar
    I found that making sure my router was on the same channel instead of on automatic helped. I changed mine to 11 and it instantly showed back up.
    02-23-2014 11:47 PM
  24. MS711's Avatar
    +1 - It was maddening seeing it connect to the network, but the ipad and the android couldn't see the chromecast. Set the channel manually and there it was!
    04-05-2014 08:23 AM
  25. thefull1's Avatar
    +1 from me too! Set the channel manually and bosh! Connected straight away...tvm
    04-05-2014 03:59 PM
35 12

Similar Threads

  1. How can i disable that annoying increasing ringtone sound
    By cookie_moster_84 in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 04-21-2016, 02:06 PM
  2. How can I root my 4.3 nexus 4 on a Mac?
    By Chetan Takyar in forum Nexus 4 Rooting, ROMs, & Hacks
    Replies: 7
    Last Post: 09-02-2013, 09:07 AM
  3. Stock Android messaging app?
    By neonworm in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 4
    Last Post: 08-23-2013, 08:00 AM
  4. No casting icon in Netflix app!!!
    By mvasquez009 in forum Google Chromecast
    Replies: 4
    Last Post: 08-13-2013, 08:34 AM
  5. Replies: 6
    Last Post: 08-12-2013, 08:34 AM
LINK TO POST COPIED TO CLIPBOARD