1. eelmcd's Avatar
    Hi guys

    The problem I am having is weird. I have not been able to find anybody who has had something even close to it. Lets see if I can explain it correctly.

    Youtube works through Chromecast no problem. Netflix however does not. What seems to be happening is when I try to cast Netflix, the computer, or phone, or whatever I am using at that time disconnects from the wifi network, and tries to connect to the Chromecast network, which shows up in my wifi selection on my phone or laptop. I have not been able to figure why this is, or how to fix it. If any of you understand what I am saying here, maybe you can help me out.

    Thanks!
    09-03-2013 09:39 AM
  2. Scott Kenyon's Avatar
    Use your devices to "forget" the Chromecast network. I mean the direct wifi connection to the Chromecast, not your home wifi. Try after that.
    eelmcd likes this.
    09-03-2013 09:47 AM
  3. eelmcd's Avatar
    I tried this with my android device but it didn't seem to work. The wifi only disconnects when I get on netflix and press the "cast to tv" button. It loads for a second like it's going to work, and I see it loading on the TV also, but then the wifi disconnects and nothing happens. Then I go to my wifi screen on the phone and it shows that it is trying to connect to the chromecast wifi. It only does this at my girlfriends house though. At my house it worked fine. She has a D-link router. I don't know the exact model though.
    09-03-2013 11:07 AM
  4. Scott Kenyon's Avatar
    Block the network notification for it, maybe?
    eelmcd likes this.
    09-03-2013 01:53 PM
  5. KGauss's Avatar
    I have the exact problem and I have a D-Link router (WBR-1310).


    K
    09-04-2013 03:02 PM
  6. eelmcd's Avatar
    Unfortunately blocking network notifications and forgetting the network does nothing. It just comes back and disconnects either way. This is what I see. As you can see it is connecting back to my wifi, after disconnecting and attempting "Andrea's Chromecast." I don't know what else to do here.

    EDIT: I have a D-Link WBR-1310. Same as KGauss.
    09-04-2013 05:06 PM
  7. Scott Kenyon's Avatar
    I cannot replicate this, so I cannot help you diagnose it. I'm very sorry I don't have a better suggestion. If either of you have another router laying about, maybe give it a shot and see what happens?
    09-04-2013 05:36 PM
  8. Devlyn16's Avatar
    Ok Perhaps we should start from basics: Are you sure you have the latest version of the Netflix app? The latest version of Firmware on the Chromecast device? Does your router have all firmware updates? i poked around the D-Link site and it appears the WBR-1310 has been phased out. All support links are dead ends. I pulled up a PDF manual on line to see if there was a limited number of wi-fi connections and came across this bit "If you are using Xbox, Playstation2 or a PC....." since the Manual mentions Xbox and PS2 instead of Xbox 360 and PS3 and we are 2 months away from the launch of the XBox One and PS4 I have to wonder if you might be better served by a newer Router.

    the Cnet specs : D-Link WBR-1310 Wireless-G Router Specs - Routers - CNET Reviews indicate MAC filtering is possible so IF this is enabled try please test it with Mac Filtering OFF.

    What android device are you using type running which version of the OS? Likewise what type of laptop running which OS?

    have you reset using the reset button and repaired the chromecast [try giving it a new name to make sure]?
    eelmcd likes this.
    09-05-2013 12:22 PM
  9. KGauss's Avatar
    Ok Perhaps we should start from basics: Are you sure you have the latest version of the Netflix app? The latest version of Firmware on the Chromecast device? Does your router have all firmware updates? i poked around the D-Link site and it appears the WBR-1310 has been phased out. All support links are dead ends. I pulled up a PDF manual on line to see if there was a limited number of wi-fi connections and came across this bit "If you are using Xbox, Playstation2 or a PC....." since the Manual mentions Xbox and PS2 instead of Xbox 360 and PS3 and we are 2 months away from the launch of the XBox One and PS4 I have to wonder if you might be better served by a newer Router.

    the Cnet specs : D-Link WBR-1310 Wireless-G Router Specs - Routers - CNET Reviews indicate MAC filtering is possible so IF this is enabled try please test it with Mac Filtering OFF MAC filtering was already off .

    What android device are you using type running which version of the OS? Likewise what type of laptop running which OS? Windows 7 on PC

    have you reset using the reset button and repaired the chromecast [try giving it a new name to make sure]? Yes and Yes
    09-05-2013 02:19 PM
  10. SnicersX's Avatar
    I am having this same exact issue. I reset the Chromecast and reconnected to my Wireless network. I can stream YouTube as well as my chrome tabs and my entire desktop, just not Netflix. Back to the HDMI for now, anyone have any luck yet?
    09-05-2013 07:01 PM
  11. eelmcd's Avatar
    After doing some research on the router, it is very old and I have considered replacing it. It's unfortunate that that has to be the fix for this, but I haven't found any other way. I am running on a Droid Razr Maxx with Dirty Unicorns ROM running android version 4.2.2. The laptop is a Dell Inspiron running Windows 7. Same as KGauss, I have also factory reset Chromecast multiple times to no avail. I will probably be replacing the router soon.
    09-05-2013 07:32 PM
  12. eelmcd's Avatar
    I am having this same exact issue. I reset the Chromecast and reconnected to my Wireless network. I can stream YouTube as well as my chrome tabs and my entire desktop, just not Netflix. Back to the HDMI for now, anyone have any luck yet?
    Do you also have a d'link WBR-1310? The three people I've seen on the internet that I could find that have this same problem, also have this router.
    09-05-2013 07:33 PM
  13. SnicersX's Avatar
    Do you also have a d'link WBR-1310? The three people I've seen on the internet that I could find that have this same problem, also have this router.
    I have a Linksys E1000 v2.1 with DD-WRT custom firmware (Firmware Version DD-WRT v24-sp2 (05/03/11) mini - build 16968M NEWD-2 K2.6 Eko). It can't be the router because my Netflix was working and stopped later, thus the router is fine. Seems to me the the Chromecast might have a bug.
    09-05-2013 11:03 PM
  14. KGauss's Avatar
    After doing some research on the router, it is very old and I have considered replacing it. It's unfortunate that that has to be the fix for this, but I haven't found any other way. I am running on a Droid Razr Maxx with Dirty Unicorns ROM running android version 4.2.2. The laptop is a Dell Inspiron running Windows 7. Same as KGauss, I have also factory reset Chromecast multiple times to no avail. I will probably be replacing the router soon.

    Well, I upgraded my firmware on the D-link to 2.02 AND IT'S FIXED.
    Scott Kenyon, Devlyn16 and eelmcd like this.
    09-06-2013 11:48 AM
  15. Scott Kenyon's Avatar
    Well, I upgraded my firmware on the D-link to 2.02 AND IT'S FIXED.
    So now we know it's the router.

    Pro Tip:
    Always keep your router updated to the latest firmware.
    eelmcd likes this.
    09-06-2013 12:22 PM
  16. eelmcd's Avatar
    This is great. Any info on where you got the update? I checked dlinks website.. Got nothing but dead links.

    EDIT: After searching around I have found the correct firmware update. I will update this post when I get back to my girlfriends house as to whether it worked or not. Thanks for all the help you guys have given.

    Posted via Android Central App
    Scott Kenyon likes this.
    09-08-2013 07:28 PM
  17. eelmcd's Avatar
    Problem is solved thanks to the firmware update.. Thank you guys for all of the help.

    Posted via Android Central App
    Scott Kenyon likes this.
    09-09-2013 05:58 PM
  18. KGauss's Avatar
    Problem is solved thanks to the firmware update.. Thank you guys for all of the help.

    Posted via Android Central App

    Glad it worked out for you.

    Thanks to all.
    09-10-2013 03:56 PM
  19. John Tam's Avatar
    I have not been able to connect my Chromecat to my Dlink Router WBR1310 Version B1, The Chromecast got the four digit ID & saw my network then the Chromecast wants to get an update but it just sit trying to get an update never got it. ChromeCast keeps circling on the TV screen trying to update for 1 hour without doing anything. Can you please help to at least get my ChromeCast working. Thank You
    12-05-2014 12:00 PM
  20. John Tam's Avatar
    I have not been able to connect my Chromecat to my Dlink Router WBR1310 Version B1, The Chromecast got the four digit ID & saw my network then the Chromecast wants to get an update but it just sit trying to get an update never got it. ChromeCast keeps circling on the TV screen trying to update for 1 hour without doing anything. Can you please help to at least get my ChromeCast working. Thank You
    12-05-2014 12:24 PM
  21. trippymanni's Avatar
    could you provide the source site, where you got the firmware. I tried doing the same but mine still isn't working
    12-15-2014 05:20 AM
  22. YokoOroZora's Avatar
    Hi guys

    The problem I am having is weird. I have not been able to find anybody who has had something even close to it. Lets see if I can explain it correctly.

    Youtube works through Chromecast no problem. Netflix however does not. What seems to be happening is when I try to cast Netflix, the computer, or phone, or whatever I am using at that time disconnects from the wifi network, and tries to connect to the Chromecast network, which shows up in my wifi selection on my phone or laptop. I have not been able to figure why this is, or how to fix it. If any of you understand what I am saying here, maybe you can help me out.

    Thanks!
    06-18-2016 09:20 PM
  23. YokoOroZora's Avatar
    I have had the exact same problem... Uninstall the Netflix app and then reinstall again. Be sure to install the most recent version.
    If you have an app that you use to clean junk files from your device, it may be making changes to the registry and causing this problem to occur.
    06-18-2016 09:24 PM

Similar Threads

  1. HTC One and Microsoft Exchange issues
    By mperson007 in forum Verizon HTC One
    Replies: 9
    Last Post: 09-13-2013, 03:54 PM
  2. I just made and ADB and Fastboot installer
    By ajua in forum HTC One Rooting, ROMs & Hacks
    Replies: 2
    Last Post: 09-10-2013, 06:17 PM
  3. Power Problem
    By CFH MaelStrom in forum Sprint Galaxy Note 2
    Replies: 6
    Last Post: 09-10-2013, 09:43 AM
  4. New Nexus 7 Battery/Heat Problems
    By Winterswind in forum Google Nexus 7 Tablet (2013)
    Replies: 4
    Last Post: 09-04-2013, 06:20 AM
  5. problem in downloading apps from google play
    By Amir Justin in forum General News & Discussion
    Replies: 2
    Last Post: 09-03-2013, 04:51 PM
LINK TO POST COPIED TO CLIPBOARD