1. Trees's Avatar
    I've had a new generation Chromecast since late last year. Have cast many movies from my Note 5 without problem. Prior to that had the 1st generation Chromecast connected to the same TV. Hadn't used the new one in a few weeks until last night. Rented a movie from Google Play, and then tried to cast that movie from my Note 5, but no Chromecast icon was available. That was strange since I hadn't changed anything.

    Went to Chromecast app and it did not see the Chromecast even though I could see it showing up fine on my network. Tried the same thing from my Windows laptop via Chrome browser extension. Still couldn't find the Chromecast. Tried power cycling Chromecast, and relevant troubleshooting steps as suggested by the Chromecast app/browser extension, but no luck. Finally did a factory data reset (FDR), and that was successful at least to get the Chromecast accessible.

    Setup Chromecast and chose the default settings and the new random name that is generated after the FDR. Successfully completed the setup steps, but was still not able to connect to the Chromecast (made sure that I carefully followed the steps in the proper sequence to connect/reconnect to the Chromecast's open WiFi broadcast network, and then back to my home WiFi network).

    I finally gave up after about 30 minutes and watched the rented movie via my laptop's Chrome Google Cast extension. Worked well. Did no further troubleshooting or try to connect to Chromecast.

    This morning I fired up the Google Cast extension and it immediately connected to the Chromecast. Tried the same from my Note 5, and casting worked perfectly as it should have last night before I had to embark upon all of the troubleshooting, FDR, and then more troubleshooting.

    So, sharing the above in the event anyone else has recently encountered a "disappearing" Chromecast that was working perfectly fine, and on its own just decided to disappear.
    srkmagnus likes this.
    01-23-2016 09:46 AM
  2. srkmagnus's Avatar
    That's for sharing that tid-bit. It's a little odd that it would do that. Most often a reboot or even a reset of the device will fix the issue(s). Have you tried rebooting the router as well? It's worth a shot and seems to be the last thing to try if it disappears again before sending it back for replacement.
    Trees likes this.
    01-23-2016 09:51 AM
  3. Trees's Avatar
    Yes it was strange. I did reboot the router/WiFi earlier this morning while my end users (family) were still asleep. It's possible the restart did the trick, and although one of the Chromecast troubleshooting steps does mention restarting router, I couldn't do that last night as I would have been "in trouble" for interrupting everyone's streaming video and YouTube sessions.

    I will also say that I know technology isn't perfect, but it seems odd that I have to restart my router/WiFi to get one device (Chromecast) to "appear" (assuming that was the "fix" to get Chromecast to appear again) when all of the other devices in my home network connect and stay connected without requiring a router/WiFi reboot.
    01-23-2016 09:59 AM
  4. Jeff Solo's Avatar
    Interesting. I've not encountered this with the new one. However my old 1st gen chromecast did occasionally disappear.

    Out of curiosity do you un plug your chromecasts when your not using them? Or do you leave them in 24/7?
    I always unplug mine, as I'm nervous about it getting hot. It often feels warm after being on for a short time.
    01-23-2016 10:15 AM
  5. jhilker's Avatar
    I also had that issue with the 1st gen Chromecast, but haven't seen it occur with the 2nd gen, which I've had since late December. I have never unplugged my Chromecast.
    Jeff Solo likes this.
    01-23-2016 11:12 AM
  6. Trees's Avatar
    I don't unplug the Chromecasts, but agree it can get a bit warm when the TV is on. The TV that I've used the 1st and 2nd generation Chromecasts with has minimum several feet of clearance in all directions, so there is decent airspace for the TV and Chromecast heat to dissipate.

    Never had the 1st generation Chomecast disappear, but did have a few movies encounter buffering or getting stuck at a certain scene. Whether or not that was just an intermittent recurring (for those movies) Play Movie backend infrastructure problem, something along the internet between my home network and the Play infrastructure, or the 1st generation Chromecast; I'm not sure.

    Still have the 1st generation Chromecast, and once I figure out where to use it, will monitor it for "dissappearing" as that could point to something in my home network, or just a common behavior across the 1st and 2nd generation Chromecasts.
    01-24-2016 08:51 AM
  7. donc13's Avatar
    You have to completely close the Chromecast application (remove from memory) and then restart it for it to find the newly reset chromecast.


    Best way to do that is to reboot your phone.
    01-28-2016 02:25 PM
  8. Trees's Avatar
    You have to completely close the Chromecast application (remove from memory) and then restart it for it to find the newly reset chromecast.


    Best way to do that is to reboot your phone.
    Tried that last night. Same problem as I initially posted about happened again. Tried removing the Chromecast from TV and after a minute plugged back in. No Chromecast. Then tried turning off/on WiFi on my Note 5, and after that didn't work, restarting Note 5 - but no Chromecast. Tried accessing Chromecast from Chrome on Windows laptop, same problem.

    Didn't feel like more troubleshooting, so just watched the rented movie I intended to watch on the Chromecast on my laptop. When I can later today will try the router reboot trick to see if that helps the Chromecast "reappear". If not, I'll go back to the 1st generation Chromecast or Apple TV.
    02-06-2016 08:18 AM
  9. Trees's Avatar
    After more troubleshooting with the 1st generation Chromecast (basically repeated all of the steps I tried previously above), still couldn't get that to connect to the home network. Was able to connect the Apple TV with zero problems. Finally restarted the router/WiFi access point and then put the 2nd generation Chromecast back into the TV. Chromecast app on the Note 5 instantly recognized the 2nd generation device.

    So, not clear why the Chromecasts have started "disappearing" recently, when they were perfectly fine for months (year + in the case of the 1st generation). I'm not getting complaints from other users about not getting on WiFi. At least there appears to be a workaround (rebooting router/WiFi access point). While troubleshooting I also found the Chromecast app for Windows. Good to have that as option.
    02-06-2016 05:46 PM
  10. I Can Be Your Hero's Avatar
    I had that happen to me all the time with the 1st gen Chromecast and it was very frustrating. Pretty much every time I wanted to cast something, there wouldn't be a cast button appearing on the app and when I'd go to the Chromecast app, it wouldn't detect a Chromecast device. I chalked it up to the device getting too hot and 'overheating', so I'd pull it out of the TV, throw it in the freezer for a minute or two then pull it out and put it in the TV again. Pretty poor fix, but it'd get it going again.

    With the 2nd gen I haven't had this issue. I believe they're using extra thermal paste to remedy the overheating issues, but it could still occur.

    OP if it happens again, try my method. Pull it out and throw it in the fridge for a couple of minutes then try again.
    Trees likes this.
    02-21-2016 09:14 PM

Similar Threads

  1. Does Moto X 2nd gen charge over OTG?
    By neroneuman in forum Moto X
    Replies: 3
    Last Post: 01-25-2016, 04:00 AM
  2. Replies: 0
    Last Post: 01-20-2016, 06:26 PM
  3. Replies: 5
    Last Post: 01-20-2016, 03:02 PM
  4. MOTO X (2nd gen) voicemail keypad
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-20-2016, 12:25 PM
  5. Does Moto X 2nd Gen support charging while using USB OTG ?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-19-2016, 10:16 PM
LINK TO POST COPIED TO CLIPBOARD