1. Scottrc35's Avatar
    My rooted device was connecting to my DSLR Camera (Olympus E510) yesterday via USB OTG cable, but stopped. Now when connecting the gallery app opens to a black screen and locks up. The camera is not at fault because it connects to other devices just fine. I think I need a Terminal Wiz to tell me how to reset the USB settings or something on the android device.

    My camera has 4 settings to use to connect to a PC/Device, Storage mode, MTP mode, Print mode, and easy print mode. What would normally happen is I would put my camera in MTP Mode and plug it in my android device, gallery would open with all the photos on the devices memory card, and I would be able to view the photos and select ones to import. It worked fine yesterday, But now when connecting via USB in MTP mode the gallery app opens and then either sits there on a black screen, or it loads gray squares where the albums normally display. if I put it in storage mode android tries to mount the XD card, then reports that it has an unsupported file system (it is formatted as FAT)

    I have tried:
    • Doing a Data wipe, cache wipe, and delvik cache wipe.
      Flashing a different rom AOKP
      Re-formatting the camera memory card.



    Please help as I really need to have this functionality.
    Thanks!
    04-02-2013 09:36 AM
  2. Devlyn16's Avatar
    I know it seems silly but check on the Nexus

    Settings>storage>Menu [three dots]> Usb

    is it set to connect as MTP or PTP.
    04-03-2013 10:20 AM
  3. Scottrc35's Avatar
    Thanks for the reply, I'll try that, in a little bit can't get to the camera until lunch, I unrooted the tablet and did a factory reset and the problem is still present, I am able to connect to it through USB from my computer VIA Fast boot, but I did just notice the tablet is not connecting to my PC via MTP, the tablet displays "Connected as Media Device" but is not showing up in my PC, when connecting as PTP, it opens a folder on the PC.

    I have also tried changing USB debugging on and off, but that didn't make a difference.

    [EDIT] I was able to get it to connect to my PC as an MTP Device, That problem was that windows was trying to load the ADB Drivers, I removed them and that part is working now.

    [Edit] I am wondering, what information is stored on android and where when a USB device is plugged into it? Examples being drivers or USB profiles for the device plugged in, I think what might be going on is the driver is currupted and needs to be deleted from the android device, but the factory rest did not do the job.
    04-03-2013 10:51 AM
  4. Scottrc35's Avatar
    Checked that I am still having the same Issue :-(
    04-03-2013 12:40 PM
  5. Mahir Shajal's Avatar
    my phone is huawei y9 and my camera is nikon d7100 but they are not connect in usb cable .when i connect usb cable it will be blank .i start MTP or PTP bt it is not responds .what is the prblm in this please tell me
    08-06-2018 06:40 AM

Similar Threads

  1. Phone Not Connecting to Computer Via USB - HELP!!
    By koolx in forum General Help and How To
    Replies: 10
    Last Post: 07-08-2014, 12:28 PM
  2. Can not connect to camera error fix?
    By gitit20 in forum Motorola Xoom
    Replies: 5
    Last Post: 11-05-2013, 05:42 AM
  3. Will not connect to android file transfer on Mac
    By manbearpig073 in forum US Cellular Galaxy SIII
    Replies: 2
    Last Post: 09-02-2012, 06:39 PM
  4. can not connect to computer via USB after unroot
    By blackwaterstout in forum LG Optimus S
    Replies: 8
    Last Post: 06-20-2012, 09:27 PM
  5. Connect Android (HTC Evo) to Canon DSLR Camera
    By CouchFisher in forum Android Apps
    Replies: 9
    Last Post: 08-31-2010, 08:58 AM
LINK TO POST COPIED TO CLIPBOARD