1. chris Last Name's Avatar
    Hi All,

    I am hoping you can help. My nexus 10 is not finding any update. It is currently running on Android 4.2, yet I see on the web that a roll out of Android 4.4.2 is suppose to be well underway. When I try to update android just tells me that it is up to date. What version of android should my Nexus 10 be on? I am in the UK by the way. Even if I should not yet be on Android 4.4.2 should I still be on Android 4.2 at the moment?

    I ask this because I am having problems with several apps wanting to update, but when I let them update through play store the new version of the app just crashes and I get a message like "unfortunately google play music has stopped" or whatever app is trying to run. This happens even if I am not running the app so that I get numerous pop-up errors for several apps. These errors then repeat every few minutes. You tube is also affected if I let it upgrade to what play thinks is the latest version. I tried talking to Google UK about this, but they just kept insisting that I should wait for an OTA update in the next few days (but I have a strong feeling that the tablet will never pick up the OTA as the OS installation seems to have been scrambled when a previous samsung authorised repair team re-installed the OS with something called ASOP_manta) , but the guy didn't know what version of Android I should be on!! So I was not inclined to trust his judgement, nor did he have any explaination as to why apps keep updating to a version that is incompatable with Android 4.2, he just told me "that is something for the app team to deal with". Frankly I am really dissappointed with the google UK support. This was all the more frustraiting as the Google US team guy I had spoken to earlier said I needed to RMA the tablet as faulty for a replacement with a new one. Sorry for the rant.
    Anyway does anyone know what version of android I should be on currently in the UK even if I haven't had the latest 4.4.2 roll out yet (which google told me has been heavily delayed).
    01-08-2014 06:24 PM
  2. patruns's Avatar
    Yes, you should have Kit Kat by now in the UK. Manta is just a code name for the Nexus 10. It is possible something got whacked in the OS. I would suggest you back up what you need (movies, pictures, etc) and do a factory reset on your device. (Make sure it is fully charged.)
    01-09-2014 09:54 AM
  3. Ant the ant's Avatar
    I'm having the exact same issue, did you resolve it in the end? I've tried a factory reset and still no joy. Google support are being equally useless too. Most annoying thing of all this a new tablet Google sent to replace a previously broken one, its been stuck on 4.2 the whole time I've had it, and all the Google apps keep crashing, as you describe. Can anyone help??
    08-11-2014 01:29 PM
  4. mavrrick's Avatar
    If you are stuck on 4.2 my suggestion would be to do a little research on loading the factory image of 4.4.4 from Googles website. It isn't that complicated, and would certainly give you a clean load of the OS. Just make sure you get find some fairly clear directions. I loaded the factory image at one point, and though it looked complicated it was much easier then I anticipated.

    The link to the factory images is https://developers.google.com/android/nexus/images
    crxssi likes this.
    08-12-2014 03:42 PM

Similar Threads

  1. HELP URGENT LG G2 Stuck IN TWRP, Not Showing In ADB Devices
    By jbadz3 in forum General Help and How To
    Replies: 2
    Last Post: 01-21-2014, 07:25 AM
  2. Can't get iMessage out of my Android world. Help!
    By ezridermn in forum Verizon Samsung Galaxy S4
    Replies: 9
    Last Post: 01-11-2014, 10:08 AM
  3. Replies: 2
    Last Post: 01-09-2014, 11:21 AM
  4. VZW GN refugee's report on Nexus 5 on AT&T
    By bjrosen in forum Verizon Galaxy Nexus
    Replies: 1
    Last Post: 01-08-2014, 06:08 PM
  5. my magazine updated itself???
    By imnewtoandroid in forum Legacy Android & Other OS's
    Replies: 2
    Last Post: 01-08-2014, 04:32 PM