1. tommymonk's Avatar
    I received my Nexus 4 whilst at work yesterday and got everything set up just how I like it using the wifi.

    When I got home and connected to my Wifi I started having all manner of connectivity issues.
    Through Chrome I maybe get 1 in 5 requests succeed, whereas HSPA is rock solid.

    My Wifi router (Edimax BR-6574N running DD-WRT) has always been rock solid.

    I have tried all sorts of change to the mode and security of the wifi to try and diagnose the issue, with no luck.

    We have 2 x Laptops, 1 x Desktop, 2 x Nexus 7 (Running JB 4.2) all using the Wifi without issue.

    Interestingly my Wife's new Nexus 4 is also having the exact same issue. I have also tried a factory reset.
    I have a new router on order to try and rule out a crazy incompatibility.

    Has anyone else been having this type of issue whilst on Wifi ?
    11-17-2012 10:30 AM
  2. Kaenon's Avatar
    I am posting this from my nexus 4 while on my WiFi network.
    Sorry I can't help you.
    11-17-2012 11:14 AM
  3. Ziptied's Avatar
    Do a hard factory reset.

    Sent from my Nexus 4 using Android Central Forums
    11-17-2012 11:19 AM
  4. tommymonk's Avatar
    Ok I'll give it a go, not sure it will help seeing as though Wife's is the same.
    11-17-2012 11:24 AM
  5. tommymonk's Avatar
    Do a hard factory reset.

    Sent from my Nexus 4 using Android Central Forums
    How do you hard reset the N4 ?
    When I select "Recovery mode" I just land on a "No command." screen
    11-17-2012 11:34 AM
  6. still1's Avatar
    just forget wifi network and add network again
    11-17-2012 11:40 AM
  7. tommymonk's Avatar
    I already tried removing and adding the network, as well as playing with the advanced settings
    11-17-2012 11:42 AM
  8. molomolo's Avatar
    I have pretty the same Wifi issue on my Nexus 4.
    I don't have internet through wifi router at home on Nexus 4. The wifi notification icon shows the signal bars (but most time it's in gray color - means disabled instead of blue - active).
    Other devices - android phones, tablet, laptops and xbox use the same wifi with no problem.

    On the other had - I tried the neighborhood wifi connection and at work office - it works fine.

    I had a call with Goole play support - the rep suggested to restart the wifi router. Will do this later today.

    So far it seems it's particular issue with wifi router and nexus 4. I didn't have such kind of wifi issue with previous devices under the same wifi coverage(I had dozens of android phones before).

    11-20-2012 04:14 PM
  9. jlk_250's Avatar
    I'm having what may be the same problem. Similar anyway. Just got my N4 today and can connect to my home wifi but the data is coming so slow that everything times out. I'm talking like 5 minutes to partially load a web page. My old phone, my wife's phone, my laptop, our Wii, ipad, PC, all work normally. I took the N4 to a coffee shop and it connected just fine with normal data speeds. Google support has no idea. Sent an email to our router mfg but won't get a reply until tomorrow at the earliest. Actiontec Q1000, for the record.
    11-21-2012 12:26 AM
  10. yokken's Avatar
    I'm running DD-WRT on a Buffalo router. My Nexus 4 does speed tests at my MAXIMUM bandwidth, which is awesome. However, the Play Store and a few other apps completely time out. It takes 2-3 minutes after pressing the "Install" button on an app for it to reset and actually start downloading. Works fine on everything else I've tried. Very disappointing.
    11-21-2012 07:16 PM
  11. tommymonk's Avatar
    Just an update, I have now set up my new Router (Asus RT-N66U) and installed DD-WRT.

    Mine and my Wife's Nexus 4 are now rock solid on wifi both 2.4Ghz and 5Ghz

    Looks like it was some strange incompatibility with my Edimax router
    11-23-2012 03:50 PM
  12. yokken's Avatar
    I want one of those N66Us... they were on sale for $120 yesterday. I'd buy one if I was having ANY other problems with my current router, but at the moment it's just the Nexus having problems.
    11-23-2012 07:08 PM
  13. tommymonk's Avatar
    I want one of those N66Us... they were on sale for $120 yesterday. I'd buy one if I was having ANY other problems with my current router, but at the moment it's just the Nexus having problems.
    Yes they are brilliant routers, I can now utilise my 120Mbps internet for wired devices, my old router could only channel half of that bandwidth.
    11-24-2012 04:45 AM
  14. mattatwar1's Avatar
    We got a Cisco router and my moms nexus 4 works perfectly fine on it (my nexus 4 is on back order)

    Sent from my Galaxy Nexus using Android Central Forums
    11-24-2012 07:38 AM
  15. hankdu's Avatar
    I have issues with the wifi at my girl friend's house: can connect to wifi but the wifi logo changes color quickly from blue to grey, can not download any data. As soon as switching wifi off back to mobile data, it changes back to blue and loads data normally.

    At home the n4 connects to my airport extreme without any problem.

    The same problem as everyone else.

    Sent from my iPad using Tapatalk HD
    11-25-2012 07:33 PM
  16. jlk_250's Avatar
    I had reported a problem earlier in this thread. It got solved today and had nothing to do with the N4 as far as I know. In fact it seems that merely restarting the router made things right. I had thought we had done that right off the bat but I had thought my wife did it and she thought I had done it. Anyway, my N4 connects with no trouble now. (As soon as the problem was resolved we installed a new router I had bought. We never liked the old router anyway and are taking advantage of some features that the new router has. N4 connects to it just fine too.) So, false alarm.
    11-25-2012 08:37 PM
  17. joshuay04's Avatar
    I had a lot of issues with data spotted. Check speedtest.net on HSPA only and check reported speeds. Data works just fine but the app would day I was only getting 12kbs. I think there is an issue with latency timeouts.
    11-26-2012 08:54 PM
  18. oldcrow52's Avatar
    I am having the same problems here also! My mom and I received identical tablets for Christmas. Android 4.0 by Chromo my tablet connects,blue bars and all. My mom says its connected but its bars are grey also. I try to go on google or google play and it says " not connected " and I get some sort of certificate error. I tried every thing i can think of short of resting it. Don't know what to do! When it comes to computers and internet and my mom id swear they were mortal enemies hahaha.
    12-28-2012 11:29 AM
  19. Hubertsng's Avatar
    Well I'm pretty sure it might be the routers problem and the Nexus 4 not being able to identify the router. Since this isn't a one device thing, it has to be something with your router. If the phone can't identify with router or something and the internet will be dodgy. I think.....
    12-28-2012 01:56 PM
  20. GemMoth's Avatar
    My Nexus 4 can't connect to wifi. I called Google, they are replacing it. That's crazy, I've read about people who receive several defective Nexus 4.
    01-06-2013 10:54 PM
  21. Jennifer Burrow's Avatar
    is there any way to connect rooted phone to wii counsel?? when i try an connect it says error.. changed tether.denied=false to true in build.prop but still same error..
    02-08-2013 09:22 AM
  22. Jennifer Burrow's Avatar
    do u kno of a way to connect rooted phone to wii counsel??
    02-09-2013 08:10 PM

Similar Threads

  1. Massive Battery Drain??? Check your WiFi Connectivity
    By Bob61 in forum Droid RAZR MAXX
    Replies: 20
    Last Post: 12-21-2012, 02:38 PM
  2. Gingerbread for Inspire; Massive failure. Yes or No?
    By JoshuaExline in forum AT&T Inspire 4G
    Replies: 12
    Last Post: 10-27-2011, 11:35 PM
  3. Massive failure!
    By MSGTwife in forum New to the Forums? Introduce Yourself Here!
    Replies: 0
    Last Post: 09-24-2011, 01:29 AM
  4. Wifi Tether Status/Info/ App request
    By bigscout79 in forum Android Apps
    Replies: 1
    Last Post: 07-15-2010, 09:18 PM
  5. Request to Admin/Mods
    By licenced in forum Site Feedback & Help
    Replies: 3
    Last Post: 09-21-2009, 10:36 AM