1. Jnorton2724's Avatar
    Hey,

    I'm currently trying out APN settings from xda for my Nexus 4 on at&t after noticing that my speeds were fairly poor with the default APN. XDA settings increased my speeds dramatically; I was getting around 3 to 4 Mbps down with default settings but now I'm getting 8 to 13 Mbps down. I'm fairly new to APN changes and settings but thought I'd post this in case some people are looking for settings with at&t.

    APN settings: [APN][AT&T][MMS][HSPA+] Single APN for HSPA+ Speeds AND MMS - (Updated 9/15) - xda-developers

    EDIT: Let me know if anyone knows about better settings or anything else I need to know.
    Dramer77 and TheNDChief like this.
    11-27-2012 05:18 AM
  2. Nof603's Avatar
    Thanks for posting. I'm also new to changing APN settings and had a general question for anyone here that can answer.. If I was to change these settings from the default "ATT WAP" APN that AT&T set up when I got the new SIM, would AT&T have any problems with this? I would love to get the faster data speeds, but don't want to cause any issues with AT&T. Thanks!
    11-27-2012 09:59 AM
  3. Jnorton2724's Avatar
    Thanks for posting. I'm also new to changing APN settings and had a general question for anyone here that can answer.. If I was to change these settings from the default "ATT WAP" APN that AT&T set up when I got the new SIM, would AT&T have any problems with this? I would love to get the faster data speeds, but don't want to cause any issues with AT&T. Thanks!
    I don't think they can tell if you change the APN or not. I've been using this for alittle bit and nothing has changed with my service, I just get faster data speeds.
    11-27-2012 02:13 PM
  4. Nof603's Avatar
    I don't think they can tell if you change the APN or not. I've been using this for alittle bit and nothing has changed with my service, I just get faster data speeds.
    Sweet! That's what I was looking for. Thanks for the response!
    11-27-2012 07:36 PM
  5. Dramer77's Avatar
    which settings did you use OP?
    11-27-2012 10:15 PM
  6. Lazo7's Avatar
    I have an iPhone 5 and waiting for my Nexus 4 to show up next week. Its my 2nd Android device after getting the Nexus 7 on black friday and really getting to love it. In regards to the APN settings i will followed the above settings. Im also going to be switching between the i5 and N4 every so often. Do i have to mess with Apn setting everytime i put the sim card in the devices? Also after setting the APN settings up for the N4 and when i switch back to the iphone 5 will my LTE work flawlessly?? Thanks for any response
    11-30-2012 05:03 PM
  7. harsubs's Avatar
    Hey,

    I'm currently trying out APN settings from xda for my Nexus 4 on at&t after noticing that my speeds were fairly poor with the default APN. XDA settings increased my speeds dramatically; I was getting around 3 to 4 Mbps down with default settings but now I'm getting 8 to 13 Mbps down. I'm fairly new to APN changes and settings but thought I'd post this in case some people are looking for settings with at&t.

    APN settings: [APN][AT&T][MMS][HSPA+] Single APN for HSPA+ Speeds AND MMS - (Updated 9/15) - xda-developers

    EDIT: Let me know if anyone knows about better settings or anything else I need to know.
    This doesn't work for me. I walked into the AT&T store today and got the phone set up with a new sim. I am moving from a Captivate (3G). The data shows HSPA 10/15, but because the APN is wap.cingular, speedtest craps out. Moving to this APN cuts off my data connection completely. I just chatted with an ATT rep who told me they can't move me to a 4g plan because the billing system will not recognize my device as an "AT&T 4G device". Basically she told me I'm SOL.

    Forgot to add - I did pick a TMO sim as well to test it out and the speeds are outstanding. Seems to be a no-brainer for me -> I'm going to have to move to TMO.
    11-30-2012 06:21 PM
  8. tpd15's Avatar
    This doesn't work for me. I walked into the AT&T store today and got the phone set up with a new sim. I am moving from a Captivate (3G). The data shows HSPA 10/15, but because the APN is wap.cingular, speedtest craps out. Moving to this APN cuts off my data connection completely. I just chatted with an ATT rep who told me they can't move me to a 4g plan because the billing system will not recognize my device as an "AT&T 4G device". Basically she told me I'm SOL.
    Check out this thread;
    http://forums.androidcentral.com/goo...xus-4-att.html

    It explains that you need to get them to put you on a 4G HSPA+ plan, and how to do it. (I had then assign me an Inspire 4G phone).
    11-30-2012 07:39 PM
  9. Jnorton2724's Avatar
    Check out this thread;
    http://forums.androidcentral.com/goo...xus-4-att.html

    It explains that you need to get them to put you on a 4G HSPA+ plan, and how to do it. (I had then assign me an Inspire 4G phone).
    At&t also told me I'm Sol but am using this APN and getting hspa 10 and hspa+15. I've talked to at&t a lot about this and its the same every time

    Sent from my Nexus 4 using Android Central Forums
    11-30-2012 08:37 PM
  10. Dramer77's Avatar
    At&t also told me I'm Sol but am using this APN and getting hspa 10 and hspa+15. I've talked to at&t a lot about this and its the same every time

    Sent from my Nexus 4 using Android Central Forums
    If you can't get them to put you on a 4G data plan post on their Facebook wall, the reps on there are way more helpful
    11-30-2012 08:48 PM
  11. jordanmc109's Avatar
    Running into some problems. I am coming from a AT&T GS3 so I have a LTE plan. I am still getting crappy speeds on the "phone" APN outside, with full bars, with "About Phone" showing HSPA+:15 and "Phone info" showing HSPAP, in an area that AT&T's coverage viewer says had "4G". Screenshots below. Any tips would be great! Thanks!

    12-10-2012 01:17 AM
  12. Jnorton2724's Avatar
    Running into some problems. I am coming from a AT&T GS3 so I have a LTE plan. I am still getting crappy speeds on the "phone" APN outside, with full bars, with "About Phone" showing HSPA+:15 and "Phone info" showing HSPAP, in an area that AT&T's coverage viewer says had "4G". Screenshots below. Any tips would be great! Thanks!

    http://i48.tinypic.com/1zxv1hy.png http://i50.tinypic.com/nd3401.png http://i49.tinypic.com/2rpekxt.png [url]http://i50.tinypic.com/2h3n5ab.png[/IMG}http://i50.tinypic.com/34igyew.png
    Change APN to pta and turn on data roaming. I'm getting decent speeds on an LTE plan ranging from 6 Mbps to 10 Mbps with AT&T.

    Sent from my Nexus 4 using Android Central Forums
    12-10-2012 01:26 AM
  13. Dramer77's Avatar
    I didn't need to put it Pta when I was still on my lte plan... have you tried using s diff server ? Were yo getting better hspa speeds wit another device

    Sent from my Amazon Kindle Fire using Android Central Forums
    12-10-2012 09:00 AM
  14. jordanmc109's Avatar
    Just got 7.73mbps down! That is good enough for me
    12-14-2012 02:42 PM
  15. DMC55's Avatar
    I have the same issue. I called customer service and they claim to have put me on 4G Smartphone Data Plan. The APN settings shown do not work at all for me, all data cut off. I went to the AT&T store today and basically got blown off saying they already have you on 4G Data plan. I really don't want to move to T-Mobile after 15 years of being an AT&T customer and also since I do a lot of international travel, the phone needs to work when I get to where I'm going. Very discouraged.
    01-05-2013 11:41 AM
  16. miketherobot's Avatar
    Awesome, I thought it was odd that I was getting terrible speed on my new Nexus 4 on AT&T. Your post was a lifesaver.
    02-07-2013 06:33 PM
  17. ibbyj's Avatar
    I was having poor data speeds too, maybe 1mbps.

    Now I'm much better off. These results are after following these instructions. Thanks!

    - I did have to call, and ensure I was on the correct plan.

    Sent from my Nexus 4 using Android Central Forums
    Attached Thumbnails at&t APN settings for Nexus 4-uploadfromtaptalk1360331620117.jpg  
    02-08-2013 07:53 AM
  18. nokia4life's Avatar
    I'm not sure what's to expected with h+ but anything over 6 mb should be good its not lte but it will do for me on att sure bit as fast as my iPhone 5 with lte but we knew that right.

    Sent from my Nexus 4 using Tapatalk 2
    Attached Thumbnails at&t APN settings for Nexus 4-uploadfromtaptalk1360384846552.jpg  
    02-08-2013 10:40 PM
  19. Marco Mendoza's Avatar
    This is my speed with my nexus 4. I have the 3gb lte plan. I'm using an imei from an lg nitro HD
    Attached Thumbnails at&t APN settings for Nexus 4-screenshot_2013-02-10-08-22-14.png  
    02-10-2013 10:33 AM
  20. poojaguptagupta's Avatar
    I'm on the smartphone 4g plan and I get around 1.5mbps with all the suggested settings. Would there be a difference in switching to an LTE plan and putting an LTE capable phone's IMEI in AT&T system?
    02-10-2013 12:51 PM
  21. Archerbold's Avatar
    Thank you! My speeds just went from .05 download to almost 12mbps. With the stock settings I was getting faster upload speeds.
    04-02-2013 10:33 AM
  22. LalumpM's Avatar
    IAM TRY
    05-31-2014 01:52 AM
  23. LalumpM's Avatar
    my Nexus 4 at&t apn settings
    Real AT&T APN settings for Nexus 4l
    05-31-2014 01:56 AM

Similar Threads

  1. Apn settings for skyrocket on straighttalk?
    By Ferretmom in forum Skyrocket Rooting, ROM's, and Hack's
    Replies: 9
    Last Post: 10-27-2013, 02:01 PM
  2. AT&T apn settings
    By harrycarry250 in forum Google Nexus 4
    Replies: 22
    Last Post: 01-28-2013, 01:43 PM
  3. apn setting for tmobile 30 unlimited plan
    By iopepper in forum Google / Samsung Galaxy Nexus
    Replies: 2
    Last Post: 07-20-2012, 05:13 PM
  4. at&t apn setting for evo 3d
    By mikearey in forum AT&T
    Replies: 2
    Last Post: 04-13-2012, 11:06 AM
  5. T-Mobile USA APN settings for Data/MMS
    By Sillian Himself in forum G2 Rooting, ROMs, and Hacks
    Replies: 6
    Last Post: 02-26-2011, 03:55 AM
LINK TO POST COPIED TO CLIPBOARD