Live

Black Friday deal team is live right now!

Join our live stream for latest deals

Expand Minimize
  1. Jason Escobar's Avatar
    Someone please help me out with this issue, it's really bugging me.

    I just bought a Nexus 4, I cut my sim card from my old HTC Inspire 4G and the phone worked great. But I have a huge problem, I cannot send nor receive MMS while my wifi is on and my data is off(I always keep it off because I only have 200MB). My Old HTC phone could send and receive pictures via messages when my data was off and only connected via wifi without a problem, so I don't understand what is going on! Then I contact AT&T and get me set different APN settings and nothing! I reset them to default APN now. Then they tell me that it was weird that my old phone could do that because you HAVE to have data turned on for you to receive picture texts, which is BS. Could someone please help out? Sorry if this has been addressed already as I'm new here and not really phone/Android savvy.
    02-08-2013 03:47 PM
  2. planoman's Avatar
    Can you post screen shots of the APN you are using?


    Sent from my Nexus 7 using Android Central Forums
    02-08-2013 04:17 PM
  3. Greg C's Avatar
    Someone please help me out with this issue, it's really bugging me.

    I just bought a Nexus 4, I cut my sim card from my old HTC Inspire 4G and the phone worked great. But I have a huge problem, I cannot send nor receive MMS while my wifi is on and my data is off(I always keep it off because I only have 200MB). My Old HTC phone could send and receive pictures via messages when my data was off and only connected via wifi without a problem, so I don't understand what is going on! Then I contact AT&T and get me set different APN settings and nothing! I reset them to default APN now. Then they tell me that it was weird that my old phone could do that because you HAVE to have data turned on for you to receive picture texts, which is BS. Could someone please help out? Sorry if this has been addressed already as I'm new here and not really phone/Android savvy.
    Are you using stock or a third party sms app such as Go SMS Pro?
    02-08-2013 04:22 PM
  4. Jason Escobar's Avatar
    Here they are
    Attached Thumbnails AT&T Nexus 4 MMS problem-screenshot_2013-02-08-16-20-47.png   AT&T Nexus 4 MMS problem-screenshot_2013-02-08-16-21-00.png  
    02-08-2013 04:27 PM
  5. Jason Escobar's Avatar
    Using Stock. I realized the problem today when I downloaded GO SMS Pro and tried sending out, and nothing happened. It just gets stuck on Sending...
    02-08-2013 04:30 PM
  6. williams448's Avatar
    Try these APN settings:

    Name: AT&T HSPA+
    APN: Phone
    Proxy:
    Port:
    Username:
    Password:
    Server:
    MMSC:http://mmsc.mobile.att.net
    MMS proxy: proxy.mobile.att.net
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type:
    APN type: default,supl,mms,hipri
    APN protocal: IPv4
    APN protocal: IPv4
    Bearer: unspecified

    MMS is sent through your data. Try turning on your data and sending a MMS. If it works then you know that is the problem.

    Dont delete your current APN settings. Simply create another, so if the new one doesnt work, you can always go back.

    I too have AT&T. When I got my N4, those same settings were on my phone by default. I changed to the settings above, and it works so much faster on At&t's HSPA+ network.
    Aquila likes this.
    02-08-2013 04:37 PM
  7. Jason Escobar's Avatar
    Try these APN settings:

    Name: AT&T HSPA+
    APN: Phone
    Proxy:
    Port:
    Username:
    Password:
    Server:
    MMSC:http://mmsc.mobile.att.net
    MMS proxy: proxy.mobile.att.net
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type:
    APN type: default,supl,mms,hipri
    APN protocal: IPv4
    APN protocal: IPv4
    Bearer: unspecified

    MMS is sent through your data. Try turning on your data and sending a MMS. If it works then you know that is the problem.

    Dont delete your current APN settings. Simply create another, so if the new one doesnt work, you can always go back.

    I too have AT&T. When I got my N4, those same settings were on my phone by default. I changed to the settings above, and it works so much faster on At&t's HSPA+ network.
    Im trying to send picture texts without having to have my data on. Just like I could with my HTC Inspire! I tried your settings and nothing in fact it got worse! It said, "cannot send message. try again when service is available" or something like that
    02-08-2013 04:51 PM
  8. Greg C's Avatar
    Using Stock. I realized the problem today when I downloaded GO SMS Pro and tried sending out, and nothing happened. It just gets stuck on Sending...
    Are you using stock or a third party sms app such as Go SMS Pro?
    02-08-2013 04:55 PM
  9. williams448's Avatar
    Im trying to send picture texts without having to have my data on. Just like I could with my HTC Inspire! I tried your settings and nothing in fact it got worse! It said, "cannot send message. try again when service is available" or something like that
    Did you try turning data on and sending? I bet if you turn it on, you'll be able send all the MMS you want.
    02-08-2013 04:55 PM
  10. Jason Escobar's Avatar
    Are you using stock or a third party sms app such as Go SMS Pro?
    I'm using stock.

    - - - Updated - - -

    Did you try turning data on and sending? I bet if you turn it on, you'll be able send all the MMS you want.
    yes it did send, but I could send MMS with data OFF with my old device! I'm trying to do that again with this one!!! Plus I have only 200 MB so I'm not trying to go over my limit!!
    02-08-2013 04:56 PM
  11. Greg C's Avatar
    Im trying to send picture texts without having to have my data on. Just like I could with my HTC Inspire! I tried your settings and nothing in fact it got worse! It said, "cannot send message. try again when service is available" or something like that
    MMS uses DATA.... SMS doesn't. Turn your data on and it will work. Data MUST be enabled to send MMS.
    02-08-2013 04:58 PM
  12. Jason Escobar's Avatar
    MMS uses DATA.... SMS doesn't.
    So how was I able to send MMS with my data off on my other phone? ...
    02-08-2013 05:02 PM
  13. Greg C's Avatar
    IDK.... I'm just telling you what you need to do to send mms... now... with THIS phone.
    02-08-2013 05:06 PM
  14. Jason Escobar's Avatar
    IDK.... I'm just telling you what you need to do to send mms... now... with THIS phone.
    Damn, that sucks. My battery is gonna get drained a lot LOL. Thanks anyways, good thing is that the Nexus 4 can disable data if it approaches the limit.
    Greg C and Aquila like this.
    02-08-2013 05:09 PM
  15. planoman's Avatar
    The APN's look correct. The one you are using is fine if you are not on an LTE data plan. The other one posted if for an LTE plan. Data needs to be on to send MMS but not SMS like gcorliss says. Did you get it working?

    Battery life will improve after a few cycles...it is really not that bad for a 2100 mah battery.
    Greg C and Aquila like this.
    02-08-2013 05:16 PM
  16. Greg C's Avatar
    The APN's look correct. The one you are using is fine if you are not on an LTE data plan. The other one posted if for an LTE plan. Data needs to be on to send MMS but not SMS like gcorliss says. Did you get it working?

    Battery life will improve after a few cycles...it is really not that bad for a 2100 mah battery.
    My battery life vastly improved after several charging cycles
    Aquila likes this.
    02-08-2013 05:27 PM
  17. Jason Escobar's Avatar
    I never said sms needed data turned on... only mms.
    I could receive and do receive pictures if data is enabled I was trying to get picture texts while only having WIFI on, like in my old HTC Inspire so I wouldn't accidentally use data(background or syncing) but now I see that maybe it was just my old phone(running gingerbread) that was able to do that. I've searched online and found a lot of people saying the same as gcorliss. Guess I'm gonna have to get used to it now, don't want to miss anything out of people are trying to send me stuff
    Aquila likes this.
    02-08-2013 05:34 PM

Similar Threads

  1. Problem connect wifi at home NEXUS 7 TABLET
    By tabletandroid2012 in forum Google Nexus 7 Tablet (2012)
    Replies: 29
    Last Post: 04-10-2014, 07:12 AM
  2. PLEASE TAKE A LOOK AT THIS VIDEO (my problem on galaxy nexus)
    By trebontdroid in forum Google / Samsung Galaxy Nexus
    Replies: 1
    Last Post: 10-25-2012, 01:41 AM
  3. AT&T/Nexus One data question
    By MNTwinsFan in forum Google / HTC Nexus One
    Replies: 6
    Last Post: 03-19-2010, 12:10 PM
  4. I'm switching to an AT&T Nexus One (back up advice)
    By jd914 in forum Google / HTC Nexus One
    Replies: 0
    Last Post: 03-18-2010, 11:57 PM
  5. nexus one problems
    By aquaj13 in forum Google / HTC Nexus One
    Replies: 5
    Last Post: 02-01-2010, 08:51 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.