1. peejay1977's Avatar
    Ok, so on Saturday morning my Nexus 4 (running CyanogenMod 10.1) froze on me and I had to do a reset, after resetting it the phone got quite warm in the top area of the device and stayed that way, battery temp read about 40degrees celsius. In 6 hours the battery then drained to almost empty which was very peculiar.

    Tried to see what was causing it and noticed that "drmserver" was using more battery than anything else but I had no idea why. I couldn't recall anything being updated that day or the previous day that might use any kind of DRM for it's functionality but I decided to uninstall Double Twist media player just in case, this seemed to instantly stop the phone heating up and also the battery drain.

    What I also noticed was that the phone had been sluggish performing certain tasks, I use the flashlight quite alot and it was taking about 20-30 seconds for the flashlight to come on or off, this led me to check the battery temp using the *#*#4636#*#* code on the dialler but this also had a delay of up to 30 seconds. On uninstalling Double Twist and rebooting both of these became instananeous as well as the hot phone/battery drain issue.

    So I thought I had the problem solved, but the following day the phone froze again, wouldn't activate the screen at all so I had to reset it, as soon as I did the phone got hot, drained the battery etc and the 2 things mentioned above were sluggish. Wiping the cache and the delvik cache using the CWM recovery made no difference either.

    I thought it was then about time to "go stock" and I reflashed using the stock 4.2.2 image, and as soon as the phone booted, was logged into Google there was no heat build up and the flashlight and dialler code were super quick, that was until the updates started to installed automatically.

    I let it finish installing the updates and all my previously installed apps and set about uninstalling everything I could live without, still no joy. Then I started uninstalling the updates to the Google apps themselves, each time checking the flashlight and dialler code. As soon as I uninstalled the updates for Google Earth the phone started cooling down and the 2 problems went away so again I thought I had cracked it.

    I then installed the Google Earth update again expecting the problem to return but.....nope, everything still OK and is still OK now 3 days on. Very bizarre, it's almost like it was the order of how things installed that caused the problem but I did Google the problem and found other Nexus 4 users commenting on the exact same day the problem started for me having the same issue.

    I know this post is long winded but I thought it might, possibly be of use to some people if they encounter the same issue.


    03-27-2013 12:36 PM
  2. Citizen Coyote's Avatar
    So a Google Earth update seems to be what was causing your massive battery drain? When was Google Earth updated last? Do you remember seeing the behavior start around the same time? I'm just curious if this was the sole issue, or just one brick in the wall, so to speak. Good to hear about a potential fix however, and also good to hear your phone is back to normal.
    Patrick Schroedl likes this.
    03-27-2013 03:13 PM
  3. return_0's Avatar
    Very interesting. I'm no software expert, but I have a feeling it's just a one-time glitch. What were the experiences of the other users who experienced that problem?
    03-27-2013 10:59 PM
  4. peejay1977's Avatar
    Google Earth hadn't been updated since February and Double Twist hadn't been updated in a while, it seemed to me like a cumulative effect as it did it on both stock 4.2.2 and CM10.1.

    Other peoples experience was that on the same day, DRMSERVER started using massive amounts of battery, thats all I know at this point.

    Very strange indeed but as I say I wonder if it was a cumulative effect.
    03-28-2013 05:09 AM
  5. Citizen Coyote's Avatar
    It does sound like it could have been a cumulative effect, a perfect storm of software interaction that pooped on your battery. Weird. More voodoo to add to the toolbox, I suppose.
    03-28-2013 02:29 PM

Similar Threads

  1. Strange problem while trying to update. NEED HELP!
    By nismo300zx96 in forum Verizon Droid Incredible
    Replies: 12
    Last Post: 09-07-2010, 12:33 PM
  2. Help with Vonage and EVO - Strange Problem
    By jgladstone in forum HTC EVO 4G
    Replies: 8
    Last Post: 09-03-2010, 01:44 PM
  3. Strange problem with Google contacts
    By breugel in forum Verizon Droid Incredible
    Replies: 6
    Last Post: 08-21-2010, 11:38 PM
  4. GPS problems, even after fix
    By thenameisgabe in forum AT&T Captivate
    Replies: 8
    Last Post: 07-26-2010, 08:45 AM
  5. Strange Problem
    By rtlsnke in forum HTC EVO 4G
    Replies: 1
    Last Post: 06-08-2010, 02:25 PM