1. willdogs's Avatar
    I'm testing out Straight Talk (AT&T) and it works great except for MMS!

    I can't send or receive MMS messages. They just keep failing.

    Here are the settings im using

    1. APN Name: Straight Talk
    2. APN: tfdata
    3. Port: 80
    4. MMSC:http://mms-tf.net
    5. MMSProxy:mms3.tracfone.com
    6. MMS Port: 80

    These were given to me directly from straight talk.

    I've scoured this site and other sites for other valid APN settings and none of them work for me at all. I get no data connectivity what so ever.

    The APN provided me by ST is the only one that gives me data connectivity, others just give me gray bars with no 3G/H indications.

    any Ideas?
    07-03-2013 08:25 PM
  2. nickacs's Avatar
    That's what I have on my N4 with ST AT&T and no MMS issues for me. I played around with a couple different APN settings, but these seemed to work the best for me??

    I've been on ST AT&T for about 4 months now, but since they switched their APN settings about a month ago, my signal reception has gone to crap. Literally. I would get high data "bars" and connection and now it fluctuates up/down and even lose data signal for a minute or two. I end up putting the phone on Airplane mode and then take it off and then my signal "comes on" again for a bit.

    On Friday, I am going to say good riddance to ST and port to either AT&T go prepaid or TMobile $30 prepaid.

    Good luck! You'll need it Search the forum here and on XDA Developers, as you'll find tons of people unhappy/throttling them ridiculously on their Nexus.
    07-03-2013 08:49 PM
  3. specificsandwich's Avatar
    I have a Samsung Nexus S. Got it about a week ago and only just now got the data to work. These are the only settings that let me receive MMS. I pieced them together by blindly combining what Straight Talk has on their website with what some other users on this forum have said.

    I used the settings here Support | Straight Talk

    but substituted the following for the last three settings:
    MMSC=http://mmsc.cingular.com
    MMS proxy=mms2.tracfone.com
    MMS Port=(none)

    Good luck!
    07-04-2013 08:26 PM
  4. IvIountainman's Avatar
    Apparently the 'SIMPLE' solution is just removing port assignments from Straight Talks suggested APN.
    (android 4.0)
    Name: (Does not matter)
    APN: tfdata
    Proxy: Not set
    Port: Not Set
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mms-tf.net
    MMS proxy: mms3.tracfone.com
    MMS port: Not set
    MMS protocol: WAP 2.0
    MCC: 310
    MNC: 410
    Authentication type: Not set
    APN type: Not set (if you don't have another APN it doesn't matter, if you do insert 'default,supl,mms')
    (following is on Android 4.X and above)
    APN protocol: IPv4
    APN roaming protocol: IPv4
    Bearer: Unspecified
    MVNO type: Non
    bananer4019 and WisdomCube101 like this.
    09-03-2013 11:51 AM
  5. coraxe's Avatar
    The above setting kept mms.android.com from crashing but the mms still does not send or receive. Pretty annoying that ST can't provide a simple service as this...
    09-21-2013 01:51 PM
  6. kmcochran's Avatar
    For me, the problem was the google voice app on my phone. I only use it for voicemail, and nothing else. Once I uninstalled it from my phone, then my MMS message started working.
    09-21-2013 07:37 PM

Similar Threads

  1. Can I pin music from Google Music to the SD card?
    By Surfing32 in forum Samsung Galaxy S4
    Replies: 7
    Last Post: 07-25-2014, 10:49 AM
  2. Replies: 5
    Last Post: 11-11-2013, 07:05 PM
  3. Corporate Exchange "Can't connect to server."
    By peter1337 in forum Legacy Android & Other OS's
    Replies: 3
    Last Post: 07-06-2013, 10:06 AM
  4. Hi, 6 year iPhone/iOS user switching to Android!
    By TheFirm88 in forum New to the Forums? Introduce Yourself Here!
    Replies: 8
    Last Post: 07-05-2013, 11:10 PM
  5. New to Note 2
    By HolyCrapThisSux in forum Samsung Galaxy Note 2
    Replies: 17
    Last Post: 07-05-2013, 10:52 AM
LINK TO POST COPIED TO CLIPBOARD