1. Google_Superuser's Avatar
    As of 1240pm pst I cannot receive texts from anyone. They get my texts just fine but I don't receive there's. I am on ATT with a family unlimited messaging plan. Does anyone have any suggestions on how to fix this?

    I'd give more details but there really isn't much to say the phone is dead stock never been flashed or rooted. I can receive mms picture messages just fine.


    Making matters worse I've had to hear from my iphone owning friends about how much better their baby phones are because of this.
    07-08-2013 07:45 PM
  2. pontiac005's Avatar
    You probably already did this but maybe rebooting the phone. Also take out the sim and reinstall it.

    Sent from my Nexus 4 using Tapatalk 2
    07-08-2013 08:10 PM
  3. Google_Superuser's Avatar
    Did both of those. I was going to try and put the sim in my old phone but its a full size sim in that one not the N4's micro sim and I couldn't get it to work.
    07-08-2013 08:28 PM
  4. donm527#IM's Avatar
    could try going to settings > apps > all > messaging and force stop and clear data/cache.
    then shut down and restart and see if clearing cache helps.

    i have a different type of issue where it seems if i am group texting that after many texts back and forth, my texts to the group takes a while to send, just hanging at sending for a while then eventually sends. and i think occasionally a delay in receiving. but it only seems to happen in group texts with the stock messaging app. clearing cache and all that has no effect.
    07-08-2013 09:38 PM
  5. Google_Superuser's Avatar
    Fixed it!

    I eventually got the smaller sim lined up in the larger slot of my old phone so that I could boot it up with cell signal. Then it downloaded all the messages on the old phone. Turned it off put the sim back in the N4 and now all is fine.
    07-08-2013 11:18 PM
  6. debraarzn's Avatar
    You probably already did this but maybe rebooting the phone.
    07-08-2013 11:44 PM
  7. Google_Superuser's Avatar
    Did it again same method fixed it. This is annoying...any thoughts?
    07-09-2013 07:45 PM
  8. pontiac005's Avatar
    New Sim card?

    Sent from my Nexus 4 using Tapatalk 2
    07-09-2013 10:05 PM
  9. Google_Superuser's Avatar
    Ok got new sim card and its working for the moment.
    pontiac005 likes this.
    07-10-2013 02:37 PM
  10. pontiac005's Avatar
    Please keep us posted.

    Sent from my Nexus 4 using Tapatalk 2
    07-10-2013 06:43 PM
  11. Google_Superuser's Avatar
    So far so good!
    07-11-2013 02:52 PM
  12. pontiac005's Avatar
    So far so good!
    Awesome!

    Sent from my Nexus 4 using Tapatalk 2
    07-11-2013 04:02 PM
  13. Google_Superuser's Avatar
    ....and I'm not receiving texts again!
    07-15-2013 10:13 PM
  14. Google_Superuser's Avatar
    Update they supposedly fixed my text messages by correcting their imei. This afternoon data stops working followed by text messaging. I call support they blame the Nexus 4 so while they are on the line I put the sim back in my stock ATT Galaxy S2 Skyrocket and surprise it doesn't work either. I tell this to support and they said a technical support specialist would "look at the network" in 7-10 days. So I am just supposed to not use text messaging, mms or data for 7-10 days, so basically get the same service I could get with a flip phone and their cheapest plan. I could petition for a partial refund for the days it is not active. I complained enough that they cut the contract cancellation fee in half so I am done with ATT and done with contracts ever again.
    07-17-2013 10:11 PM
  15. sturpe's Avatar
    I don't think the problem is the Nexus 4. I am having similar problems with my new Moto X. It will receive texts only if Wi Fi is turned off.
    07-28-2014 11:18 AM
  16. Yashi Shekhar's Avatar
    Hey Thanks

    These steps worked for me.
    After force stop and clear cache, I started receiving all the backlog messages.
    Sd67pwgme likes this.
    07-23-2015 02:31 AM
  17. Ruchika Tadakala's Avatar
    it worked for me.. thank you
    10-05-2016 11:59 AM
  18. mkrause01's Avatar
    I have a Google Pixel on Verizon plan.
    Can send but haven't received any texts for about a week. New SIM and (hours of) diagnostics with tech support up to "time to restore to factory".
    I feel strongly that it's a Verizon system problem of course, not my problem ;-) )
    Cleared cache / data, sent test multiple text messages from other working phone. Watched data and cache but no change from 504kB/32.77kB.
    WhatsApp, Hangouts and Voice work fine bidirectionally but they're using proprietary protocol so all bets off.
    Other ideas short of reset phone?
    09-14-2017 11:55 AM
  19. eileenspants's Avatar
    I am also having the same problem. Also have a Google Pixel and also on Verizon. Also tried a lot of the same troubleshooting and Verizon tech support has opened a ticket on this. mkrause01 if you were able to find a solution, please share...
    09-25-2017 10:58 AM
  20. eileenspants's Avatar
    were you able to get it fixed?
    09-25-2017 10:58 AM

Similar Threads

  1. Text expander built into the keyboard?
    By Razeus in forum Samsung Galaxy S4
    Replies: 8
    Last Post: 03-18-2014, 11:28 AM
  2. Not charging on car or laptop cables
    By jeffrok in forum Droid RAZR MAXX
    Replies: 4
    Last Post: 07-09-2013, 12:29 AM
  3. Transferring texts?
    By cmcfarland in forum HTC EVO 4G
    Replies: 1
    Last Post: 07-08-2013, 06:21 PM
  4. Apps not staying connected to Facebook
    By Fourth Hokage in forum General Help and How To
    Replies: 0
    Last Post: 07-08-2013, 04:36 PM
  5. apps not updating
    By velvetelvis in forum Sprint Nexus S 4G
    Replies: 0
    Last Post: 07-08-2013, 04:08 PM
LINK TO POST COPIED TO CLIPBOARD