1. Luis M Gonzalez's Avatar
    This is so extrange.
    My Nexus indicates that all my apps are up to date, but Maps is still on version 6.14.
    I tried updating many times, deleting latest updates and reinstalling, but nothing... it's stuck on version 6.14...

    What's curious is that my two daughters have each a Huawei Ascend y300 (same model, same android version 4.1.1).
    One of them updated maps to version 7.0.1, but the other one is also stuck on 6.14 (and indicating that it's already updated).

    What's wrong? Am I missing something obvious??
    07-13-2013 04:21 PM
  2. RenoD2010's Avatar
    Same here (no version 7). However, I read that the rollout is being spread out over the coming weeks. Have no idea what criteria determines which phones will see it first.

    Sent from my LG-E970 using AC Forums mobile app
    07-13-2013 04:28 PM
  3. anon(847090)'s Avatar
    its called staged rollout. since maps is used by 500 million+ people they dont want to release it to all users without properly testing.
    so they send the update to only very few people and see how it goes and once they fix issues if they exist they will release to all.

    they first released 7.0.0 and then people complained about offline support and then Google fixed it and released 7.0.1.

    it will be released soon to all in few days. so basically your daughter is Android maps app tester. lol
    RenoD2010 likes this.
    07-13-2013 04:33 PM
  4. Luis M Gonzalez's Avatar
    I understand now.
    Thanks to all of you for responding so quickly!
    07-13-2013 04:37 PM
  5. RenoD2010's Avatar
    I just took the desktop tour; incredible. With a nice display and good CPU, using the new maps will be a real treat.

    Sent from my LG-E970 using AC Forums mobile app
    taj7575 likes this.
    07-16-2013 10:47 PM
  6. scoutzdad's Avatar
    In the same boat here too! Very frustrating since now all of our iOS folks are getting it today!! Come on Google, how about tossing your loyal nexus users a bone here and give us the update?!?!?
    07-17-2013 12:14 PM

Similar Threads

  1. Top bar on lock screen disappeared after update.
    By remedemic in forum Samsung Galaxy S4
    Replies: 7
    Last Post: 08-10-2013, 09:54 PM
  2. GS3 won't connect to MBP via USB after phone Firmware udate
    By promart611 in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 2
    Last Post: 07-18-2013, 07:08 PM
  3. [Solved] Can I root the E4GT without flashing a stock or custom ROM? (Camera shutter noise issue)
    By Dark Penguin in forum Epic 4G Touch Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 07-15-2013, 09:09 PM
  4. Need firmware update md5/tar file for ATT-Thru Odin Please!
    By sunfire29 in forum AT&T Samsung Galaxy S4
    Replies: 1
    Last Post: 07-13-2013, 09:13 PM
  5. Can't remove icons
    By fremal in forum Samsung Galaxy Tab 2 10.1
    Replies: 0
    Last Post: 07-13-2013, 03:52 PM
LINK TO POST COPIED TO CLIPBOARD