1. x3m's Avatar
    Hi guys, I'm having the weirdest problem on my Nexus 4, and I can't find anything about it, and seems like Play Store support doesn't know what to do about it either.

    This is what hapenned:
    - I live in Brazil, and used my N4 here for many months with no issues.
    - I traveled to the US and used a T-Mobile prepaid while I was there.
    - When I arrived back in Brazil, and booted my phone with my brazilian SIM card I got no service. Not bars, no calls, no sms... just "No service". But what is more weird, is that it got a data connection from my carrier, and the internet worked fine!
    - After investigating a little, I found that my IMEI was set to 0 (zero)!! and even though I'm not sure when that happened, I'm sure that is wasn't like that a few weeks before at least.
    - I tried different SIM cards, from different carriers, and had the same exact result (no service, but got a data connection). My SIM card also worked fine in other phones.

    My theory, is that the carriers do not let a phone with a invalid IMEI connect to the network for security reasons.

    I tried factory resets, safe boot, but nothing worked, and the IMEI it still 0.

    My phone has always been stock Android.

    Google Play Support has offered to RMA my phone (since I only bough it in April), but since I'm in Brazil now, that would be very complicated to do (they obviously only ship phones for warranty inside the country it was bought). So I would like to avoid that at all cost, since it would cost me a lot of money to send it, but most importantly, I would not have a phone for a while!

    So does anyone have any other suggestions? I can post some screenshots if that'll help.
    I'm thinking of flashing it with factory stock ROM to see if that helps at all. But does anyone know if that void my warranty? Do I have to unlock the bootloader for that?

    Thank a lot!
    08-31-2013 03:07 PM
  2. fernandezhjr's Avatar
    Are you still on 4.2.2 or have you upgraded to 4.3?

    Sent from my Nexus 4 using Tapatalk 4
    x3m likes this.
    08-31-2013 07:55 PM
  3. x3m's Avatar
    4.3 (and the latest 1.8mb security update)! I upgraded to 4.3 while I was using the phone on my travel... thought if that could have anything to do with it, but didn't make sense to me.
    08-31-2013 09:01 PM
  4. Fairclough's Avatar
    Try reading this not sure if it's much help
    http://androidforums.com/nexus-4/657...play-imei.html

    - Android Central App. Remember courage is contagious.
    x3m likes this.
    08-31-2013 09:33 PM
  5. fernandezhjr's Avatar
    When you go to settings>about phone, does it show a baseband? When you go to settings>about phone>status, does it show your phone number and what does it show for IMEI SV?

    Sent from my Nexus 4 using Tapatalk 4
    x3m likes this.
    08-31-2013 09:50 PM
  6. x3m's Avatar
    Yes, it shows a baseband and the IMEI SV is 04 . Here are some screenshots also. Attachment 78941 Attachment 78942 Attachment 78943 Attachment 78944 Attachment 78945
    08-31-2013 11:04 PM
  7. fernandezhjr's Avatar
    Your attached pics do not show, but that is ok. As long as the fields I asked about do not show "unknown", you are probably ok. I have seen a few threads here and over at xda where that info along with the imei number is lost and the phones were not recoverable. This doesn't appear to be the same scenario. There is a bug introduced with 4.3 that only affects certain carriers in certain countries that involves populating improper apns. You may want to check for this. If you are affected by this, the way around it would require you getting the proper apn(s) from your carrier first. Then you would need to power down and remove your sim card, power back up without the sim card and manually put in the apn(s), power back down and re-enter the sim card, and finally power back up.

    Sent from my Nexus 4 using Tapatalk 4
    petaf, anon4276835 and x3m like this.
    09-01-2013 07:36 AM
  8. x3m's Avatar
    Yeah, the only similar cases that I had found in my search were the ones you described, with "unknown" basebands etc... But since mine doesn't seem to be the same case, I'm looking for other solutions. I've seen some stuff about IMEI injection, but I'm not sure that would do it...

    When I checked the APNs that were configured, they seemed fine (it configured my brazilian carrier APN as soon as I put the SIM back in). But since I does get a data connection, I don't think that's the problem... but I'll give it a try, and see if it works. Thanks!

    Sorry, don't know what happened to those attachments. Here are the images:
    N4 IMEI 0 - Imgur
    09-01-2013 12:48 PM
  9. fernandezhjr's Avatar
    Ok, you are right. I don't think it is the apn. Looking at the pics, it appears that the phone is detecting the mobile network, but it is not properly reading the sim card. I saw a post over on xda that had a fix for this. Only thing is I think you may need to be rooted. I will post a link if I find it.

    Sent from my Nexus 4 using Tapatalk 4
    x3m likes this.
    09-01-2013 03:08 PM
  10. x3m's Avatar
    Ok, I would appreciate that!
    But I still think that the problem it the IMEI 0 not getting trough network security (since you can blacklist a stolen phone through IMEI, for example).If it didn't read the SIM card, I think it wouldn't even get a data connection... But I'll give it a try, if you can find that, thanks!
    09-01-2013 06:43 PM
  11. x3m's Avatar
    Does anyone think it's worth trying to flash stock ROM on the device? And does anyone know if that voids Google's warranty (didn't find any conclusive answer for this anywhere...)? Thanks!
    09-01-2013 09:56 PM
  12. fernandezhjr's Avatar
    Unfortunately the imei injection tool has been removed from xda and from what I have been reading, have a 0 for imei is no different than have no imei. All that have tried flashing the factory image had no success in restoring the imei. I did find a case where someone was able to get it back by flashing an older radio, but he probably just got lucky.

    Sent from my Nexus 4 using Tapatalk 4
    x3m likes this.
    09-02-2013 02:33 PM
  13. fernandezhjr's Avatar
    I found one case where flashing the factory image worked. Also linked in that thread is another thread where flashing an older radio worked. I guess it is hit and miss, but you might as well try everything at this point.

    http://forum.xda-developers.com/show....php?t=2060780

    Sent from my Nexus 4 using Tapatalk 4
    x3m likes this.
    09-03-2013 03:42 PM
  14. x3m's Avatar
    Unfortunately, flashing the factory image and baseband did not do any good... guess I will really have to RMA it.
    09-04-2013 03:05 PM
  15. Fabrizzio Valdivia's Avatar
    Hey, I've seen similar problems after going abroad with phones, not the IMEI 0 problem but having no signal at all. Have you tried to make the phone to choose the network automatically?

    Oh, I just saw the date of the post... sorry for reviving :P
    11-19-2013 10:38 PM
  16. Gabriel Fernandes's Avatar
    I am going crazy with same Nexus 4 problem in Brazil, reading all I can since sunday.
    It seems that there are some tools that can do the job: octopus box, LGNPST, QPST, but I am too noob to use them. all cracked versions seems to have some sort of virus or other problem.
    Please help me if you solved the issue.
    02-09-2015 03:56 PM

Similar Threads

  1. Replies: 8
    Last Post: 11-06-2015, 12:02 PM
  2. [APP] Help Me - A life saver in EMERGENCY
    By allzhere in forum Android App Inventor
    Replies: 4
    Last Post: 09-09-2013, 02:48 AM
  3. Help rooted and think i deleted the operating system
    By Katie Notargiacomo in forum Samsung Galaxy Ace
    Replies: 71
    Last Post: 09-03-2013, 02:22 PM
  4. Please Help. Titanium Backup and Aosp
    By JSteez81 in forum Verizon Galaxy Note 2 Rooting, ROMs, & Hacks
    Replies: 5
    Last Post: 09-01-2013, 07:10 PM
  5. HELP!! google play store not responding and i have tried everything!!
    By androidbelle in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 6
    Last Post: 08-31-2013, 07:58 PM
LINK TO POST COPIED TO CLIPBOARD