1. jaileer's Avatar
    I'm on a Nexus 4 running 4.4.2 - and I can't download any apps. When I try it just say installing forever.

    I've uninstalled/reinstalled my google account, rebooted, and cleared cache. From what I gather my next step is a factory reset, but I'm hoping to avoid that. Any other ideas?
    04-12-2014 06:42 PM
  2. mrsmumbles's Avatar
    If your internet connection is good otherwise, it might help to reset app preferences. Settings, Apps, All, tap menu button, Reset Preferences. But this doesn't always help. Apologies if you already tried it.

    Sent from my LG-LG870 using Tapatalk 2
    04-12-2014 07:54 PM
  3. jaileer's Avatar
    Thanks for the tip. I hadn't tried that, but it didn't work. Thanks again.
    mrsmumbles likes this.
    04-13-2014 09:34 AM
  4. mrsmumbles's Avatar
    Maybe this can help.


    Sent from my LG-LG870 using Tapatalk 2
    04-13-2014 01:08 PM
  5. jaileer's Avatar
    No joy with either suggestion. I wiped it and everything works now. Thanks for the help!
    mrsmumbles likes this.
    04-14-2014 06:17 AM

Similar Threads

  1. What is the Best Email App
    By neil154 in forum The Android Central Lounge
    Replies: 8
    Last Post: 05-13-2014, 11:15 AM
  2. Replies: 10
    Last Post: 04-24-2014, 04:27 AM
  3. HTC TV app
    By abalboa3 in forum HTC One M8
    Replies: 6
    Last Post: 04-12-2014, 11:04 PM
  4. Cannot Download Apps
    By jaileer in forum Google Nexus 4
    Replies: 1
    Last Post: 04-12-2014, 09:10 PM
  5. Apps and SD cards
    By lanm1192 in forum General Help and How To
    Replies: 0
    Last Post: 04-12-2014, 05:15 PM