1. Calvigile's Avatar
    Hi everybody !

    After two days of research I resign to beg for assistance.

    Long story short, all was pretty good with my Nexus 4 until I happily updated my OS to 5.0.1. During few days my phone was a bit laggy, and soon auto-rotation stopped to work. At the end I decided to reboot. It was a really bad mistake:

    Trap on an infinite bootloop. Usual recovery procedures ( like Wipe Cache / Factory Reset ) were unsuccessful. Since I always stayed on Stock and never give interest to Root and Flash stuff I was really lost. Thanks to Google search I managed to save my phone by flashing to a previous OS via Nexus Root Toolitkit. Only working ones are 4.2.2 and previous. Newer lock me on Infinite Bootloop too.

    Internet says it's because of some sensors trouble so I downloaded three different apps and checked it. Can now confirm that most of my Sensors are kinda mute. In fact auto-rotating is still not working.

    How can I get my sensors back and by so update for at least 4.4 KitKat ? Seen a video on Youtube from a guy explaining how to open my Nexus 4 and rotate the rubber on Gyroscope Sensor to fix it and go past 4.3 OS but since most of my Sensors are out and this suddenly after my update to 5.0.1 and without any shock or fall it's really suspicious. Don't want to chase Torx 5 and take the risk to open the phone for nothing.

    TL;DR: Phone was okay. Lollipop a great source of trouble until eventually it locked me on Infinite Bootloop after a reboot. Since impossible to go past except with old OS like 4.2 or inferior. Due to most of my Sensors apparently "broke" by 5.0.1.

    Also, I tried to fix it by myself by erasing /data/system/sensors + /data/misc/sensors + /persist/sensors/sns.reg but it didn't work.
    I'm aware that I can cheat with the BandBase to go for 4.3 but it will not fix my missing Sensors and I will still miss 4.4 and most recent OS.

    Can someone get me out of this ?
    Thank you anyway for reading this !
    02-04-2015 01:07 AM
  2. ChromeJob's Avatar
    I found your thread due to a similar issue. Recently flashed 5.1, and autorotation ceased to work (though Yelp Monocle mode will force to landscape). System Panel Pro reports NONE of the sensors are detected. Phone Tester same, no sensors supported.

    WTF ... have disabled Settings | Accessibility | Auto rotate, then shut down, then booted and reenabled - no joy.


    Trying to clear cache, but have little hopes. The phone hasn't taken any hard bumps or anything, so I'm surprised that a solid state phone like this will suddenly lose all of its sensors...
    05-19-2015 11:19 PM

Similar Threads

  1. Replies: 1
    Last Post: 02-04-2015, 01:31 AM
  2. Where is the setting to change my S view color on my Note 3?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-04-2015, 12:38 AM
  3. Where is the mic button for sheets on my keyboard?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-04-2015, 12:14 AM
  4. Micromax Android One Lollipop update ?
    By Aarav sinha in forum Ask a Question
    Replies: 0
    Last Post: 02-04-2015, 12:08 AM
  5. Replies: 0
    Last Post: 02-03-2015, 11:25 PM
LINK TO POST COPIED TO CLIPBOARD