Dell Technologies Cyber Savings Event - Up to 45% off

12-26-2018 05:39 PM
51 123
tools
  1. LondonJohn's Avatar
    Hi,

    I have a problem with my Nexus 4, now out of warranty, running 5.0.1

    The "e" and "3" keys have stopped working in portrait. Touching the e just types a w or an r (two letters on either side), However, The "e" and "3" keys work OK in landscape.

    I'm not aware of anything that happened to cause this problem, it just started a few weeks ago.

    Swipe letters works fine in landscape, but in portrait there's no swipe line over the letter "e" when I swipe across the row - line appears right up to edge of r and w but then there's a gap over the e. This is the same in all keyboards tested.

    There's no problems with that part of the screen, I can touch OK and screen works fine when not using keyboard.

    Tried safe mode, still doesn't work

    Tried 4 different keyboard apps, still doesn't work

    Tried Resetting App Preferences, still doesn't work

    Phone hasn't been dropped or damaged, and everything else works fine.

    I'm really out of ideas - can anyone help?

    Thanks.

    J.
    02-11-2015 08:16 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! To be sure the touchscreen is working correctly, use an app like Screen Touch Test.
    LondonJohn likes this.
    02-11-2015 07:20 PM
  3. LondonJohn's Avatar
    Thanks for your suggestion, but Screen Touch Test works fine.

    It's not an issue with the screen, as i can touch the same location fine when keyboard is not showing.

    It's an issue specific to that key on any keyboard in portrait mode.

    Any ideas anyone?

    J.
    02-12-2015 03:44 AM
  4. Javier P's Avatar
    That's a weird problem! I remember having some problems in the beginning with words like "see" and such, where the keyboard changed the e for a w. But after a few tries managed to include them in the prediction algorithm.

    Have you tried setting a different row for the numbers? Keyboards like SwiftKey can do that. See if that makes a difference when swiping.
    LondonJohn likes this.
    02-12-2015 04:36 AM
  5. LondonJohn's Avatar
    Thanks.

    I changed to SwiftKey and placed the number keys on the right side of the keyboard, instead of top row, and the 3 key worked fine.

    I added a row of numbers to top of Smart Keyboard Pro and the 3 DIDN'T work in Portrait but worked fine in Landscape.

    So, it seems to be an issue with e and 3 (when I hold e down) AND 3 (when numbers appear on their own row).

    Really weird and very annoying!
    02-12-2015 05:49 AM
  6. Javier P's Avatar
    Very weird! So no harm asking stupid questions Have you tried swiping with your other hand?

    I'll let you know if I find something about that. Post if you find a fix. Good luck.
    LondonJohn likes this.
    02-12-2015 06:55 AM
  7. LondonJohn's Avatar
    Thanks for the suggestion, but same problem with either hand.
    02-12-2015 07:33 AM
  8. belodion's Avatar
    Have you tried a Cache Partition wipe? It's the sort of fix you just know in advance probably won't work, but maybe worth a try.

    Posted via the Android Central App
    LondonJohn likes this.
    02-13-2015 05:59 AM
  9. LondonJohn's Avatar
    Have you tried a Cache Partition wipe? It's the sort of fix you just know in advance probably won't work, but maybe worth a try.

    Posted via the Android Central App
    Thanks, belodion.

    Wasn't aware of that. Now done it but sadly didn't work.
    02-13-2015 06:15 AM
  10. Javier P's Avatar
    Another one. Select SwiftKey and change the layout to "compact". You can do this longpressing the "123" key. This way you're going to know if the problem is in the screen or some glitch with the software.

    Not easy to write this way
    Attached Thumbnails "e" and "3" keys on keyboard not working in portrait-1423838425253.jpg  
    02-13-2015 08:40 AM
  11. Javier P's Avatar
    If the problem is gone long press on the arrow. This will change the position of the keyboard to the right. Test how many keys don't work this way.
    Attached Thumbnails "e" and "3" keys on keyboard not working in portrait-1423838639576.jpg  
    LondonJohn likes this.
    02-13-2015 08:43 AM
  12. LondonJohn's Avatar
    Another one. Select SwiftKey and change the layout to "compact". You can do this longpressing the "123" key. This way you're going to know if the problem is in the screen or some glitch with the software.

    Not easy to write this way
    Thanks again.

    Interesting ... the "e" key doesn't work on SwiftKey Full or SwiftKey Thumb but does work on Compact - progress! Does that give any clues? The position of the "e" key in SwiftKey Full and SwiftKey Thumb is different, and as I can touch screen OK normally in those positions when not using the keyboard, I think we can rule out screen issue.

    Does this point towards the problem?
    02-13-2015 08:54 AM
  13. Javier P's Avatar
    Does it work in compact mode in both sides!? Now it gets interesting ... and personal
    That's a funny software glitch.
    LondonJohn likes this.
    02-13-2015 09:04 AM
  14. LondonJohn's Avatar
    Does it work in compact mode in both sides!? Now it gets interesting ... and personal
    That's a funny software glitch.
    Yes, "e" key works on both sides.

    I changed back to full mode, and changed keyboards as well, just in case my eyes were deceiving me, and "e" key doesn't work any other way in Portrait. Grrrr...
    02-13-2015 09:10 AM
  15. Javier P's Avatar
    I think there's some file(s) in the phone that relates letters and position in some way. I'll have a look. Have you ever messed around with root access?

    I called a forum member for help. Stay put.
    LondonJohn likes this.
    02-13-2015 09:14 AM
  16. LondonJohn's Avatar
    I think there's some file(s) in the phone that relates letters and position in some way. I'll have a look. Have you ever messed around with root access?

    I called a forum member for help. Stay put.
    Great, thanks.

    Never touched root and wouldn'r know where to start
    02-13-2015 09:25 AM
  17. Javier P's Avatar
    And another one Go to settings > apps > all > search for Google keyboard and uninstall updates and clear data. Reboot the phone. Make a test. Update the keyboard in the Play Store.. Test again.
    LondonJohn likes this.
    02-13-2015 10:30 AM
  18. LondonJohn's Avatar
    And another one Go to settings > apps > all > search for Google keyboard and uninstall updates and clear data. Reboot the phone. Make a test. Update the keyboard in the Play Store.. Test again.
    Thanks again for your suggestion and for sticking with this

    Unfortunately that didn't work - tried several times, but no joy
    02-13-2015 11:41 AM
  19. Javier P's Avatar
    Run out of ideas mate

    Just trying to postpone the factory reset. I'll be out for a while, carnival time!. I'll post if something else comes to my mind.
    LondonJohn likes this.
    02-13-2015 12:04 PM
  20. LondonJohn's Avatar
    Run out of ideas mate

    Just trying to postpone the factory reset. I'll be out for a while, carnival time!. I'll post if something else comes to my mind.
    No worries, am steeling myself for a factory reset.

    Really appreciate your help. Cheers.
    02-13-2015 12:07 PM
  21. Simon Luckhurst's Avatar
    Well you are not on your own mate. About two days ago my phone - also a Nexus 4 - starting doing exactly the same thing, however my c and f keys also don't work in portrait. Every now and then they do work and outside of the keyboard the whole touchscreen works fine??!!!?!

    Also starting at the same time, my keyboard just goes mental and randomly starts selecting stuff when I'm not pressing anything.

    Very interesting that we both have the same phone and got the problem at the same time. Only thing left for me to try is a factory reset. Have you done one? Did it work?

    Thanks
    02-13-2015 01:10 PM
  22. LondonJohn's Avatar
    Well you are not on your own mate. About two days ago my phone - also a Nexus 4 - starting doing exactly the same thing, however my c and f keys also don't work in portrait. Every now and then they do work and outside of the keyboard the whole touchscreen works fine??!!!?!

    Also starting at the same time, my keyboard just goes mental and randomly starts selecting stuff when I'm not pressing anything.

    Very interesting that we both have the same phone and got the problem at the same time. Only thing left for me to try is a factory reset. Have you done one? Did it work?

    Thanks
    Haven't tried a factory reset yet, but aware that that's not far away!

    I've a great idea .... you go first!

    Seriously, if I don't get a solution soon, I'll probably try a factory reset next week. Eeekk.

    J.
    02-13-2015 01:22 PM
  23. Javier P's Avatar
    I'm not sure that a factory reset will fix it. It can be a bug, some problem with a map, an error in a system file... Who knows. And I like trying everything before going nuclear.

    If you're ready to play a bit read on

    Open the developer options. To enable them go to settings - about phone and tap 7 - 10 on the build number. After that they will be just before the "about phone" setting. OK. Now careful there,* some things could give you some extra problems. You can read about these options here:

    http://m.androidcentral.com/all-abou...eloper-options

    My idea is to force the phone to make an extra effort after tapping things and see what happens when you tap on those problematic letters.

    Enable these ones:

    Show touches:*Select this to see a visual cue on the screen when and where a touch was registered.

    Pointer location:*This setting places an information bar at the top of your screen telling you the screen coordinates of the last place the screen was touched. See what happens after tapping on the "e".

    And to have a bit of fun:

    Force RTL layout direction:*Forces screen orientation for right to left language support.

    Fancy this whole thing? It's* not very risky,* but there's always the chance of things go sour. Disable them after you finish the test.*
    LondonJohn likes this.
    02-13-2015 03:41 PM
  24. Rukbat's Avatar
    Not risky at all, unless you play with other settings in Developer options. Still not actually risky, they can always be set back to what they were (if you remember the original settings or write them down before changing them).

    Good idea, though - see if the touch on the 'e' in portrait mode is actually touching the 'e', not the 'w'. If it's touching the 'w', either the digitizer is bad, the motherboard is bad or the firmware got corrupted. If it's touching the 'e, the keyboard mapping would probably be the problem ... but the fact that it changes with orientation, while the mapping doesn't, kind of rules that out.

    This is the kind of bug that answers the question "Why are so many programmers bald?" (We had a database bug that took 6 months to be able to duplicate at will - which is what you have to be able to do to fix it. And you have to be able to trace the running code, which Google should be able to do, the manufacturers might be able to do and the user probably can't do.)
    02-13-2015 04:18 PM
  25. LondonJohn's Avatar
    Show touches:*Select this to see a visual cue on the screen when and where a touch was registered.
    Touch doesn't show up when touching the "e" key. I can see it fine on all other keys.

    When I touch the "e" key there's two touch marks on either side of it.

    BUT ... playing around with it on my home screen .... there's a vertical strip aligned with the e key which ALSO shows two touch marks, with a space in the middle (aligned where the "e" key would be). So, looks like there a dead strip up my screen in portrait, about one quarter width in from the left edge!

    So .....

    Pointer location:*This setting places an information bar at the top of your screen telling you the screen coordinates of the last place the screen was touched.
    The dead area start at approx x= 120 through to x=250

    This is a massive jump, as I now know what the problem is ... question now is .. is there anything can be done or is this fatal?

    Javier - thanks for the suggestion, superstar!
    02-13-2015 04:22 PM
51 123

Similar Threads

  1. Motorola Keylink or The Tile; Which would work better?
    By JimA in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 02-12-2015, 07:15 AM
  2. I have forgotten my password and i want to change it.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-11-2015, 10:48 AM
  3. Replies: 2
    Last Post: 02-11-2015, 09:53 AM
  4. Is the screen shot available in new KitKat version?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 02-11-2015, 08:19 AM
  5. Replies: 2
    Last Post: 02-11-2015, 08:17 AM
LINK TO POST COPIED TO CLIPBOARD