1. TechZOnline's Avatar
    I think between upgrading from the Xperia Sola to a Nexus 4 and then a Nexus 4 to 5, the former was a much, MUCH smoother process with the least amount of hassle.
    So far I've had to factory reset about 5 times, that's 5 times more than I've ever done before. I was hoping the N5 would be near flawless, but alas...perhaps these are issues limited to me?!

    I have two wifi routers at home, the Netgear D6300 (Handles internet - ADSL and routing) and the Netgear WNDR 4720 (acts mostly as a switch/wlan, no routing).

    I've got 2 Nexus 4s in the house and a bunch of other smartphones/tablets/laptops (mix of Windows OS, Windows Phone & Android), no issues on the 2.4 wifi or 5ghz wifi - I use WPA2 & hide my SSID.

    The N5 connects to all 4 SSIDs just fine, internet through Chrome and other apps is also alright. The trouble is, that it will ONLY access the Play Store if I connect to the WNDR 4720 on 5ghz and under no other wifi circumstance in my house! Play Store app is ver 4.4.22

    Now unless the N5s Play Store app is configured to connect to wifi completely differently - this makes no sense...

    What I've tried so far:
    • Factory Reset (multiple times)
    • Force Stop on Play Store app
    • Clear data/cache on Play Store app


    That seems to be the 3 top options every website talks about and it hasn't helped me.

    Also Google needs to up its game when it comes to restoring settings for its users, it's always been a half-***ed result for me. I've had to go into each app and check whether settings were restored, most were done partially. And yes, I made sure to Sync up the N4 before I started up the N5.
    11-18-2013 02:07 AM
  2. TechZOnline's Avatar
    11-18-2013 06:51 AM
  3. Gekko's Avatar
    no problems here.

    Nexus 5 + Netgear WNDR3400

    WPA2-PSK [AES]
    11-18-2013 07:39 AM
  4. N4Newbie's Avatar
    I have seen reports specifically concerning problems with the 5 GHz Wi-Fi band. Try forcing the phone to 2.4 GHz Only mode and see if that resolves the problem. Settings -> Wi-Fi -> Menu -> Advanced -> Wi-Fi Frequency.
    11-18-2013 07:52 AM
  5. TechZOnline's Avatar
    I'll try that, but since I have tried all 4 SSIDs (2 per router, since each router can do both 2.4 and 5ghz), I suspect it won't help.
    11-18-2013 01:42 PM
  6. Shilohcane's Avatar
    No issues with Linksys E2500 N600 Dual Band Wi-Fi Router after Settings -> Wi-Fi -> Menu -> Advanced -> Wi-Fi Frequency. to 5GHz ONLY.

    When back and turned off Wi-Fi then set it to 2.4 GHz ONLY and still worked just fine with WPA/WPA2 PSK security on.

    So Auto, 5.0 Only and 2.4 Only all works well connecting to Google's Play Store.
    11-18-2013 02:53 PM
  7. y2whisper's Avatar
    Only two things I can think of is trying to turn of wi-fi optimisation. And wondering if your wifi is set to an incorrect country settings. There is at least one app out there that will help you change that. Some custom roms for my n10 enabled this in settings (then i discovered it was set to japan when I was in canada and fixed my issues)
    11-18-2013 03:02 PM

Similar Threads

  1. Nexus 5 wifi calling
    By ssrini12 in forum Google Nexus 5
    Replies: 31
    Last Post: 05-19-2015, 07:38 PM
  2. help with wifi usage.
    By Amin09 in forum General Help and How To
    Replies: 2
    Last Post: 11-17-2013, 10:25 AM
  3. how to play a Google Keep audio file
    By rgraham1 in forum General Help and How To
    Replies: 0
    Last Post: 11-17-2013, 09:17 AM
  4. Google play services down?
    By Motogameruk in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 11-17-2013, 08:42 AM
  5. Replies: 6
    Last Post: 11-17-2013, 02:28 AM
LINK TO POST COPIED TO CLIPBOARD