Shop Holiday deals at: Amazon | Walmart | Best Buy | Dell | Samsung

  1. Mark1010's Avatar
    Cannot open videos from Photos app due to "Media not found" error, despite being able to open in MX Player manually

    When I open the the Photos app and view one of my media folders (containing pictures and videos, jpg and mp4 file types) Photos app shows the pics okay, but not the videos. When I tried to open a video photos app reports on a black screen "Media not found." Furthermore, if I tap the centre of the screen (where the "message media not found" is displayed) the message is replaced by "Can't play video" error message in the centre of the screen. See attached screenshots.

    However, I can open the mp4 in MX Player from Android File Browser.

    This is really bugging me, please help!

    Thanks for any help.

    I have a Nexus 5 running Android 4.4.2, build KOT49H as of 01 May 2014.

    I'm not sure whether this is a generic Android issue or a Nexus 5 specific issue, although I've posted it here anyway.
    Attached Thumbnails -picture1.jpg   -picture2.jpg   -picture3.jpg   -picture4.jpg  
    05-01-2014 07:35 AM
  2. PAC757's Avatar
    I've had this problem happen to me along with the "no SD card found" error trying to open the gallery. I don't know what fixes it, sometimes it just goes away eventually by itself, other times a reboot fixes it.

    Posted via Android Central App
    05-01-2014 08:32 AM
  3. Mark1010's Avatar
    Thanks for your input Pac. I have just restarted my Nexus 5 but the problem remains.

    I'm open to any other ideas from anyone.

    Sent from my Nexus 5 using AC Forums mobile app
    05-01-2014 08:43 AM
  4. B. Diddy's Avatar
    Welcome to Android Central! Can you access the video using the stock Gallery app (not Photos)?

    Try going to Settings/Apps/All, selecting Google+, and tapping Clear Cache and Data. Then open Photos again, let the database repopulate, and see if it works now.

    The other thing to try is a cache partition wipe, which won't erase any personal data:

    Posted via Android Central App--please excuse the brevity and any typos!
    05-01-2014 10:00 PM
  5. Mark1010's Avatar
    Thanks B. Diddy for your very helpful input.

    Try going to Settings/Apps/All, selecting Google+, and tapping Clear Cache and Data. Then open Photos again, let the database repopulate, and see if it works now.
    The problem remains after doing this. It seems that this is a defect in the Photos app, that is the Photos app is not able to recognise movie files as expected, at least not my mp4 files.

    However, thank you, thank you!! The Gallery app provides a similar interface to the Photos app and can play the movies (or rather it recognises them as movie files and then opens them in MX Player). I did not notice the Gallery app even existed as I tended to access my Photos by swiping left from the Camera app. I wonder why there are two stock Android apps that's both function with such similarity.

    Anyway, thank you again.

    B. Diddy likes this.
    05-02-2014 05:48 AM
  6. B. Diddy's Avatar
    Glad you found a solution! The Gallery app has been around forever, while the Photos app (part of Google+) was recently introduced. They do very similar things, but Photos has a few more editing functions, I think, and is fully integrated with Google+. Many believe that Google will eventually phase out the Gallery app, but presumably they'll fix all the bugs in Photos first.

    I would encourage you to let Google know about your issue by opening Photos, tapping Menu, then Feedback.

    Posted via Android Central App.
    Please excuse any typos or autocorrect derps.
    05-02-2014 01:39 PM
  7. Mark1010's Avatar
    Thanks. Okay I have just sent the issue to Google via the Photos app . Thanks again

    Sent from my Nexus 5 using AC Forums mobile app
    B. Diddy likes this.
    05-02-2014 02:27 PM
  8. ambientdata_digital_forensics's Avatar
    This is happening on my Note 3 4.2. Very annoying. No fix works.
    12-26-2014 05:55 PM
  9. INDroid 64's Avatar
    Looks like we all have either disabled or deleted the 'Media Storage' app. Try to enable that in setting>apps>disabled (or it'll be down in 'all' section) or install it if you finger a way to install it back if you have deleted it.
    04-04-2017 10:59 PM

Similar Threads

  1. Recent upgrade to 4.4.2 on LG G2
    By Chris Belton in forum Legacy Android & Other OS's
    Replies: 4
    Last Post: 05-02-2014, 06:44 PM
  2. Replies: 4
    Last Post: 05-01-2014, 12:58 PM
  3. Switching from 4G to 3G
    By Xanth269 in forum Motorola Droid MAXX
    Replies: 1
    Last Post: 05-01-2014, 11:21 AM
  4. removing blank screens in Nova
    By nyartist in forum Moto X
    Replies: 2
    Last Post: 05-01-2014, 07:57 AM
  5. How to get lg gpad 8.3 back to stock Android
    By DCSholtis in forum Software Development and Hacking
    Replies: 0
    Last Post: 05-01-2014, 07:28 AM