1. ttwiitch's Avatar
    I'm extremely frustrated with this matter. I waited patiently for this update that supposedly was going to fix this issue and it did not!

    Before anyone suggests 3rd party alternatives, I would like for my REGULAR voicemail to work like a very one else's, and not having a third party app.

    I called Sprint and they forwarded me to technical support (big help!...not) and they completely refreshed and reset my voicemail. Did not work. Brought it in to the repair center, they did NOTHING.

    I have very important calls coming in and many times I can't answer. I need voicemail notifications! Is it that HARD for Google to do this right!?!

    What should I do???

    Sent from my Nexus 5 using AC Forums mobile app
    06-05-2014 06:26 PM
  2. Gekko's Avatar
    your problem is Sprint.
    06-05-2014 06:34 PM
  3. Almeuit's Avatar
    Are you sure it's Google? I haven't seen others complaining about voicemail.. And my buddy who had the nexus 5 before the S5 didn't mention anything about it.

    Sent from my T-Mobile Note 3 using AC Forums.
    06-05-2014 06:46 PM
  4. N4Newbie's Avatar
    your problem is Sprint.
    Agreed.
    06-05-2014 06:52 PM
  5. ttwiitch's Avatar
    Are you sure it's Google? I haven't seen others complaining about voicemail.. And my buddy who had the nexus 5 before the S5 didn't mention anything about it.

    Sent from my T-Mobile Note 3 using AC Forums.
    I'm 100% its a software problem that's not compatible with something to do with Sprint. Google had said this was one of the fixes....yet here we are.

    Sent from my Nexus 5 using AC Forums mobile app
    06-05-2014 06:58 PM
  6. Almeuit's Avatar
    I'm 100% its a software problem that's not compatible with something to do with Sprint. Google had said this was one of the fixes....yet here we are.

    Sent from my Nexus 5 using AC Forums mobile app
    That sucks .

    Sent from my T-Mobile Note 3 using AC Forums.
    06-05-2014 09:30 PM
  7. Jaramie10's Avatar
    I had this exact issue with sprint. Li wound up leaving them for T Mobile.

    Posted via Android Central App
    06-05-2014 10:04 PM
  8. Zense's Avatar
    I am with Sprint and have no problems with my voice mail, no visual voice mail app but I get an icon in my notification bar when I receive a new message.
    06-06-2014 01:06 PM
  9. ttwiitch's Avatar
    I am with Sprint and have no problems with my voice mail, no visual voice mail app but I get an icon in my notification bar when I receive a new message.
    Has it always worked? Are you on 4.4.3?

    Sent from my Nexus 5 using AC Forums mobile app
    06-06-2014 01:35 PM
  10. Zense's Avatar
    When I first activated my phone I had some issues with the notification not going away. Called Sprint, they reset my voice mail and since then no problems at all.

    Yes I am on 4.4.3
    06-06-2014 07:27 PM
  11. brodieb's Avatar
    I am also with Sprint and have zero issues with voicemail. I get the icon and it works just fine. I do wish we had a visual VM app but it works the old school way.

    Posted via Android Central App
    06-06-2014 08:03 PM
  12. ttwiitch's Avatar
    I am also with Sprint and have zero issues with voicemail. I get the icon and it works just fine. I do wish we had a visual VM app but it works the old school way.

    Posted via Android Central App
    When I first activated my phone I had some issues with the notification not going away. Called Sprint, they reset my voice mail and since then no problems at all.

    Yes I am on 4.4.3
    I wish.... Sprint has reset my voicemail twice already these past 2 says and it still didn't fix it.

    I will prob do a factory reset, what do you guys think??

    Sent from my Nexus 5 using AC Forums mobile app
    06-06-2014 08:34 PM
  13. Zense's Avatar
    After upgrading I always do a factory reset. It can be a pain at times but I think its best to start with a clean slate. A lot of the times people have issues after updates, and a majority of them are eliminated by doing a reset. I am not saying its a must its just my preference.
    ttwiitch likes this.
    06-07-2014 12:46 PM
  14. ttwiitch's Avatar
    After upgrading I always do a factory reset. It can be a pain at times but I think its best to start with a clean slate. A lot of the times people have issues after updates, and a majority of them are eliminated by doing a reset. I am not saying its a must its just my preference.
    Cool, thanks for your input.

    Sent from my Nexus 5 using AC Forums mobile app
    06-07-2014 04:25 PM
  15. Ed Briggs's Avatar
    Actually, the best way to do it would be to flash the factory image. No "upgrading", and no factory reset needed. A TRUE clean install is always best.
    06-08-2014 11:14 PM
  16. ttwiitch's Avatar
    Voicemail is now working to perfection after 4.4.4 ๐Ÿ‘Œ๐Ÿ’ช

    Just thought I'd update โœŒ

    Sent from my Nexus 5 using AC Forums mobile app
    07-02-2014 05:22 PM
  17. LightaDroid's Avatar
    Voicemail is now working to perfection after 4.4.4

    Just thought I'd update โœŒ

    Sent from my Nexus 5 using AC Forums mobile app
    Awesome!!.. I was going to say. Im on Sprint and I too have the Nexus 5 and never had a problem with voicemail.
    but then again I did the update to kit kat 4.4.4 last week.

    - - - Updated - - -

    Voicemail is now working to perfection after 4.4.4 ๐Ÿ‘Œ๐Ÿ’ช

    Just thought I'd update โœŒ

    Sent from my Nexus 5 using AC Forums mobile app
    Awesome!!.. I was going to say. Im on Sprint and I too have the Nexus 5 and never had a problem with voicemail.
    but then again I did the update to kit kat 4.4.4 last week.
    ttwiitch likes this.
    07-02-2014 05:34 PM
  18. Shilohcane's Avatar
    I read some where a few weeks ago when Sprint leaked the first report about 4.4.3 release that Sprint had some code included in 4.4.3 that enabled their Spark data network in 4.4.3.
    07-02-2014 05:50 PM
  19. ttwiitch's Avatar
    I read some where a few weeks ago when Sprint leaked the first report about 4.4.3 release that Sprint had some code included in 4.4.3 that enabled their Spark data network in 4.4.3.
    What does that have to do with voicemail?

    Sent from my Nexus 5 using AC Forums mobile app
    07-02-2014 07:16 PM
  20. StealthTH's Avatar
    I'm on sprint and agree VM service is lacking. What they need to do is be like the other carriers and add an VM app on the playstore that works with unlocked / unbranded devices.

    In the mean time though, I have my VM forwarded to Google voice (which is free) and it works great! I recommend trying it out.

    Posted via Android Central App
    07-02-2014 09:28 PM
  21. ttwiitch's Avatar
    I'm on sprint and agree VM service is lacking. What they need to do is be like the other carriers and add an VM app on the playstore that works with unlocked / unbranded devices.

    In the mean time though, I have my VM forwarded to Google voice (which is free) and it works great! I recommend trying it out.

    Posted via Android Central App
    Actually, Google is the one that needs to implement VM on Nexus and GPE devices just like iPhone does for every carrier.

    Sent from my Nexus 5 using AC Forums mobile app
    07-02-2014 11:11 PM
  22. jkayakj's Avatar
    visual voicemail is up to the carrier... ATT has their app in the play store etc.. So its not really on google but is instead on sprint to open up their APK for their voicemail..
    08-09-2014 01:42 PM
  23. avidSomnambulist's Avatar
    I have had the same problem. I got my first Nexus 5 from Sprint about a month after Google released it. Ever since then, a notification reading "New voicemail (2): Dial XXX-XXX-XXXX" has hung around my notifications bar, disappearing only when I force terminate the built-in phone app (and then reappearing sometime in the next ~15secs-5mins). When I lost that phone and got a new one in mid-July (this time directly from the Play Store, updated to 4.4.4 on first boot), the notification appeared again,. It still didn't go away, and is now sitting on my Android 5.0 lockscreen. It's probably worth noting that I'd been using Google Voice for over a year when the N5 was released, and that neither any of the phones I'd had, Android or otherwise, before getting my first N5 or in the interim between my two N5's, had this or any similar issue. I dimly recall trying to completely disconnect my Sprint and GV accounts soon after getting the first N5 in order to fix it, but I don't think I finished the process. My best guess as to how to fix it would be to completely disconnect my Sprint and GV accounts, go through my Sprint voicemail (calling Sprint to have it cleared as ttwiitch did if necessary), maybe wait a few days to make sure that both Sprint and Google had properly processed/registered/recognized the disconnection, and then start from scratch. But I really don't want to go through all the pain of doing that. It's annoying, but it's not *that* bad. I'll update if I make any progress.
    11-15-2014 06:45 PM

Similar Threads

  1. google play services not working sometimes
    By Pookachee in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 11-02-2014, 08:09 PM
  2. Replies: 8
    Last Post: 08-12-2014, 03:44 PM
  3. S4 Active 4.4.2 Bluetooth issue - Buttons not working
    By Christoffer Antonsen in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 06-05-2014, 05:57 PM
LINK TO POST COPIED TO CLIPBOARD