1. hell911's Avatar
    im having problems with GPS, i have tried different gps/maps apps, it just wont figure out my location. im trying the option "Device Only" "use GPS to determine your location".

    i have also tried the option, "use wifi, gps, and mobile networks", still no change.
    07-20-2014 12:50 PM
  2. N4Newbie's Avatar
    Have you tested it outdoors, with a clear view of the sky?
    07-20-2014 01:08 PM
  3. hell911's Avatar
    yes
    07-20-2014 01:35 PM
  4. flattie's Avatar
    I know there were a few N5s that were (or are) having GPS connectivity problems. Mine was one of them. My GPS would seldom pick up more than 2 or 3 satellites (often none) and would forever lose connection when using the navigation mode of Google Maps. I sent it to Asus for repair, who replaced the rear cover, which houses the GPS antenna. This cleared the problem completely. My GPS performance is now quick and rock solid.

    Looking into the problem further seems to indicate that the sprung contacts for the antenna have not been making a very good connection for many users. Some have fixed this themselves with minor DIY alterations, whereas others have sent the phone in for repair.

    Posted via Android Central App
    07-22-2014 05:10 AM
  5. grasman94's Avatar
    Happened to me. Location was not accurate and it wouldnt even give me the right routes (i.e. taking the highway instead of local roads) .. a full reset fixed my problem.
    07-23-2014 01:09 PM
  6. jvai's Avatar
    i've noticed it recently leaving the subway, google now would give me feedback on the last known location miles away;

    what i do to hasten it as of lately, is open the maps app, & hit the location button making it blue, to *awake whatever was asleep* & move away from any tall obstructions t have a clear line of site to the sky..

    after about less than a minute, it picks up..

    & gives me directions from the subway, to my kitchen.. lol
    07-23-2014 02:46 PM
  7. hell911's Avatar
    ok, my gps just worked. i had to leave the map application for around 1-2 minutes before it picked up the signal.
    07-25-2014 01:47 PM

Similar Threads

  1. Play Services draining, but not both devices?
    By theprimogenitor in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 07-20-2014, 12:39 PM
  2. Replies: 1
    Last Post: 07-20-2014, 11:48 AM
  3. samsung galaxy core not charging
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-20-2014, 10:54 AM
  4. Replies: 2
    Last Post: 07-20-2014, 10:10 AM
LINK TO POST COPIED TO CLIPBOARD