1. DashEndar's Avatar
    I have a Nexus 5 on Sprint. I went out of the country and decided out of curiosity to see if I could connect to the international network. It didn't work. I came back now, but I now have this issue with the network. When I'm on LTE it says "Sprint" and everything seems normal, but when I'm connected to 3G it continuously says "Searching for Service" rather than "Sprint." It still works and is connected, but I don't understand how because when I go to update the PRL and Profile it says I can't do it with no service. I'm a bit confused and I haven't been able to find a solution on google. Is this an issue where I should just take out and put back in the SIM card? Thanks in advance!
    08-16-2014 09:25 AM
  2. Golfdriver97's Avatar
    Try powering down and reinserting the sim card.
    08-16-2014 09:45 AM
  3. DashEndar's Avatar
    I just tried that, and now I can't even register on the sprint network. It's telling me that sprint is unavailable when I go to the available networks page.
    08-16-2014 09:59 AM
  4. Bront's Avatar
    Try clearing your cache. I had a similar issue that was caused by cache corruption.
    08-17-2014 01:42 PM
  5. Q-fugee's Avatar
    The exact same thing happened to me, pretty much on the same day as you. I roamed with an international SIM for a while, and couldn't connect to Sprint voice when I came back.

    Sprint was zero help, since there are so few of these on the Sprint network they never see this problem.

    After 10 hours on the phone and in the store with Sprint, I finally found the solution myself. You have this problem:


    It's a known bug in the CDMA radio stack of Android 4.4.4, and even a factory reset won't help. Your choices are a new phone (they'll replace it under warranty or TEP or charge you 75 bucks) or reflash it yourself. Sprint stores can't reflash the firmware, so you're on your own. It's actually not that hard.

    Some folks on the Google forum thought clearing out the APN settings would work, but they didn't for me. You could try that before doing the drastic stuff.

    Back up your phone, write down your MDN and MSID, reflash back to 4.4.3 or 4.4.2, and put the Sprint SIM back in. You may need to have customer care or the website self-service reactivate it like it's a new phone. Once it reboots, it'll update back to 4.4.4 over-the-air.

    Sound difficult? The WugFresh Nexus toolkit almost makes this a one-click process:

    Nexus Root Toolkit v1.8.6 | WugFresh

    I'd be lost without that toolkit. Even if you get them to replace the phone, you'll want to use the NRT to back up the old one first.

    In the end, you'll have an unlocked rooted Nexus 5 to show for your troubles. I know it sounds ridiculous that you have to go through all this just because you swapped your SIM card, but it's Google's fault for not adequately testing 4.4.4 before foisting it on the six of us who use the N5 on Sprint.

    08-19-2014 02:17 PM
  6. Dave Gutknecht's Avatar
    I had a similar problem. I went to Australia and used a Telstra pre-paid Sim. While in Australia I got the 4.4.4 Release 2 update and unfortunately took this update, not knowing is was for Australia only.
    When I returned to the US, I put my Sprint Sim back in and everything works, except for outgoing calls.

    I flashed stock down to 4.4.2, verified that outgoing calls worked and then took the OTA updates to 4.4.3 and then 4.4.4 Release 1.
    Everything still worked after the OTA updates.
    08-21-2014 09:13 AM

Similar Threads

  1. Nexus 5 Multicast
    By Raajpoot in forum Google Nexus 5
    Replies: 2
    Last Post: 12-31-2014, 12:49 PM
  2. Help! I may have lost my photos on my micro SD card!
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 08-18-2014, 04:40 PM
  3. Replies: 5
    Last Post: 08-18-2014, 11:28 AM
  4. Charging port help! Please help!
    By Tristin Hill in forum Samsung Galaxy S4 Active
    Replies: 5
    Last Post: 08-16-2014, 06:39 PM
  5. Replies: 2
    Last Post: 08-16-2014, 11:35 AM