1. Frank McElroy's Avatar
    I have a Nexus 5, and have just been updated to Android Lollipop 5.0

    When I got a voicemail notification, but when I tried to access my voicemail from the notification it said I hadn't setup my voicemail number. that was funny because it was setup before the Update. Then when I went into settings and tried to setup my voicemail access number - it would not save it .

    I am on O2 in the UK and the voicemail access number is 901
    11-21-2014 10:46 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! How are you trying to edit the voicemail number? Are you opening the Dialer, tapping Menu>Settings>Call Settings>Voicemail>Setup? What happens when you enter the number and tap OK? Do you get an error message, or does it seem like it accepts the number but just doesn't change it?

    Have you asked O2 if they're aware of any issues?
    11-21-2014 11:38 AM
  3. Ron Wilson3's Avatar
    I had same problem and tried everything no success. It would not save the voicemail number. Was playing with it tonight and tried putting my cellphone number into voice mail. It saved and when I dialled 1 on dialpad it wen to to my phone.
    Heartened I went back to voicemail settings and re entered the correct voicemail number and it saved. Tested it and it works fine. I am tempted to think that there has been an update to Android somehow but have certainly not instakked any updates except the original Lollipop.
    Weird. Suggest you try changing to your own number and saving it and then change it to gthe voicemail number.
    see what happens
    11-23-2014 03:11 AM
  4. andyhurley's Avatar
    I had a similar problem in that my Nexus5 seemed to have 'forgotten' the voicemail number after the 5.0 upgrade (OTA) but I was able to set it and then call voicemail from the voicemail notification.

    For what it is worth I also use the O2 network in the UK but I'm with their MVNO Gifffgaff which has a different voicemail number. I had a previous phone that would not allow me to change away from the default O2 voicemail number but I have not had that problem since getting the Nexus5.
    11-25-2014 09:49 AM
  5. Alexandre Mansur's Avatar
    I did it.
    First, go to the app for calling. Then click in the three points (...) on the right side of the search field. Select configurations. Then "calling configurations". Then "voicemail" . Again "configuration". And enter your voicemail number.
    Good luck.
    11-28-2014 04:52 PM
  6. Frank McElroy's Avatar
    Thanks everybody for your responses, like Ron Wilson 3 above, it now seems to be working.

    Whereas before, opening the Dialer, tapping Menu>Settings>Call Settings>Voicemail>Setup when I entered "901" it did not allow me to save it (pressing 'OK' was ignored). So I put in my roaming voicemail number (i.e. the voicemail access number I use when roaming when 901 is not supported - it is a normal phone number). But this was far from ideal, as using this number I have to tap in a password each time to access my voicemail - OK when you're abroad, but a pain when you have to do it every time. Then like Ron when I went back to settings, and re-set the number to "901" it worked this time.

    Perhaps the first time you setup this number there is some sort of check that it is a valid phone number - which is not carried out when you are resetting it?? Or perhaps there has been a minor update in the background fixing the problem?

    Anyway - problem solved for me - thanks again everyone for the help.
    12-07-2014 07:46 AM
  7. Bob Douglas's Avatar
    I too am having same problem with Nexus 5.
    I am on Tesco mobile. I enter the number in call settings. It just does not save (Lollipop)
    01-27-2015 05:03 PM
  8. TEastwold's Avatar
    Exactly like the original poster, this function worked fine before the 5.0 upgrade yesterday. Now, I have tried all of the suggestions in this thread and nothing works. I am trying to establish the dialing string of *86,,XXXX#. *86 is the dial number for Verizon Voicemail (,, is two pauses) the XXXX is my numeric VM Password and the # is required to signal that you are through entering your password. I can enter this and save it. In fact, when I look at the VM notification it says I have 2 messages and the number (*86,,XXXX#) is listed below. When chosen either by clicking the notification or by holding down the 1 button on the dialpad, the Voicemail system answers and says "Please enter your password and press #", but nothing else happens. Like I say, this was working perfectly before and the phone would immediately dial "XXXX#" Tried resetting the phone, also at the suggestion of a technician, I looked up the Phone app in the Application Manager, Forced Closed, Cleared Data, turned off phone and restarted, again with no joy. The only weird thing is that when looking in the Application manager, there were three "Phone" apps in the list. One of them had the Icon of the android with a gear in it's belly (android system file?", the other 2 had the normal Phone icon I see on my phone screen and were the same version. I have a friend here in town that also has the S5 that is having the exact same issue.

    Any Help would be appreciated. I might open a new thread just to open this as a new discussion.

    Thanks for your consideration.
    02-04-2015 07:45 PM
  9. juan reynaga's Avatar
    are you trying to edit the voicemail number
    open the Dialer, tapping Menu>Settings>Call Settings>Voicemail>Setup

    if it does not save it.
    put the original carrier SIM card and change the voicemail number and then switch the sim card again.

    like please!
    07-27-2015 04:53 PM
  10. damon05's Avatar
    I just got this to work!!! You have to be in an active call in order to change it. I called myself from my home number, went to settings during the call, and changed it!
    09-26-2015 10:42 PM
  11. t lo's Avatar
    Worked for me too.
    I have been trying to reset Straight Talk Voice Mail for 3 hours. I called Straight Talk. Went 3 different times 3 different people. Each time, they assured me that I was now back on track. But it never worked.
    Then I tried my phone itself. I had discovered my old message was in my phone settings but with a different NUMBER. When I called it, it played my old prompt. After I saw this suggestion I figured to give it a shot or microwave the phone and mail the melted blob to Straight Talk.

    So, as it mentions in this forum, I called my number and while that was in progress I went to settings and changed the phantom number to my actual number and hit OK.
    Suddenly it went into action and I have my voice mail back. (It was with a crappy new message I had plugged in, but I'll change it to something beautiful when I get brave.)

    It's obviously some kind of plot. But we won this one.
    11-17-2015 10:30 PM
  12. imran9999's Avatar
    I had the same problem. To fix I changed the number, saved and restarted the phone. Upon restart I saw that the number had been retained.
    12-12-2015 10:10 PM
  13. xolon's Avatar
    I have Android 5.1, so I'm assuming that's what you've upgraded to. Took me a while to find any info that resembled anything close to what my phone showed.

    These are the steps that I took, after much searching.

    1. open dial app
    2. click on the three dots at top right
    3 choose settings
    4 choose calling accounts
    5 click on your phone service - mine is vodafone
    6 choose voicemail
    7 choose setup
    8 choose voicemail number by typing in your short code 121 for vodafone
    9 choose OK
    And then it should pick your service provider bits and pieces, saved it and then you should be able to press and hold the number 1 key to go to voicemail.

    Hope this helps!!
    03-21-2016 04:09 PM
  14. Rojan Shakya's Avatar
    I just got this to work!!! You have to be in an active call in order to change it. I called myself from my home number, went to settings during the call, and changed it!
    can't thank you enough...been loosing sleep over this
    03-22-2016 10:23 PM
  15. Krystal Williams2's Avatar
    I just got this to work!!! You have to be in an active call in order to change it. I called myself from my home number, went to settings during the call, and changed it!

    I'm using a Unlocked Verizon Galaxy S5 G900A on AT&T network and this worked for me
    04-27-2016 12:03 AM

Similar Threads

  1. Replies: 4
    Last Post: 05-29-2017, 10:16 PM
  2. Any news on a Lollipop update?
    By javierlp in forum OnePlus One
    Replies: 17
    Last Post: 01-13-2015, 12:52 PM
  3. Default Navigation / Geo Apps with Lollipop
    By Matt McHeck in forum Legacy Android & Other OS's
    Replies: 3
    Last Post: 11-25-2014, 05:51 PM
  4. Why am I having issues with my Nexus 5 since the Lollipop update?
    By Melanie Carvalhal in forum General Help and How To
    Replies: 3
    Last Post: 11-24-2014, 10:36 PM
  5. Need Help Deciding on New Phine
    By An-Droid-M in forum Ask a Question
    Replies: 3
    Last Post: 11-21-2014, 01:04 PM
LINK TO POST COPIED TO CLIPBOARD