1. Eleni Nikolaou's Avatar
    hello
    1 week ago i send my nexus 5 to the service because it was rebooting after google logo appears...after 2 days the send my device back.They didn't fix it cause of liquid damage... yes liquid sensor was red...they send a paper witch it says that lcd,battery,fpc flex,mainbord sort circuit due to liquid damage ...after 5 days i open my self the phone and i realize that the problem was on the power button...and voila!!!the phone open again,everything works fine except gsm signal .... after i insert the sim card it says "no service"sim card works i test it to an other phone. is any way to test quallcom transceiver?when i realize that the devise works i make update to 5.1 so i don't know if gsm works with older version.i think this is a hardware problem. Any thoughts?
    04-08-2015 07:40 AM
  2. DLK1's Avatar
    May want to open it back up and make sure that that the cable from the antenna is connected to the logic circuit board.
    04-08-2015 06:21 PM
  3. Rukbat's Avatar
    It sounds more like the SIM card reader got damaged by being wet. Considering the cost of the phone versus the cost of replacing everything that's going to keep going bad after you replace the motherboard, I'd say the phone isn't worth repairing. A repair of everything will cost more than a new phone.
    04-17-2015 01:01 AM

Similar Threads

  1. Replies: 2
    Last Post: 03-28-2016, 10:58 AM
  2. Why am I unable to open a preferred network type?
    By Maher Afrasiab in forum Huawei
    Replies: 2
    Last Post: 11-12-2015, 11:54 PM
  3. How to root a Lenovo P70?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-16-2015, 10:07 AM
  4. Do I have to upgrade to Lollipop?
    By Hunter8282 in forum Samsung Galaxy Note 4
    Replies: 14
    Last Post: 04-09-2015, 12:12 AM
  5. Replies: 1
    Last Post: 04-08-2015, 07:33 AM
LINK TO POST COPIED TO CLIPBOARD