1. calnastic's Avatar
    Today I got my new nexus 6, I set up wireless network, threw in a nano sim card, entered my google login information, when prompted about restoring from my other android tablet I chose NO. After some google account settings it started "Restoring" process and it never come to an end. It has been about 3 hours. I tried to restart the device but it always comes back to the Restoring, I tried to unplug sim card, or enter the bootloader mode(the device was locked), nothing helped.

    Any suggestions? Is the restoring process supposed to take this long?

    Thanks.
    11-09-2015 08:31 PM
  2. yankeesusa's Avatar
    Go into recovery mode and hard reset again.

    Posted via the Android Central App
    11-09-2015 08:34 PM
  3. calnastic's Avatar
    Thank you, it solved the problem.
    11-12-2015 09:17 AM
  4. yankeesusa's Avatar
    Thank you, it solved the problem.
    Awesome

    Posted via the Android Central App
    11-12-2015 09:39 PM

Similar Threads

  1. Moto X Play Back on the Maxx 2
    By Von Spradlin in forum Motorola Droid MAXX 2
    Replies: 1
    Last Post: 12-10-2015, 12:42 PM
  2. Wugfresh toolkit Nexus 6
    By Satanic Mailbox in forum Google Nexus 6
    Replies: 3
    Last Post: 11-10-2015, 11:32 AM
  3. Google Play not working on Android 2.2 Froyo?
    By Moonshadow830 in forum General Help and How To
    Replies: 0
    Last Post: 11-09-2015, 08:23 PM
  4. Can I get some help finding files on my Note 5?
    By RealtorROb in forum General Help and How To
    Replies: 0
    Last Post: 11-09-2015, 07:47 PM
  5. How do you tell if your cell phone is on a GSM network or a CDMA network?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 11-09-2015, 07:28 PM
LINK TO POST COPIED TO CLIPBOARD