1. caesar305's Avatar
    Hello!

    After the most recent update to Google Photos it seems many of my "albums" (folders) are missing from the Photos app. For example, SnapChat, Twitter, Viber, etc. are no longer available on the app and therefore can not see any photos. To make matters worse, the dialog box for sharing/sending photos also has this issue. I guess somehow the photo app or whatever was updated also affected the sharing dialog box. If I try to send a photo to someone via skype, whats app, etc. the dialog box that opens now only shows the photos in my camera, none of the other photos are available.

    Anyone know how to fix? I downloaded Astro file manager and I can see the folders and photos. There were no .nomedia hidden files either.
    07-04-2016 11:19 AM
  2. N4Newbie's Avatar
    Open the Google Photos app on your phone, tap the hamburger menu at top-left, tap Settings, tap Backup & sync, tap Back up device folders, enable desired folders.
    kct1975 likes this.
    07-04-2016 11:29 AM
  3. caesar305's Avatar
    Yeah tried that but the folders I am looking for are not there. I can see snapchat, viber and whats app folders in Astro File Manager but not on here in this settings menu.
    07-05-2016 12:30 AM
  4. caesar305's Avatar
    After rebooting I can see viber and twitter, but still missing whats app and snapchat.
    07-05-2016 12:32 AM
  5. N4Newbie's Avatar
    After rebooting I can see viber and twitter, but still missing whats app and snapchat.
    So far as I know, it should see any folder which a) has one or more media files present and b) does not contain a file named ".nomedia" (I think that is the correct name).

    Use Astro file manager to confirm the above.
    07-05-2016 09:44 AM
  6. caesar305's Avatar
    Yes I used Astro, that was one of the first things I did after searching online. Snapchat and whats app is still missing. Even the downloads folder is missing now. I used to be able to save an image from a website and then go to whats app and attach it from the dialog box that opens (go to downloads album). Now they are missing. I contacted Nexus support and they told me these features were removed in the last photos update.... what?
    07-05-2016 08:23 PM
  7. JBoen's Avatar
    If you go to the Google Photos, try to swipe right from the left edge you should see device folders. From there you will see all your photos, now you can check whether it is synced or not from the cloud icon on the right hand side of the folder. Probably you didnt turn the cloud sync on.
    07-11-2016 03:54 AM
  8. Mike Dwyer1's Avatar
    I have fixed this problem! I've had the same issue for over a year and never found any help other than people saying to make sure the folder was marked as sync in Google Photos. Several of the albums I had created simply did not appear. I wish I could explain why the problem occurred in the first place (still haven't figured that out) but the solution is fairly simple...

    - Plug your phone into a PC via USB cord and open up the phone on the PC.

    - There are two folders you want to check out. The first is Pictures. This will show all of the albums that should also be appearing in Google Photos. If necessary, make a note of these.

    - Back out of this folder and open the folder called DCIM. Within this you will see the rest of your albums which are not showing up in Google Photos.

    - This step has some risk of accidental deletion so be careful... Select the albums that you need to see in Google Photos and right-click, Cut. *DO NOT SELECT THE CAMERA ALBUM*

    - Go back to the Pictures folder on your phone and paste the Cut albums there.

    - When this is complete, unplug your phone and check Google Photos. The albums should all be there now.

    Hope this helps.
    07-23-2017 12:37 PM
  9. 2015CamAUS's Avatar
    Finally someone found the answer. All the other responses seem to be overlooking the issue that we cannot see the folders in the list. The solutions keep saying to select them ... but we cant see them! Thanks your simple solution works well. IE Google photos cant see DCIM folders (apart from camera). It can only see folders with photos outside DCIM. So cut and paste them all to Pictures works fine. Would be a nice bug for Google to fix.
    08-31-2017 08:23 PM
  10. zcs72's Avatar
    I found another solution. Though it may not apply to you. I found that several folders I'd created were automatically put in DCIM/extra. Used ES Explorer to move them to the Pictures folder and... They now show in Google Photos. No idea why they were in the "extra" folder to begin with.
    JoniEsq likes this.
    09-16-2017 06:07 PM
  11. JoniEsq's Avatar
    I don't have a "Pictures" folder, but moving folders from DCIM to the top level directory on my SD card enabled Google Photos to see them. I was missing a year of my camera photos, at first, but updating the app fixed that. Moving the folders fixed being able to see them. And BTW, I did this on the phone in MyFiles app that came with the Galaxy S7, and not my PC. It was only seeing the camera folder for some reason, as a sub-folder.
    12-08-2017 09:39 PM
  12. thiagooliv's Avatar
    Just go to the folder using a good file manager, create a file called .nomedia and then delete it.
    03-28-2018 01:15 AM
  13. niloferislam's Avatar
    Thanks a ton!! my pics were in DCIM folder I moved them in Pictures folder and it works


    I have fixed this problem! I've had the same issue for over a year and never found any help other than people saying to make sure the folder was marked as sync in Google Photos. Several of the albums I had created simply did not appear. I wish I could explain why the problem occurred in the first place (still haven't figured that out) but the solution is fairly simple...

    - Plug your phone into a PC via USB cord and open up the phone on the PC.

    - There are two folders you want to check out. The first is Pictures. This will show all of the albums that should also be appearing in Google Photos. If necessary, make a note of these.

    - Back out of this folder and open the folder called DCIM. Within this you will see the rest of your albums which are not showing up in Google Photos.

    - This step has some risk of accidental deletion so be careful... Select the albums that you need to see in Google Photos and right-click, Cut. *DO NOT SELECT THE CAMERA ALBUM*

    - Go back to the Pictures folder on your phone and paste the Cut albums there.

    - When this is complete, unplug your phone and check Google Photos. The albums should all be there now.

    Hope this helps.
    08-18-2018 07:52 AM
  14. petri71's Avatar
    I have the same problems except the content of the albums is being synched but not the album itself... meaning I can see the pictures in the photo stream but not in the album list.... why is that ?
    11-28-2018 12:43 PM

Similar Threads

  1. Google maps with multiple stops
    By IMANUT46 in forum Samsung Galaxy S5
    Replies: 14
    Last Post: 07-06-2016, 01:33 PM
  2. Google Play Music coming to India?
    By VyprNoch in forum General News & Discussion
    Replies: 1
    Last Post: 07-05-2016, 03:26 PM
  3. com.android vendiing missing
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-04-2016, 12:05 PM
  4. Why does my Nexus tablet keep resetting my Google Play games?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-04-2016, 09:18 AM
  5. Replies: 1
    Last Post: 07-04-2016, 09:11 AM
LINK TO POST COPIED TO CLIPBOARD