1. vladman's Avatar

    I've had my Nexus 6 64Gb for about two and a half years now, and it's mostly served me very well. It's quite slowed down now, and the battery has really weakened, but when it's charged it's working mostly ok.

    Unfortunately, today, the battery run down completely, and the phone shut down. I don't know if this has happened maybe once or twice ever since I've owned the phone, but it was never an issue before.

    Now, I can't get the phone to power up.

    I've plugged it into a charger and it shows the battery being charged symbol in the middle of the screen. If I attempt to power it up, the white Google logo and an unlocked padlock show up on a black screen for about 2-3 seconds, then the screen goes completely off, then 2-5 seconds later Google logo and the padlock show again, for a few seconds, and it just keeps going on like that. I don't even get the coloured Google dots.

    I can get into the bootloader (I think that's the right term), by holding the power and volume down button. I tried wiping the cache partition, and it does this, but it doesn't help and I still can't power up the phone.

    Is there anything I can do that ISN'T a factory reset? I'd like to preserve the data on the phone and not have to go through hours and hours of complicated process of fully resetting/flashing the phone and having to reinstall everything.

    I realise it may not be possible to avoid having to factory reset the phone, but I'm really hoping there are other things I can try before resorting to that.

    I'm fairly technically minded and PC literate, but haven't done much "advanced" stuff on the phones... I have once in the past flashed the phone and I think that's when I unlocked the bootloader (I'm really not sure I'm using all the right terminology here), but like I said, I'd really rather avoid doing all that again, if at all possible.

    For info, about 3-4 weeks ago I finally got the OTA update to 7.1.1 (from 7.0) and I did that and it all went smoothly and the phone worked fine, until this happened today.

    Many thanks, really appreciate all advice and help given.
    08-27-2017 01:18 PM
  2. SpookDroid's Avatar
    I'm assuming yes, but is the battery fully charged now or have you let it charge for a while before attempting to power up?

    Also try holding the power button down for 20 seconds (this usually hard-resets phones and might help with any misbehaving boot data). Also try booting into Safe Mode and see if that helps.
    08-27-2017 01:32 PM
  3. vladman's Avatar
    The phone is about fully charged now. I have initially (when it was completely dead) put it on a wireless charger, the battery symbol being charged showed up so I left it thinking all was fine. Some time later, not sure, maybe half an hour or so, I picked the phone up, thinking it will have charged some, and tried to power it up, and that's when the problems started. Since then, it's been plugged in into the original motorola Turbo charger with the original USB cable, and is now fully charged.

    I'll try the power button for 20 seconds trick (was searching before I posted here, and saw advice to try that, but in combination with holding the volume up button, tried it, didn't work). I'll try only holding power for 20 seconds.

    How would I boot it into Safe Mode?

    Thanks very much for your help.

    I need this bl**dy phone for work tomorrow, typical.
    08-27-2017 01:40 PM
  4. SpookDroid's Avatar
    I know how frustrating not having your phone can be, and more if you use it for work...

    This from Google's site for when the phone is off:
    Press your device's Power button.
    After the Google logo shows on your screen, when the animation starts, press and hold your device's Volume down button. Keep holding it until the animation ends and your device starts in safe mode.
    You'll see "Safe mode" at the bottom of your screen.

    Hope you can get it working. If the above doesn't help, try the power button held down tip but WHILE the phone is bootlooping. (So turn on, release power, let it start, while it's booting, press and hold power button until phone shuts off).
    Laura Knotek likes this.
    08-27-2017 02:19 PM
  5. vladman's Avatar
    I tried this and it didn't work. Basically, once the white Google logo and padlock show, it doesn't matter if I let go or keep holding Power forever (I held it for nearly a minute). All that happens is the looping, Google logo and padlock showing for a few seconds, disappearing, showing again, etc... Can't get past this stage, and never see the coloured animated Google dots, that should follow the white Google logo normally.

    If I press power until Google logo shows, and let go, then press Volume Down, as per that advice, all that happens is I get into the Bootloader, where I have all those options, most of which I don't know what they are/do.

    I may have even made things worse just now... I was just looking at all the options in Recovery Mode (the only one I ever used was Wipe Partition Cache, and that always worked fine), and saw something like Run Graphics Test. I selected that, and then there was a fairly fast sequence of things that happened, something like, a wavy, colourful circle appeared briefly, said something like Installing, then Android on its back and red exclamation mark appeared, and a word error, then Erasing (gulp!), then installing again, and then it just goes back to the Recovery Mode screen. So no idea what that was all about.

    I'm just reading about this, and it looks like I might be able to reflash the ROM (I wish I understood all the terminology better - is reflashing the ROM the same as installing a factory image?) without losing my data - do I understand this correctly?

    Really appreciate your help, please let me know if you can think of something else I can try?
    08-27-2017 02:31 PM
  6. SpookDroid's Avatar
    Reinstalling the ROM is basically re-installing the OS, BUT I'm not entirely sure you can do this without wiping data. I haven't delved with rooting and flashing in a while. Sorry.

    Not sure if you can press both volume buttons at once or not, but if you can, I'd try that along the Power button to see if that forces the phone to hard-shut off. If not, then volume up plus power since you've tried volume down already.

    Last thing I can think of is let it reboot the battery away. Then re-charge fully, then try again.
    08-27-2017 02:42 PM
  7. vladman's Avatar

    So, I've just tried following two guides I found, one for flashing a factory image but preserving user data, and another for applying a rescue OTA, and neither worked, even though I followed each guide to the letter, and received all the responses as the guides listed them and no errors in either process.

    For info, the guides I found and followed are:

    1. https://forum.xda-developers.com/nex...shamu-t2954008
    2. https://drive.google.com/file/d/0Bz6...1xc3lHbE0/view

    I tried the first guide first and used method 2 (as directed in another posted that led me to that guide, where another guy was asking how to fix his phone but also preserving his user data), and skipped the steps where I was supposed to flash the userdata.img file and perform factory reset. I did everything as per that guide (but skipping the steps above) and this made no difference.

    I then tried the second guide, again following it to the letter, everything was as the guide said it should be, but again, at the end, no difference. The phone just loops when trying to boot.

    So all this leads me to believe the actual userdata.img file on my phone (with all my data) became corrupt when the phone shut down when it ran out of juice.

    I think I have no choice but to perform a full factory reset, or reflash the device again, but this time flash the userdata.img file too, and get the device back to stock.
    08-27-2017 04:05 PM
  8. SpookDroid's Avatar
    If you connect it to a computer, does it recognize it? Is there a way you could get it to recognize the phone as mass storage for you to save your files?
    08-27-2017 05:22 PM
  9. nobo's Avatar
    Hello vladman,

    I'm also suffering and till now watching Google white color logo and reboot my nexus 6P.

    I try several method but nothing worked. If you get any way that work for you, please help me to get out from this situation.

    09-23-2017 02:31 PM
  10. vladman's Avatar
    Hi nobo, I ended up flashing the phone with the latest image, and starting from scratch. This was the only thing that worked for me, I'm pretty sure my userdata.img file on the phone got corrupted, so overwriting it with a factory-build fresh one was what worked.

    The links above are unfortunately specific to my device (Nexus 6, not 6P like yours), so you'll have to do some further research and find something that works for you. Good luck.
    09-23-2017 02:51 PM

Similar Threads

  1. Low on space LG K4 2017 8GB HELP!!
    By drupalsucks234 in forum LG G6
    Replies: 3
    Last Post: 09-29-2017, 04:08 PM
  2. I have a blue flashing light and airy blank screen. Help! !
    By AC Question in forum Samsung Galaxy S6
    Replies: 2
    Last Post: 08-27-2017, 11:32 PM
  3. Huawei P8 Lite SD card problems help please
    By AC Question in forum Huawei P8 lite
    Replies: 2
    Last Post: 08-27-2017, 01:39 PM
  4. I have a blue flashing light and airy blank screen. Help! !
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-27-2017, 07:06 AM
  5. Infinity Loop: HEX - The new Loop Game!
    By Muhammad91 in forum Android Games
    Replies: 3
    Last Post: 08-26-2017, 09:58 PM