09-23-2013 10:43 AM
43 12
  1. junglejunkie's Avatar
    I have read other members using Foxfi on the phone and PDAnet tablet on the N7 and having success.
    08-07-2012 03:20 PM
  2. rdelfin's Avatar
    I have read other members using Foxfi on the phone and PDAnet tablet on the N7 and having success.
    That's provided your phone is an android one, but if your phone does not run on android then no such thing as the FoxFi work-around.

    So, besides the BlueVPN solution, has anyone come up with another alternative to tether with a non-android phone that has the ability to offer hot-spot (adhoc mode)?
    08-13-2012 08:52 PM
  3. spacesquirrel's Avatar
    This really sucs, Nexus 7 is my first android device and i was quite happy with that before my wife started complaining about missing ad-hoc wifi network, i could not believe that android that is basicly a linux could not handle quite common network type, well i searched and searched and could not find any real solutions for this, i did got that bluevpn network working but it is not wifi and few things do not work with that, so it's no solution. now it seems that this will be my first and last android device (this sucks, it was nice one), well back to ipad, atleast network works in that one.
    08-14-2012 01:27 AM
  4. rdelfin's Avatar
    i could not believe that android that is basicly a linux could not handle quite common network type,
    Is not that android couldn't handle adhoc, as said before, it's on purpose (by design)... and yeah, that sucks.
    08-14-2012 08:55 AM
  5. ManThatCan's Avatar
    Hi - I'm with you 100% on this one. I have the new Nexus 7. Without 3G/4G or the ability to tether using basic ("ad-hoc") I've rapidly come to the conclusion that Android tablets are just expensive toys. You've got full AP mode wireless within range of your home/office router. You also got your home PC/laptop. Surely the whole point of these things is that need to work on a campsite miles from anywhere ? Asus/Google and other manufacturers need to wake up and fix this, not by encouraging us to root and hack about with the firmware, but by a proper, structured upgrade to Andriod, beit ICS or Jelly Bean (or even earlier versions). As you rightly point out support for "basic level" "ad-hoc" Wi-Fi is hardly "rocket science" !
    09-20-2012 03:23 PM
  6. rrohde's Avatar
    How exactly is that be design? How can this be a purposeful design when Android literally bans users from being able to connect to an adhoc wifi hotspot? When I am at work, I sit in an area where there's now 3G connection, and I have to use my Ubuntu laptop's adhoc hotspot in order for me to connect to the Internet. Again -- why does Google do that, especially on a wifi-only device.

    I sold my iPad in order to get the Nexus7, and the iPad *always* allowed me to connect to adhoc, the Nexus7 never did. What a shame.

    When will Google actually change that? I already see myself looking at the 7" iPad coming out this month... sad..
    10-02-2012 05:55 PM
  7. consigliero's Avatar
    I have that some problem, funny thing is that my second tablet asus TF 201 never had problem with joikuspot on nokia e6-00 , both tables work on some 4.1 compilation . In my opinion Google doesn't want that we use nokia, thanks that is working well with ZTE mi-fi
    10-08-2012 06:36 AM
  8. bsponaugle's Avatar
    Thanks!! With your help I now understand the problem and your solution was easy to implement. I spent a lot of hours trying to figure this out myself.
    10-14-2012 10:44 AM
  9. bruna.dda's Avatar
    You saved my life! I've been searching everywhere and just you got it! Thanks!!!
    10-22-2012 08:03 AM
  10. littlemon's Avatar
    I have a N9 as well. It works perfect!!! Thank you very much for sharing the work around. Cool!
    12-13-2012 11:23 PM
  11. srfox's Avatar
    Thanks for the Foxfi recommendation. I just downloaded the free version and it worked flawlessly. I then purchased the Full Version and it too works perfect with my Nexus 7.
    01-12-2013 08:09 AM
  12. cynide99's Avatar

    I have finally managed to have my Nexus 7 access the internet through my non-regular-wifi-but-adhoc-phone data connection!! YAY!! and best of all, I'm almost certain that no rooting and unlocking is needed!! (99% sure of this since my device is rooted and unlocked but nothing seemed to indicate that the solution described below requires it).

    The connection is made possible through bluetooth tethering by using a special app you can download from the Google Play Store for free. So this means you're not even using adhoc wi-fi but a bluetooth link between your phone and the tablet that is established by this app through the "DUN" profile (bluetooth).

    Here are the steps:

    1. Access the Google Play Store in your Nexus 7 and download & install the app "BlueVPN" (this app was developed with Ice Cream Sandwich in mind, but luckily it works on JellyBean making our Nexi 7s 100% compatible.
    2. Both on your phone and in your tablet, do whatever needs to be done to create a pairing bluetooth relationship between these two devices (no need to look for a "connection active" message, just the pairing registered in both devices is enough).
    3. Turn wi-fi off in your tablet.
    4. Execute BlueVPN in your tablet and a list will appear with all the bluetooth devices that your tablet has been registered to will be presented. From this list, select the item that refers to the phone.
    5. Allow for the app to do its thing: negotiating a connection, the handshake, etc... and at the end, you should receive the message that a connection between both devices has been established successfully.
    6. Voil, it's on baby!

    NOW, before anyone starts bit$hing and whining, here are the caveats of this tethering method:
    • Yes, the throughput of data you get with bluetooth tethering is smaller than the one you get with Wi-fi tethering, making your 3g connection feel slower in your tablet (not as slow as browsing on your phone on EDGE, but not as fast as when browsing on HSPA+. You know what I mean?)
    • This connection feeds the internet to your tablet through a "bluetooth socket", NOT a wifi one, and thus, this makes some apps in the tablet "think" that no network connection is present (which is technically true). What do I mean with this? For those apps that only require access to the internet in a straight forward manner, everything will work fine, such as using the web browser app, the facebook app, etc. HOWEVER other apps that EXPECT to receive data through the "wifi socket" will complain saying "not network connection available" like Google Wallet among other specialized apps. One peculiar case is the Google Play Store app: you will be able to BROWSE the store, but you won't be able to DOWNLOAD/PURCHASE apps into your device. As for the two email apps, the "regular email" client works as usual (receiving emails, sending emails, pushed notifications of new emails), however the specialized Gmail client DOES not (hey, you can always use the regular client configuring it with your gmail account should this be something you need).

    To end this on a positive note, the good news is that bluetooth tethering does not consume as much battery power when idle as with wifi tethering, this means, that you can have your phone and your tablet in your bag linked and you won't drain your battery as fast as it happens when using hotspot tethering. And also, the non-requirement of rooting/unlocking I mentioned earlier

    Yes, I'm aware that this may not be a total satisfactory solution to our problem but AT LEAST now our Nexi-7 have the ability to be connected when no wi-fi is around and we only have our phones to the rescue.

    And finally, the disclaimer: proceed at your own risk, which here is practically non-existent, but still, this solution presented here is meant only as informational and I can't be liable for anything that might go wrong, OK?


    PS: Even though this is not a fix but a work-around, the issue still persists on the Nexus 7 side, and I can't take credit for this work-around, as I got to know about it in the Meego forums, just as dmmarck suggested I'd do (still think the fix can only come from the android devs).

    Now question...I've got the nokia n8, and for the love of wifi can't download anything from google play store on my nokia n8....when contacting the help people at google I was told to contact my manfacturer and tell them to install google play on my phone....which annoyed me alot.

    So do you need the blue vpn app on your phone to get this going cause I have it on my nexus 7 tablet and when I try to do the above steps, it just says modem negotiating...but gets no further
    I'm doing my head in here...any suggestions on how to make it work?

    Thanks in advance!
    02-01-2013 02:18 PM
  13. cynide99's Avatar
    bump...I still need help please fellas
    02-05-2013 01:43 AM
  14. re7ere's Avatar
    Not sure if it will help but this appears on another forum. Give it a go and post back whether successful or not:

    Originally Posted by leoniedelt
    N82 is S60v3. great phone, i had one from its release until 2 years ago. Now i have an N8 - which now runs Symbian Belle.
    I have Joikuspot. Its useless. Waste of dosh.

    I couldn't get this BlueVPN thing to work with my N8 - it tried to negotiate but didnt come through in the end.

    Reply Posted by lagoskon
    I also had the same problem UNTIL I entered the below settings

    Phone Number : *99#
    Access Point : Your ISP APN ( mine's : gint.b-online.gr)
    Authentication : Password Authentication
    Username : nothing
    Password : nothing
    Primary & Secondary DNS : nothing

    My problem solved only when I set the *99# number. I already had the correct APN but BlueVPN only showed Modem Negotiating
    I keep WiFi closed when I want Connection with N8

    Good luck.

    Original post at: Nexus 7 - WiFi Ad-Hoc fix for wpa_supplicant? - Page 6 - xda-developers
    02-11-2013 09:31 AM
  15. pssecretajent's Avatar
    [MOD ]Adhoc WIFI support for Android JellyBean phone/Tablet ( Tested by me with
    JoikuSpot try it now it ll work surely
    [MOD]Adhoc WIFI support for Android JellyBean Tablet (Tested by me with JoikuSpot
    02-24-2013 04:31 AM
  16. clay gerry's Avatar
    Hey everybody, I was also having this problem. My nexus is rooted and finally found a rom that supports adhoc Wi-Fi. It is cyanogenmod 10.1, now my nexus can come with me!
    04-20-2013 12:29 PM
  17. AJITH LAL's Avatar
    Hey everybody, I was also having this problem. My nexus is rooted and finally found a rom that supports adhoc Wi-Fi. It is cyanogenmod 10.1, now my nexus can come with me!
    Thanks, it worked for my nexus 7 2nd gen. I rooted my device and flashed with custom ROM CyanogenMod 10.2. Now I can connect to ad hoc WiFi in my n7 using joikuspot premium from Nokia c5-03( s60v5) .

    Thanks again

    Posted via Android Central App
    09-20-2013 05:41 AM
  18. AJITH LAL's Avatar
    Its working perfectly since 1 week but I think there are some bugs in WiFi, its taking too long to connect and if I kept encryption it does not even connect,

    Posted via Android Central App
    09-23-2013 10:43 AM
43 12