1. Travis Kirk's Avatar
    Hi all,

    I've been following this guide for rooting my nexus 7: http://forums.androidcentral.com/nex...-7-tablet.html

    I was able to unlock my bootloader just fine, and I flashed ClockworkMod. But when ClockworkMod loaded up, I got the following errors at the bottom of the screen:

    E: can't mount /cache/recovery/command
    E: can't mount /cache/recovery/recovery/log
    E: can't open /cache/recovery/log
    E: can't mount /cache/recovery/last_log
    E: can't open /cache/recovery/last_log

    This was before even trying to push the supersu.zip file, so I didn't try that. I was a bit freaked out since I know basically nothing about flashing android devices other than the basics I've gathered from these guides. Not sure why, but I chose to do a factory reset from within ClockworkMod thinking this would get me safely back to normal, which then gave me errors because it shouldn't mount properly (lol). Then I just had it reboot from within ClockworkMod. My nexus booted up, then shut down, then booted up again and came up fresh. Phew. I have no idea what happened there.


    1. Is flashing the ClockworkMod permanent, or now that I've rebooted is the original recovery image back in place?
    2. What is causing this on a brand new device, and what can be done to fix it so that I can root my device?
    3. If I'm ever in ClockworkMod and I get errors, can I just power off the device and turn it back on normally and things will be fine? Or would doing that cause problems?

    I want to get a feel for how these sorts of things work before I do any more, because I want to better understand what's happening.

    Much thanks for helping me with some basics.


    Partially answered my one of my own questions... I tried to do the 4.2.1 OTA update and then ClockworkMod stuff came up and prompted me if it was OK to install an "untrusted package". I didn't know what I was doing, or if having ClockworkMod installed and trying to do an OTA update was a problem that could mess things up, so I aborted the installation and rebooted. Given that I was having those mounting errors earlier, would it have been a bad idea to go forward with the OTA update?
    12-21-2012 01:24 AM
  2. Tumas04's Avatar
    I am not sure if i can help you so much but i had a similar Problem today.
    I switched to clockwork recovery today and i got the same mount-errors. The solution for me was quite easy: I booted it (normal, no bootloader or recovery) and filled all the necessary google-account Details etc. (Like u have to do if u just bought it or after u did a factory reset in my case) after that i rebooted to the bootloader/recovery without any errors.

    But do not ask me why that was necessary i am not so much into rooting and developing.

    Greetings from germany!
    12-21-2012 04:12 PM
  3. Travis Kirk's Avatar
    So I actually booted back into CWM again today and the errors were gone.

    I now have another problem though. I wanted to update to 4.2.1, which I understand you have to flash back to the stock recovery in order to do. I did this using the Nexus 7 toolkit and it was successful, but now when I check for updates in Android it says that I'm up-to-date even though I'm only running 4.1.2. Advice?

    Hallo! Ich kann ein bisschen Deutsch!
    12-21-2012 04:36 PM
  4. Tumas04's Avatar
    Well probably there are better ways to get 4.2.1 but u could follow this guide for a factory reset to stock Rom 4.2.1 http://forums.androidcentral.com/nex...e-restore.html

    But with that u will loose the clockwork recovery and the root (and all ur data, so make a backup if u need any data which are already stored on your device e.g. pictures, etc.) So u would have to do that again. But after that u will have 4.2.1 for sure without any need for an update.

    Edit: Normally there should be an update available if u are in stock 4.1.2 ..... Don't know why u can not upgrade directly on ur nexus.
    12-21-2012 05:00 PM
  5. Travis Kirk's Avatar
    I did a factory reset from the stock recovery and then it detected the update. Then I updated to 4.2.1, and THEN reflashed CWM and got root access finally haha. Looks like I'm good to go. Yay learning!
    digitalslacker likes this.
    12-21-2012 05:09 PM
  6. dark_samus's Avatar
    The reason for those errors the first time is cwm is expecting you to have booted into it before so it looks for log files it saves no biggie don't worry about it as for the untrusted package part not sure about it

    Sent from my Nexus 7 using Android Central Forums
    01-03-2013 01:43 AM

Similar Threads

  1. Tried to root my Bionic - Help!!!
    By wcbratton in forum Bionic Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 12-25-2011, 02:38 AM
  2. Help! I'm trying to root my lg optimus v and im getting this!
    By cupcakesgoRAWR in forum Optimus V Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 09-12-2011, 09:27 PM
  3. Please help, stuck trying to root my phone
    By iphoneimpaler in forum T-Mobile Nexus S Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 06-02-2011, 10:46 AM
  4. trying to root my fascinate but this came up
    By tekhinator in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 5
    Last Post: 01-22-2011, 05:18 PM
  5. Total newb about to root my Fascinate, confirming steps, thanks!
    By flogger11 in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 7
    Last Post: 10-12-2010, 11:37 PM