1. andrew.b's Avatar
    Here's what I've done. I was running a rooted nexus 7 on jelly bean 4.1 that I rooted a few months ago. I followed step by step instructions to do it using something called superboot and it worked, but I'm not a linux/android expert so I don't fully understand what all occurred, but I had superSU installed after the process was finished and could run sixaxis controller which was all I really wanted to be able to do. Then, after updating to the 4.2 OS it seems that I don't have root access anymore, or at least that's what I thought, since sixaxis controller was giving a message saying to be sure permissions were set for the driver in superuser.

    Here I think I made a mistake, I downloaded and used the nexus 7 toolkit to try and restore root access to the tablet. I followed instructions that I found again going step by step and choosing option #8 in the toolkit menu once the tablet was connected and in fastboot mode and as it proceeded through the steps it said the bootloader was already unlocked and root access already existed. It appeared everything proceeded and finished OK and I can run the tablet fine, but now I have superSU and superuser installed and sixaxiscontroller is giving the same message about trying to run as user -1 but being logged on as user 0 and to check driver access in superuser etc. I can't find how to add permissions in superuser and there haven't been any prompts regarding permissions. Also, I can't uninstall superuser but can disable it. When I tried to install superSU again and run it, it tries to update the binaries but fails and closes. So basically the tablet runs fine and everything looks exactly like it did before I ran through the nexus 7 toolkit rooting process, but I don't think I actually have root access after all.

    Can anyone suggest how I might be able to get this sorted out and possibly explain what I've done to foul this up so I can try not to make the same mistake in the future? Thanks.
    12-24-2012 02:55 PM
  2. andrew.b's Avatar
    Update - I got it working by using ADB to flash the newest TWRP recovery, then installing superSU.zip using the custom recovery mode.
    01-04-2013 08:19 AM

Similar Threads

  1. trouble with email after ics update
    By reliefman1 in forum Samsung Galaxy S II Skyrocket
    Replies: 3
    Last Post: 07-12-2012, 10:06 PM
  2. Help with root after 11/8 Update
    By hcole623 in forum Verizon Droid Incredible
    Replies: 30
    Last Post: 11-16-2010, 09:30 PM
  3. Cannot ROOT after newest OTA update, Help!
    By caveman663 in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 10
    Last Post: 07-03-2010, 02:55 PM
  4. Rooting after recent OTA update
    By chevyflames in forum HTC Hero Rooting, ROMs, and Hacks
    Replies: 24
    Last Post: 06-20-2010, 02:05 PM
  5. trouble with root, please help!
    By dannychaos in forum HTC Droid Eris Rooting, ROMs, and Hacking
    Replies: 15
    Last Post: 03-26-2010, 11:51 PM