1. bldrgn2043's Avatar
    My nexus is unlocked and rooted. I'm using nexus root toolkit v1.6.2 and I have twrp on my nexus. I have tried updating through system settings by going to apps/google play services and cleaning the cache data, then going to "about tablet" and checking system update. It downloads the update fine, but after restarting it loads into boot-recovery, but it gets stuck at the twrp options page and doesn't load the update like it normally would if it was stock/unrooted.

    I have also tried flashing the 4.2.2 .img with the nexus root toolkit and it always get seems to get stuck at the google boot image. I'm not sure how long it should take I gave it a good 2 mins on the google boot screen before I went into twrp and restored from a backup I did right before trying to update.

    Not really sure what to do next any help would be great.
    02-18-2013 08:28 AM
  2. digitalslacker's Avatar
    1) you can't install an OTA if you have a custom recovery, as you do.
    2) You can't (yet) use the root toolkit to install 4.2.2. If you are able to get back into recovery than that means you never actaully flashed the 4.2.2 img because it would have wiped everything, including the custom recovery (TWRP) and any saved backup you had.

    I'd suggest just hitting up 2def's guide here http://forums.androidcentral.com/nex...e-restore.html
    and doing it manually, it's not that hard and if you have the toolkit installed already I'm sure you drivers are already setup.

    Another options would be to restore your n7 back to 4.2.1 with the toolkit and take the OTA as if you were stock then reroot it manually after you are on 4.2.2. You could backup your stuff via TiBu and then copying everything you wanted over to your computer since a restore will wipe everything.

    You probably could flash the stock recovery back also and just take the OTA, but you'll lose root when you do that and I'm not sure where a copy of the stock recovery is. You wouldn't need to back up that way but you would need to reroot.

    good luck!
    2defmouze likes this.
    02-18-2013 07:26 PM
  3. bldrgn2043's Avatar
    Thanks, I'll back all my stuff up with TiBu and then try 2def's guide and put it back to 4.2.1 stock, then take the OTA. Hope rooting and unlocking has stayed the same. Thanks for your help digitalslacker.
    02-19-2013 12:07 AM

Similar Threads

  1. Problems updating to Jelly Bean
    By Chris71Mach1 in forum Sprint Nexus S 4G
    Replies: 1
    Last Post: 10-31-2012, 04:45 PM
  2. Problem updating to Android 2.3.5
    By bdl427 in forum HTC EVO 4G
    Replies: 8
    Last Post: 08-11-2012, 03:42 PM
  3. Problem updating to ICS using Mac
    By Kranica in forum AT&T Galaxy S II
    Replies: 5
    Last Post: 07-13-2012, 11:17 AM
  4. Problems updating to 1.4.1
    By nosmo.king in forum Barnes & Noble Nook Color
    Replies: 15
    Last Post: 04-14-2012, 02:01 PM
  5. Problems Updating to GB 2.3.6
    By Tat2 in forum Verizon Droid Charge
    Replies: 5
    Last Post: 12-04-2011, 05:12 PM