1. Louis6507's Avatar
    I already have a rooted Nexus 7 (2012) running Jellybean. I've had that OTA notification for so long now I can't even remember. I wanted to wait before updating so all of my apps would work and hopefully any bugs would be fixed.

    So, now I'm searching all over for a step-by-step on what I need to do to update and still have everything as close to it currently is. (apps, settings, preferences, saved files like pictures notifications, etc...)

    I used WUG's Nexus Root Toolkit when I first rooted my 4.2

    If someone could please just link me to a guide (or YouTube) of how to do this, I'd appreciate it. For whatever reason, my Google skills are failing to find what I need. The only thing I've learned so far is that if I try updating while I'm rooted...I'm going to have a bad time. I want to have good times. Not bad. ^_~ Please help.

    Thank you.
    01-25-2014 03:24 PM
  2. dancing-bass's Avatar
    If you're using Wug's it's easy. Painless actually. First and foremost, back up your device. Personally I would copy any photos, files, data, anything you want to keep onto your computer first. I prefer to do a total wipe and start fresh, then when I'm done I re-download my apps and transfer my files back.

    Anyway, since you use Wug's I'll assume you know your way around it. All you're gonna need is this link


    Make sure you select the correct factory image (4.4.2 for "Nakasi" Nexus 7 tablet). If you download and try to install the wrong one, bad things can happen. Wugs should warn you but still - pay attention.

    Use your recovery to wipe data/dalvik/cache. Let it boot up, skip through the setup stuff (don't sign into Google). Use Wugs to update your factory image. You will probably have to re-root your tablet. The bootloader should remain unlocked. Once you've updated you can either restore your apps+data from your backup, or redownload your apps from the Playstore. I would recommend re-downloading the apps and transfering your files back from the computer. I've had less conflicts this way.

    Good luck.
    Louis6507 likes this.
    01-26-2014 10:44 AM
  3. Louis6507's Avatar
    It failed while Flash stock +Unroot
    I tried to copy the log file but accidentally hit a key and closed the window.
    Now it tells me "Booting failed" and if I try to flash again through WUG, it tells me it "ABD device not found" which makes sense.
    Could you please tell me what I should do now?

    I was able to get the log, by selecting the soft-bricked/bootloop option.

    Should I now try it with the option "Force Flash Mode"?

    Flash Stock + Unroot...
    erasing 'boot'...
    OKAY [  0.024s]
    finished. total time: 0.025s
    ******** Did you mean to fastboot format this partition?
    erasing 'cache'...
    OKAY [  0.090s]
    finished. total time: 0.090s
    erasing 'recovery'...
    OKAY [  0.025s]
    finished. total time: 0.025s
    ******** Did you mean to fastboot format this partition?
    erasing 'system'...
    OKAY [  0.116s]
    finished. total time: 0.116s
    ******** Did you mean to fastboot format this partition?
    erasing 'userdata'...
    OKAY [  4.941s]
    finished. total time: 4.941s
    sending 'bootloader' (3911 KB)...
    OKAY [  0.487s]
    writing 'bootloader'...
    FAILED (remote: (InvalidState))
    finished. total time: 0.724s
    rebooting into bootloader...
    OKAY [  0.020s]
    finished. total time: 0.020s
    sending 'radio' (16384 KB)...
    OKAY [  1.971s]
    writing 'radio'...
    OKAY [  1.757s]
    finished. total time: 3.728s
    rebooting into bootloader...
    OKAY [  0.020s]
    finished. total time: 0.020s
    archive does not contain 'boot.sig'
    archive does not contain 'recovery.sig'
    archive does not contain 'system.sig'
    Bootloader Version...: 4.18
    Baseband Version.....: 1231_0.18.0_0409
    Serial Number........: 015d41d859481419
    checking product...
    OKAY [  0.040s]
    checking version-bootloader...
    Device version-bootloader is '4.18'.
    Update requires '4.23'.
    finished. total time: 0.200s
    UPDATE: I think I have discovered the problem of having the wrong bootloader img in the update file. I have found the "correct/fixed" bootloader for version 4.23. So, should I just copy and replace the bootloader in C:\Program Files\WugFresh Development\data\Factory_Images\nakasig-kot49h-factory-83d93b5f then flash again?
    01-26-2014 04:25 PM
  4. Louis6507's Avatar
    UPDATE: Thank you Dancing-Bass! I decided to just go ahead and try my theory and it worked perfectly. But, I never would have done this without your initial post pointing me in the right direction and getting me started. So, thank you! ^_^
    dancing-bass likes this.
    01-26-2014 08:24 PM
  5. dancing-bass's Avatar
    Sorry I wasn't available to help earlier but I'm glad you figured it out on your own... Its a great feeling to be able to solve problems like that all on your own!

    Glad I could be of some help. Keep learning

    Sent from my Galaxy Nexus using AC Forums mobile app
    01-26-2014 10:11 PM

Similar Threads

  1. From iPhone 5s to Galaxy Note 3
    By Justin V in forum Verizon Samsung Galaxy Note 3
    Replies: 2
    Last Post: 01-31-2014, 11:49 AM
  2. Nexus 5 - Set Voice Search to Data Only?
    By Justin Watkins in forum Google Nexus 5
    Replies: 1
    Last Post: 01-26-2014, 10:03 PM
  3. Replies: 1
    Last Post: 01-25-2014, 02:04 PM
  4. Replies: 2
    Last Post: 01-25-2014, 01:45 PM