1. johnnyr666's Avatar
    Even though Puerto Rico is a US territory Google is treating us as other. I had never noticed the problem until I got my wife the Nexus 7 today. I myself have a Transformer Prime and had thought that the difference between my S3 (Sprint) and the tablet was normal. Well guess what, since the tablets connect via WI-FI the Google play recognizes it as a non US territory and all we get is the basic store. I also checked my wife's S3 (Claro PR) and it has the same problem. My S3 gives me the new store and I found out that ATT, T-Mobile due the same. So here I am very dissapointed that my wife can't enjoy the Nexus 7 to it's fullest. The strangest thing is that we can't buy any apps if we use our tablets on our internet access (NONE). Very strange is that my wife's Nexus 7 says that Play Books and Movies are installed but are nowhere to be found. I can't even remove them to install again. My wife says she does not want me to return it but it's sad she can't make the most of such an amazing device. Google will be hearing from me soon. Any other people from PR, please join and let me know how you are dealing with the issue and please let Google hear us!!
    07-13-2012 10:22 PM
  2. ragnarokx's Avatar
    Search for an app called Market Enabler. Never used it personally, but I hear it lets you access the full Market from outside the United States.

    Sent from my Nexus 7
    ajonesma likes this.
    07-13-2012 10:26 PM
  3. johnnyr666's Avatar
    Thanks. Other strange thing I forgot to mention is that if I connect our tablets through my Sprint S3's mobile hotspot I can view the new store. But still can't get Play Book or Movie to show up on the Nexus 7.
    07-13-2012 10:40 PM
  4. silverthornne's Avatar
    Yea it's the same problem I'm having but it isn't new. It happens with Honeycomb tablets too. I've emailed Google about it countless times as I also have a Galaxy Tab and they do nothing about it. I'm very disappointed that they didn't fix for JB.

    Sent from my EVO using Tapatalk 2
    07-14-2012 12:19 AM
  5. nick9809's Avatar
    There are always workarounds but Google said a long time ago that the Play store would not work in Puerto Rico.
    07-14-2012 12:28 AM
  6. silverthornne's Avatar
    Really? Err where? I'd really like to read that article or press release or whatever it is.

    Sent from my EVO using Tapatalk 2
    07-14-2012 12:50 AM
  7. nick9809's Avatar
    It's been on the Google Play store help section as far as I remember. I'll try to find it for you.
    07-14-2012 01:03 AM
  8. nick9809's Avatar
    Here it is!

    Country availability - Google Play Help

    Hmm, they changed it though. It used to say just "Google Play is not supported" but now it says "Google Play movies"
    07-14-2012 01:05 AM
  9. silverthornne's Avatar
    OK I've seen that link but yes it just said Movies weren't supported the first time I saw it. Google's lack of consistency will be their undoing...

    Sent from my Nexus 7 using Tapatalk 2
    07-14-2012 07:16 AM
  10. havock999's Avatar
    I'm in Puerto Rico as well on temp assignment. I tried pre ordering a Nexus 7 from the play store but Google wouldn't allow it - strange considering I bought a galaxy nexus for a friend a month ago with no issues. I'm considering either the transformer or n7 but with these play store issues I might wait until i get back to the states.

    One idea...

    When first got to the island last year Netflix was not yet available. I found a work around by using a VPN with servers in the US (strong VPN - 7$ a month i think). With the VPN service Netflix worked perfectly as if I was in the US - ofcourse it became available here a couple months later so I cancelled the vpn service. I'm thinking this might work with the play store as well?
    07-14-2012 10:14 PM
  11. silverthornne's Avatar
    Well, one can get free stuff without issues. It's just that they don't want our money (our currency is US$ for anyone wondering) if it's bought from a tablet.

    Sent from my EVO using Tapatalk 2
    07-14-2012 10:49 PM
  12. yoyocint's Avatar
    I posted a response and its not here now. what??????
    07-15-2012 08:10 AM
  13. yoyocint's Avatar
    Due to these type of practices the DACO, Puerto Rico Consummer Affairs office is handeling complaints against some companies including Amazon.

    I think the best course of action is to file a complaint with them.

    I believe it is an impropper businees practice from Google. The will take your money for ordering the device but do not providde the content and other apps as they should in PR.
    07-15-2012 09:05 AM
  14. johnnyr666's Avatar
    Well have not been able to find away around this yet. Would love to get the Play Store credit and also the Transformers movie. Was able to download Play Movie and Books to my Transformer Prime and work perfect and as long as I connect through my Sprint Hotspot no problems. Nice thing is Barnes & Noble and Zinio are going making some money. So what to say, thanks for nothing google you will be hearing from me tonight.
    07-15-2012 12:02 PM
  15. lazychino's Avatar
    i got the same problem, i factory rest the nexus and through an vpn and at least got the google play credit and content but as soon as i connected through a regular connection on pr the google play books, movies and magazine disappear from the menus this a serious problem because it wont let you access books or movies on the tablet i will call google tomorrow to see what they say
    07-15-2012 06:41 PM
  16. silverthornne's Avatar
    Please let us know how it goes! I've never tried calling them...

    Sent from my EVO using Tapatalk 2
    07-16-2012 09:32 AM
  17. johnnyr666's Avatar
    Thought of factory reset. Does the credit stay in the account? Where did you buy it? Were you able to download transformers movie? I don't think my wife likes the idea of factory reset and start all over again. I'm trying to convince her, then she can buy some books and mags. Keep us up to date lazychino. Thanks guys!
    07-16-2012 07:48 PM
  18. ajonesma's Avatar
    Thanks. Other strange thing I forgot to mention is that if I connect our tablets through my Sprint S3's mobile hotspot I can view the new store. But still can't get Play Book or Movie to show up on the Nexus 7.
    Sounds like the Google Play Store is connecting you to the store based on the IP address you're on.

    But Market enabler should work. Like others posted above, I have never used it since I've never really travelled outside the US.
    07-16-2012 07:51 PM
  19. merg21's Avatar
    Just got back from the US and I find myself with this problem. There's a work around if you use a VPN. I still can't download the free Transformers movie on my nexus 7 tablet but I can on my Cyanogen Mod 9 galaxy tab tablet.
    08-04-2012 11:59 AM
  20. odinmoon's Avatar
    I'm having the same problem. I bought my Nexus 7 on GameStop and part of the offer said that I was gonna get the Transformers 3 movie and $25 Google Play Credit.
    Once I turn on my Nexus 7 I tried to access the Google Play Books, Movies and whatever and I couldn't. Started making my search on the internet and allegedly because of my location (Puerto Rico) I didn't have the permissions to access Google Books or movies.

    Do I need to explain a little bit of history? I hope not!

    Anyways, I wrote to GameStop about this issue and a few days later they told Me the following:

    Dear Juan,

    Thank you for contacting GameStop.com.

    Unfortunately you will need to speak to the manufacturer regarding this issue. Our apologies for any inconvenience.

    If you have any additional questions, you can respond to this email; or if you prefer to speak to someone directly, you can reach us 7 days a week 8am to 8pm at 800-883-8895.

    Wow! What a way to clean their hands.

    Making me think it's not GameStop problem and because Google don't answer regarding this issue apparently it's not their problem either.

    If anyone knows how to resolve this matter, please let me know.

    I'll keep saying Android Rules! For now
    08-09-2012 07:43 PM
  21. Driftbum's Avatar
    I got a nexus recently and called Google with the same issue, but no good. I'm also in Puerto Rico btw

    So I just reset my device, connected via mobile hotspot downloaded the nexus 7 user guide, synced books with my account.
    After that rebooted the tablet and the apps where still there.
    So the issue lies in the IP that the account is set up. when I want to purchase books, music or movies I use my phone and afterwords hit "sync now" in the books, music & movies app on the nexus.
    So far so good, the issue is annoying but at least there's a work around.
    I also tried the VPN setup and it work very well, I used superfreevpn. com.

    Sent from my Nexus 7 using Android Central Forums
    08-13-2012 11:03 PM
  22. Miriam Perez's Avatar
    Got my Nexus 7 for my birthday this week, going to return it on the weekend, I cannot purchase books from google play, that was the main reason for getting this gift. What a bummer! Google pls take notice.
    12-10-2012 08:55 PM
  23. kiikeepr's Avatar
    I made Google Play the default in my phone instead of only having the Apps page with a tweak. I don't know for how long it is going to work but for now is great.

    First I have an at&t cell phone. I turned the wifi and the GPS off, then restarted the phone. When its comes back it uses the "real" Google Play!!!!! I think that they can't track you without the gps and the wifi internet provider. Google Play can only use the IP of the at&t servers that are in USA.
    The problem is that when you turn on the GPS or the wifi and track that you are in Puerto Rico it comes back to the only Apps Google Play.
    The trick that works for me to stick with the "USA" was when I was using it. I registered some magazines that I own to use them in the Google Magazines app. When i did this it stays in the USA Google Play, even in my Nexus 7 that its only wifi and has the GPS turned ON.

    Remember that you have to make a Google Wallet account to register or buy. This works in Puerto Rico. I bought my Nexus 7 directly to google play because it was cheaper than in Walmart. I Live in Mayagez, Puerto Rico

    Ahora en espanol jejeje

    Busca un android de at&t (porque es la compania que tengo y no he probado otra) y apaga el GPS y el WIFI. Despues dale restart. Y cuando vuelve sale el que tiene "movies, magazines, apps y music" (el que queremos). Cada vez que lo necesites puedes hacer eso.
    Lo hice en dos celulares con cuentas diferentes y funciono.

    Pero a uno de ellos cada vez que prende el WIFI y el GPS le vuelve al de solo apps. Porque en este no baje nada.

    A mi se me quedo porque yo busque unas revistas a las que estoy suscrito en papel y me daba la opcion de tambien tenerlo en digital en el app de Magazines. (Times, Vanity Fair, People en Espanol). Cuando lo hice el telefono se quedo usando el mismo.

    Y la Nexus 7 cambio al verdadero Google Play.

    La Nexus 7 es solo wifi.

    Ya le di restart a la tablet y le instale el update 4.2.2 y como quiera esta el mismo Google Play.

    Yo compre la Nexus directo a Google porque me salia mas barato que en Walamart y Officemax con cover y todo.

    Recuerda que tienes que tener Google Wallet, la pagina de internet sirve desde PR.

    Espero que le sirva!!!
    02-16-2013 12:04 PM
  24. Angela Reynoso's Avatar
    I live in Puerto Rico. Currently trying Google Music All Access Subscription and it doesn't work. Called google and they said they are gonna give me a call back because they have to invetigate whats the matter.
    10-09-2014 11:19 AM