04-10-2014 07:12 AM
30 12
  1. tabletandroid2012's Avatar
    I just got google nexus 7 tablet, went to starbucks, wifi was good. but i went home, can't connect to wifi at home. even i typed the right pw, saved, secured by WEB.
    Does it problem with my router or problem with the Nexus 7? should i return nexus 7 tablet?
    can't connect home wifi. pls help. thanks
    08-08-2012 11:30 PM
  2. coryteague's Avatar
    You might want to look into which port your modem is using?

    Sent from my Nexus 7 using Android Central Forums
    08-08-2012 11:34 PM
  3. Small_law's Avatar
    Is your router set to wpa2 security (aes)? You can check on your router's admin page. Google the make and model of your router to find the admin page address.

    I remember reading that it worked for someone else.
    08-08-2012 11:42 PM
  4. dralezero's Avatar
    Are you using MAC filtering? I forgot I had recently turned that on in my router before getting my replacement Nexus 7. I was blaming the N7 at first. So my N7 would accept my WPA password and save the connection, but not actually obtain IP and get on the network.
    08-08-2012 11:45 PM
  5. blahblahyoutoo's Avatar
    You might want to look into which port your modem is using?

    Sent from my Nexus 7 using Android Central Forums
    can you explain further?
    i've never heard of ports when dealing with wifi devices communicating with each other.
    08-09-2012 11:03 AM
  6. galnex's Avatar
    For what it's worth... I'd been having intermittent WiFi signal at home on my N7... I have a Netgear N600 dual band router... after reading a bunch of different threads on the subject I decided to venture in my router' wireless settings... BTW, I do not know much about routers and wireless connections and this is not a technical advice but rather I am reporting my own personal success, which I hope could help some other people as well... that said, I went to my router's admin page (was stamped on the bottom of the router) and changed the wireless settings to the following:
    wireless isolation enabled
    security: WPA-PSK [TKIP] + WPA2-PSK [AES]

    wireless isolation disabled
    security: WPA2-PSK [AES]

    I have my Galaxy Nexus connected to the 5GHz bandwidth by default and the Nexus 7 on the 2.4GHz as it won't find the 5G anyways... my PS3, my gf's iphone and a macbook pro all connected to the 2.4GHz frequency as well...

    My N7 has not lost WiFi signal nor connection to the google servers in the past hour of observation...

    I believe the new wiresless settings have worked and hopefully this is a permanent fix for some having the same issue as me...
    dmmarck likes this.
    08-19-2012 10:10 PM
  7. Blkacesvf41's Avatar
    Like galnex said, I went into my router's settings and changed the security from WPA to WPA2 and fixed it for me.
    08-19-2012 10:29 PM
  8. Lil Jaye's Avatar
    Check your firewall on your computer. I turned mine off just long enough to get hooked up to the WiFi then I turned the firewall back on. Never have had a problem sense. Good luck.
    08-19-2012 11:53 PM
  9. jtsgrl's Avatar
    I just got google nexus 7 tablet, went to starbucks, wifi was good. but i went home, can't connect to wifi at home. even i typed the right pw, saved, secured by WEB.
    Does it problem with my router or problem with the Nexus 7? should i return nexus 7 tablet?
    can't connect home wifi. pls help. thanks
    09-18-2012 11:05 AM
  10. Jimboid Death Machine's Avatar
    Mine flat refused to talk to my Virgin superhub. Having failed to get anywhere with help desk of the tablet's manufacturer or retailer I got it going as described below. None of these steps worked individually but the three of them seemed to crack it - I am throwing them out there in case it helps someone else, it worked for me, anyway.
    I changed the superhub security mode from WPA Auto to WPA PSK (AES), I unplugged the old huberoony for 2 mins and rebooted, and I re-entered the hub p/w in lower case rather than the specified mixed case. Bingo! Good luck...
    09-22-2012 02:11 PM
  11. torre1's Avatar
    Had exactly the same problem. Have spent the last 3 days trying every idea I could find - none worked. Finally fixed it - thanks to Belkin support, why didn't I ask them first.

    My network name (SSID) was 3 words each separated by a space. I was told to simplify the name to 1 word so took out the 2 spaces. The nexus found the new name for the network and after entering the password I was connected within seconds.

    This may also apply to any non alpha-numeric characters in a network name not just the space.

    Hope this helps.
    09-24-2012 09:21 AM
  12. jpash549's Avatar
    Don't know why anyone would be using WEP security on their router unless required by some old device they are using. WPA2 is not only more secure but in my experience a lot easier to use.

    Sent from my Nexus 7 using Android Central Forums
    09-24-2012 10:39 PM
  13. johnwccres's Avatar
    As others have said, changing from WEP to WPA might be good. The password is a lot shorter!

    I use WEP for compatibility with my daughter's Nintendo DS, but the password is very long and complex - it took me a few goes to enter it correctly on my N7. So maybe you should try again being very careful to hit the right keys?
    09-25-2012 07:47 AM
  14. EcclesAgain's Avatar
    Having unhid my router's SSID and disabled the allowed wireless MAC address table my Nexus 7 can find and communicate with my router but cannot make a connection unless I disable encryption. I am using WPA-PSK (TKIP) and have tried other combinations as suggested in this thread without success.
    I am willing to disable encryption to enable the Nexus to run through set up but then will need to find its MAC address and tell it the encryption key for the WiFi to get it to connect in a fully secured fashion.
    I am a total newcomer to Android so would welcome a steer on navigating to find the MAC address and the place to record the encryption key.
    Any suggestions on where to find some good basic Android documentation would also be appreciated.
    Thanks in advance.
    11-18-2012 04:24 PM
  15. HemaV's Avatar
    Yes, Changing the router settings for 2.4GHZ with security:security: WPA-PSK [TKIP] + WPA2-PSK [AES] did the trick. Now my Wi-Fi in Nexus 7 does work. Initially for a month, I did not face any issue. Since 2 days it is not connecting and just saves the configuration. So I did a factory reset, Still it did not work. Once I changed the security settings for 2.4 GHZ, now it is working. Now I need an answer to my question as to how this worked initially without any hiccups with the same router with earlier setting of security as WPA2-PSK?

    Anyway, thanks so much for the tips and suggestions. I am happy that it is working again.
    12-19-2012 08:59 AM
  16. Judithu's Avatar
    can't connect to wi fi at home, signal is good
    01-12-2013 12:27 PM
  17. dominic southwick's Avatar
    I am using a Netgear router. The fix turned out to be very simple
    Locate Wireless Station Access List (I found this in Wireless Settings)
    Deselect Turn Access Control On
    Job Done
    01-16-2013 09:40 AM
  18. knowmaddd's Avatar
    Check the name of your SSID; I find that my N7 will not connect to a network with an SSID of less than 3 characters. No such issue with my Chromebook or GNex. I changed the SSID to 3+ characters and was able to connect without issue.
    01-27-2013 08:23 PM
  19. Twila Beverly's Avatar
    It worked! Thank you soooooo much!
    01-28-2013 06:44 AM
  20. simcha evron's Avatar
    to me you all speak chinese. where do you find all these steps to fix the wifi not connecting. how do i find where to do any of it. on my tablet(not connecting?) on my computer or do i have to go on the internet to the routers website? please explain.
    03-16-2013 10:03 AM
  21. MJKearney's Avatar
    You get to the router settings using a computer (easiest to work on) or tablet or smartphone that is connected to your router, either directly with a networking cable or via WiFi.

    On the computer, open your internet browser. Then type in the IP address of your router, the same way you would type in a web address. What is the IP address of your router? It depends on what model router you have. Usually, the address is on a sticker on the back or bottom of the router. If not, look in the instruction manual for the router. If no instruction manual, do an online search for it. Or search for a website that lists the addresses for all routers. It will look something like this (and could actually be this) :

    You will then probably be prompted for a login name and password. The default name and password will also be found as described above, with regard to the IP address. If someone has changed the default login or password when initially setting up the router, you'll need to find that tiny, crumpled up piece of paper that the changes were written on. It is likely located in the back of some drawer, in the 2nd upstairs bedroom, almost torn in half and barely legible. More likely, though, is that the dummy never wrote down the new information, and you'll have to do a hard reset of your router and set it up again from scratch.

    Once logged in, you will see a very confusing screen with lots of tabs and menus and words that barely make sense. Either bravely dive in and figure it out (with the assistance of the manual and/or online searches, and the advice given in this forum), or solicit the help of a friend who already knows what they're doing, and is likely the one who never wrote down the new router password and has forgotten it him/herself. Then hit said friend upside the head for being so irresponsible for doing that. Then buy said friend a beer once your N7 is finally connected to your WiFi.

    And finally, good luck.
    B. Diddy and rbess1965 like this.
    03-16-2013 11:06 AM
  22. B. Diddy's Avatar
    Nice explanation, MJKearney (as usual)!
    03-16-2013 11:27 AM
  23. jamesbarns's Avatar
    Thank you MJKearney! I actually understand how to do most of this now. It took me about 10 minutes of toying around with it until my Google Nexus could finally connect to the WiFi, but I couldn't have done it without your help. Thanks again!
    Best Cameras for Filming
    03-16-2013 12:04 PM
  24. Jaak Nirgi's Avatar
    I had same symtoms(wifi was lost after some time at all,sometimes had to swich wifi off and on again,sometimes only restart helped).
    I tried change my router settings-nothing helped.Finally resetted my Nexus7 to factory settings-and it helped,for now 2 days no problems !
    04-21-2013 01:45 AM
  25. TiredTaz's Avatar
    Am I then going to have to reset the settings on both of my computers that use the wifi?
    08-03-2013 09:33 AM
30 12