1. lbregister's Avatar
    Hey everyone,

    I have been trying to find a solution before i posted on this thread, but cant seem to get an answer. I have a Samsung s3 from tmobile and the nexus 7. I was able to connect to the wifi hotspot 1 time, but now it wont connect. N7 keeps saying obtaining address or will loop saying connecting. When i refresh my wifi on the N7 it says wps failed try in a couple minutes. Does anyone have any clue why this is going on? I can connect to my wifi at home just fine. Any help is much appreciated.

    Thanks,
    Landon
    09-06-2012 12:10 PM
  2. rootbrain's Avatar
    Is your hotspot ad-hoc (wext) or infrastructure (netd)? Android can't connect to ad-hoc wifi, only infrastructure.

    If you connected once, I assume it was at one time infrastructure, just make sure it still is.
    lbregister likes this.
    09-06-2012 02:16 PM
  3. lbregister's Avatar
    Good point. No where do you think i could find that info? I cant seem to find out from searching online nor on the phone. If it is Ad-hoc is there any way around this problem?
    09-06-2012 02:52 PM
  4. rootbrain's Avatar
    Look in the market. For wifi tethering. There are apps for rooted and unrooted. Foxfi has been mentioned but there are others. Download to your S3 and try some out.

    Rootbrain
    lbregister likes this.
    09-06-2012 07:28 PM
  5. lbregister's Avatar
    I tried a couple out and still same thing. Stays at obtaining IP address. Has anyone else had this problem with the S3 and Nexus 7?
    09-19-2012 05:09 PM
  6. Dixie Wrecked's Avatar
    Foxfi doesn't work with ICS

    Sent from my A500 using Android Central Forums
    09-19-2012 07:21 PM
  7. shawn122's Avatar
    Foxfi doesn't work with ICS

    Sent from my A500 using Android Central Forums
    I installed FoxFI on my 2 year old Captivate running CM9 and it installed fine. My wife was able to connect her BB Torch to my phone without any problems.
    09-20-2012 05:07 AM
  8. lbregister's Avatar
    Yeah i am not having a problem with the 7 not connecting to wifi anywhere else. It just doesnt want to work with my s3 as a hotspot...did once and now nothing besides looping of obtaining ip address. Thanks for the ideas above, but nothing has seemed to work. Is anyone else having this specific problem between the nexus 7 and s3?

    Thanks,
    Landon
    09-25-2012 02:19 PM
  9. neurodx1's Avatar
    Hi Landon,

    I don't know if you found a solution to your problem, but I had exactly the same issue and found a solution that I am going to post just in case there are others with the same problem. I just got the Nexus 7 and wanted to use my S3 with mobile hotspot for WiFi connection. The 7 recognized the S3 in it's list of available WiFi connections, but when I selected the S3, the connection got stuck in a loop toggling between "authenticating and connecting", but it never reached the point of obtaining an IP address. The 7 connects to the WiFi in my home environment and I can connect my iPad 2 to the S3. The iPad is listed with its MAC address in the allowed device list on the S3 under mobile Hotspot.

    I obtained the MAC address from the 7 by going to "settings", "about tablet", then "status". I made the 7 an allowed device on the S3 with that MAC address, selected the 7 from the list and it connected in no time. I haven't had a problem since.
    Ntchwaidumela and Minkey1 like this.
    12-20-2012 05:34 PM
  10. Jeet Pathak's Avatar
    Hey all,
    I am facing a similar issue with my S3 Mini's hotspot. My macbook pro and other android phones get connected with the S3 mini's hotspot but internet does not work. The status on both devices declares connected but no internet whereas my older android phones like galaxy ace's hotspot works fine with the same devices. I have configured the devices properly so all are 'allowed' devices. Please suggest.
    01-08-2013 10:22 AM
  11. Suntan's Avatar
    I've never had an issue tethering my N7 to my GSIII.

    I use the "hotspotswitch" app to toggle the native tethering built into the phone (I'm on VZW fwiw.)

    -Suntan
    01-08-2013 11:26 AM
  12. John Angevine's Avatar
    Did anyone find a solution to this connection problem? I have the same issue. Other devices connect to my S3 Verizon Hotspot with not problem. But the Nexus 7 just keeps cycling/trying to connect.
    04-12-2013 03:08 PM
  13. Ntchwaidumela's Avatar
    I've never had a problem connecting to my S3 hotspot, so I don't know if this will work for you. If the hotspot is showing on your list, open it, hit Forget, then restart. Once it reboots, go back into the connection list and try reconnecting again. Let us know if that works.
    04-13-2013 10:58 AM
  14. fleishhacker's Avatar
    I have the Google Nexus 7 (new 2013 version) and have tried all the above with limited success. Sometimes it will connect but other times no. When it does connect it will often throw me off. I have used my Nexus 7 to connect to my S3 via bluetooth to access the internet on my Wifi only Nexus 7. Any disadvantages to solving the problem this way?

    Thanks
    10-11-2013 11:29 AM
  15. mander43's Avatar
    Brilliant - worked 1st and every subsequent time. Thanks
    03-19-2014 02:54 PM
  16. Allan Richardson's Avatar
    Thank you so much. Worked perfectly! It was driving me nuts!
    12-03-2014 06:45 PM
LINK TO POST COPIED TO CLIPBOARD