03-23-2016 01:49 PM
33 12
  1. rossmitton's Avatar
    Had the Nexus a week, rooted it successfully, used it rooted for a few days. Playing around with OTG, worked drives and mouse well. Then it just wouldn't respond to power off/on.

    Worried and Googled for a while, then managed to get the cover off and disconnect and reconnect the battery as you would in a mobile phone.

    Got the most help from , proud he was an Aussie.
    09-16-2012 05:15 AM
  2. agnesemi's Avatar
    I actually had the same issue. I had a black screen on my Nexus 7 and couldn't do anything. I called Asus and they told me to:
    1- plug the Nexus 7 to the power cable as if you were charging it
    2- hold down the power button for 20 seconds
    I followed above steps and my Nexus 7 started up!
    liljew, VFRMark and flacousa like this.
    11-05-2012 12:49 PM
  3. Sloetz's Avatar
    Thanks agnesemi, your solution helped me out!!
    11-17-2012 02:26 PM
  4. Jstars's Avatar
    1- plug the Nexus 7 to the power cable as if you were charging it
    2- hold down the power button for 20 seconds
    I followed above steps and my Nexus 7 started up!
    I've had my Nexus 7 black screen on me twice now... (started after ICS 4.2 came out?? Coincidence??)

    Both times it seemed to come back after a few minutes (of being frantic). Both times I had reconnected to power ..
    but did not hold the button for anywhere near 20 seconds. But will remember that the next time and try it.


    12-01-2012 03:35 PM
  5. Jeff Hengesbach's Avatar
    Had to perform the battery disconnect on my unit. 20 second button hold would produce some screen flickers but the unit would never boot up.
    01-08-2013 11:47 AM
  6. Zackyy's Avatar
    I have the same problem! So, I plugged it in and it was flickering some time, then the screen had really low brightness. Like everything is black, but random-appearing red-green-blue lines and white dots were appearing. Dunno how to fix this! Tried everything! Boot menu wont work, wont power up and wont turn on at all. Some help please?
    01-08-2013 01:27 PM
  7. Didact7's Avatar
    I had the same issue today and a hard reset fixed it. But I'd like to know if this is a hardware issue or a software issue so I can decide whether to return it or not. If it's just Android being a little buggy, I probably won't.
    01-10-2013 07:09 PM
  8. VoluntaryMan's Avatar
    Open it up, unplug the battery, wait ~30s and plug it back in. pop the case back on and it will boot up fine. at least it did for me with the same sounding issue.
    01-14-2013 03:25 PM
  9. Don Steve Evergreen's Avatar
    My Nexus 7 gone black just after transferring video clips. I tried power button option ( pressing down for 20-30 sec as advised by some). It did not work. I also tried pressing power button and volume down together for some seconds. It did not work either.

    Finally i decided to remove the battery. I must say it is pretty easy to remove the back cover. I did not use any screw driver and any tool as i thought those stuffs might damage the body of the device. I just used my own nails to separate the cover. If you put your 2 or 3 nails in the ditch made by silver body and black plastic cover and pull it apart, the cover will come up. You can see the flat black battery inside . That point, try to detach the connection point using your nail. Leave disconnected for 30 sec. and reconnect gently. If you try power button, you can see GOOGLE on screen. That means it works again. Good luck
    Marc Bennett and sklein128 like this.
    01-20-2013 03:14 AM
  10. Penzes Geza's Avatar
    I hope that someone can help me with my half dead Nexus 7.
    These things have happened to the device:
    The previouos owner dropped it, the screen cracked, but apart from that, it was still functional.
    They replaced the LCD touchscreen unit with a new one. The device haven't functioned since (not even with the original, cracked display).
    I received the device in this condition, and the first thing I noticed, was that the battery was dead (~2,5V cell voltage). I recharged the cell directly (with my own separate Li-polymer charger), and I soldered the battery protection circuit back (now it's completely charged, around 4.16V).
    At first I thought that the device had drained the battery while they were waiting for the new display, and the dead battery was the reason why it didn't work for them after the screen swap, but unfortunately it was not the case.

    Here are the symptoms:
    After reconnecting the battery to the main board, and pressing the power button, I can feel the processor getting slightly warm, but the display stays black (the backlight is off and nothing changes on the display, not even in bright light).
    When I connect it to my PC, XP recognises it as a mobile device, and the 16GB flash storage is completely accesible (in the properties menu, it says the device is using battery power).
    When I try the 30 second power + volulme up key combination before connecting, my PC tries to install a new driver, without any success.
    All this points to a screen problem, but the screen is brand new, all ribbon cables seem to be intact. I wanted to do a factory reset, but all the methods I've read about required the USB debugging mode to be activated (obviously I can't do that).
    Interestingly, one time the device started making some sort of a key-press sound (2-3 times) when I pressed the power + volume up buttons, so it is not completely brain-dead.
    I've tried the power cable + 20 second powerkey-press method, it didn't work.
    Any help is appreciated.
    01-28-2013 01:40 PM
  11. thinka's Avatar
    For me something else worked:

    - Power on/off (even holding the button for 30 seconds) = failed, something happend but the screen was still almost black

    - opening the case (with two fingers, second and third, on top), then pressing "Power" (without touching the battery!) = worked,
    I could see the start screen (not locked mode) again

    Good luck!
    01-29-2013 02:31 PM
  12. Penzes Geza's Avatar
    Taking it apart once again revealed nasty cracks in the LCD ribbon cable. I'm waiting for a replacement. Hopefully, it was the only fault, and the rest is intact.
    02-07-2013 02:17 PM
  13. VFRMark's Avatar
    agnesemi - Brilliant advise - worked perfectly
    03-08-2013 12:24 PM
  14. flacousa's Avatar
    Thanks, mine too when dark and your suggestion worked, first problem since getting the tablet in July.
    03-08-2013 11:09 PM
  15. tanishh's Avatar
    hey thanx a lot......dat really helped
    06-08-2013 03:45 AM
  16. David Chang1's Avatar
    I don't know about others, but none of the methods suggested in this forum EXCEPT yours helped me. Thank you!
    07-14-2013 09:11 PM
  17. Mattys62's Avatar
    PLEASE tell me if you found a solution because i just replaced the screen and digitizer and now it dosent turn on at all but i can hear sound? maybe the ribbon?
    09-11-2013 12:16 AM
  18. preppystud's Avatar
    i just had the same problem today. i am using the 2013 version.

    i just powered off, and restarted, then the problem went away. i don't know if it is the software or hardware problem.
    01-21-2014 04:35 PM
  19. shyneng26's Avatar
    Hi ,, 4th time my nexus screen turned black,, and it shows only unlock screen but when i tried to unlock it , its still black,, so i have to turn it off .. pls help How to fix this thing?, thanks!
    02-07-2014 09:46 PM
  20. fjag2000's Avatar
    I got my Nexus 7 broken after it felt down, everything worked perfectly except half touch screen, I could use it to listening music or watching videos and many other things, but it was difficult to work with due to I had to rotate it all the time to use the half screen where the touch screen worked fine. I decided to replace the screen. After replacing the digitizer+LCD screen (one piece all together) my Nexus 7 starts up but I get BLACK SCREEN. I can hear everything: unlock screen, notifications, etc even when connecting to a PC it is detected. The funny thing is that if I replace it back to the broken part (broken screen) I get the same symptoms.
    I haven't been able to fix this.

    Anything you can advise to do to fix it will be more than welcome !!!!

    Thank you !!!!
    03-12-2014 10:38 AM
  21. thinka's Avatar
    Once or twice a day I get an almost black screen (very dark grey), while sound is still working. It's not a software problem I think. What works for me (since the beginning and for more than 1 year now) is hitting the tablet (back side) with one hand. Sometimes one time is enough, sometimes I have to hit it more times (or a little harder). Sure this is not the best way to treat a technical device but can someone tell me how to fix it? Is there a cable broken inside? The problem started a few days after first using the tablet (before treating it a little harder).

    Thanks for your reply!
    03-12-2014 11:17 AM
  22. fjag2000's Avatar
    it sounds like the cable connecting the LCD to the mother board is not correctly plugged, please check this out in you tube
    Keep on mind that manipulating the devide will make you to lose the warranty. Damages on the device will be under your responsability.

    Good luck
    03-14-2014 06:15 AM
  23. Poonam Patel1's Avatar
    hi i just bought a new nexus 7 (2012) from best buy but when i tried to turn it on nothing happened and so i called google and they told me to try holding power button ( that didnt work) then they told me to do boot menu but that didnt work then they told me to charge it for 1 hour and see if it turns on but once plugged in the screen flashes once with very low bright ness and then then nothing. So i tried to leave it in charge for 10 hours and tried to turn it on but that didnt work either. So i returned the tablet and exchanged it for another one and the same issue with the new one as well??? PLEASE HELP?? p.S iv tried to disconnect the battery but taht didnt work either.
    03-14-2014 07:56 AM
  24. st4rdog's Avatar
    Just had this happen after adding a new user. It sent me to the login screen then went black.

    Holding the power down for 15 seconds turned it on for a few seconds, then black again. Then I held it for 15 seconds again and it restarted with the Google logo this time and now it works.
    04-23-2014 01:08 PM
  25. john patel's Avatar
    thanks it really worked for me
    Kent Woodman likes this.
    05-05-2014 08:33 AM
33 12

Similar Threads

  1. [FIX]Black screen with custom recovery and custom roms
    By bigsupersquid in forum Optimus V Rooting, ROMs, and Hacks
    Replies: 265
    Last Post: 02-02-2017, 06:54 AM
  2. Black screen on clockworkmod bootup
    By Arkaneus in forum Virgin Mobile Optimus V
    Replies: 8
    Last Post: 03-17-2012, 09:11 PM
  3. rom manager and recently built optimus v, black screen on boot
    By bigsupersquid in forum Optimus V Rooting, ROMs, and Hacks
    Replies: 12
    Last Post: 11-19-2011, 02:57 PM
  4. Adding or removing home screens on Nexus
    By lamimada in forum T-Mobile Nexus S
    Replies: 1
    Last Post: 10-21-2011, 08:38 AM
  5. Black screen on home screen
    By dbmorris99 in forum Motorola Droid 2
    Replies: 0
    Last Post: 09-14-2011, 11:42 PM