1. pianomanss87's Avatar
    Hi. I can not down load or up date from play store error code rpc:aec:0]. Please help.

    Piano Man
    10-13-2012 05:18 PM
  2. a1kemist's Avatar
    10-13-2012 06:06 PM
  3. pianomanss87's Avatar
    thanks. deleting and re installing my goggle account worked

    piano man
    10-13-2012 06:27 PM
  4. bhaidasna sunil's Avatar
    its a very simple solution and it worked for me.
    1) go to settings>apps>all and clear the cache and clear data for google play store
    2) go to settings> accounts and sync and remove all the synced accounts
    3) open google play and register your id again and it works all fine once again.
    you do not need to do a factory reset also....
    11-26-2012 04:54 AM
  5. Mike C12's Avatar
    This worked for me
    Please follow the steps below to reset your Google Play Store:1) click Setting2) click Application or Apps3) click manage application4) then you will see downloaded, running, all, on SD card (Select All)5) Choose Google service framethen choose force stop,then choose clear dataAfter you clear all data, restart the Tablet.This will reset the Google Play Store and you can start downloading Apps as normal again

    sabrina harrington likes this.
    12-28-2012 05:55 AM
  6. johnatthebar's Avatar
    So I've tried clearing data for the play store and services framework, rebooted each time - still having the issue. I had this problem on my S3 as well and was never able to solve it, ended up going back to 4.1 Anyone have another suggestion for this issue on my Nexus 7?
    02-19-2013 11:23 PM
  7. Tokio_Love's Avatar
    Same thing happened to me, could never get ot to work with none of those solutions, luckily after 2 days I got my 4.1.2 update and it was fixed

    have you heard about the GN2, yea it's awesome (^-^)
    02-19-2013 11:30 PM
  8. macorvocizmi's Avatar
    How to fix Google Play Store error code RPC:S-3
    01-04-2014 10:43 AM
  9. Albert Renchkovskiy's Avatar
    need just register with original,- that first google account you opened and used when play store worked .
    02-25-2014 08:27 PM
  10. Mylene Fiesta's Avatar
    Hi. I can not down load or up date from play store error code rpc:aec:0]. Please help.

    Piano Man
    06-07-2014 12:02 PM
  11. Anneth Foonach's Avatar
    This didn't work for my galaxy s5.

    Anymore tips on how to fix error 500 on samsung galaxy s5?

    09-16-2014 05:34 AM
  12. Anneth Foonach's Avatar
    This one didn't work as well. tried dozen times even reset my phone (samsung galaxy S5) but sitll couldnt work.
    09-16-2014 05:38 AM
  13. Charles Joynt's Avatar
    Was getting the same error [RPC:S-7:AEC-0] on two devices trying to download an in-app upgrade purchase. Tried all sorts of fixes including contacting Google Play support. Turned out that this was a newbie error: I hadn't set up a wallet/credit card for the Google account I was using. Wish the error message had actually said that!

    Useful troubleshooting was to try to download a free app from the store successfully and then fail with a paid-for app.
    B. Diddy likes this.
    01-05-2015 05:23 AM
  14. GHaustin's Avatar
    “””” A Fix For Not Being Able To Download Or Install Apps From The Google Play Store
    For People Who Have Tried EVERYTHING And It Still Doesn’t Work !!!!!!”””””””””

    To keep a long story short, I had decided to start using an older Android phone of\my wife’s. So I decided to factory reset it so I could start fresh on it. Well after it restarted it immediately began to ***** about not being able to connect to server. Then when I opened the play store everything I tried to download was Error retrieving information from server. I tried everything I could think of but nothing worked. Then hitting the forums and trying everything listed in them at least 10 times. So I was about to just give up then my little voice said try this one last thing and to my surprise it WORKED. Everything was working, updating and downloading. Here are the steps to what I did.
    1. Remove all accounts and yes this means do a factory reset
    2. Restart the device
    3. After start up DO NOT and I mean DO NOT create, link or sign in using your google account info. Hit skip this step and let the device fully start up.
    4. After is has started and you have a data connection open the Play Store
    5. At this time NOW sign in with your google account info.
    6. Just sit back and enjoy watching the updates come zooming in.
    I don’t know why this worked or how but it worked. I am posting this so that others who are as frustrated as I was, might have a chance at PEACE. May this post save others and lead to calm.
    11-13-2015 07:47 AM

Similar Threads

  1. Unable to download music from Google Play store
    By _EPG_ in forum AT&T Galaxy S II
    Replies: 6
    Last Post: 07-12-2013, 03:15 PM
  2. Is there a problem with my order from Google Play
    By nairb687 in forum Google / Samsung Galaxy Nexus
    Replies: 19
    Last Post: 07-25-2012, 07:42 AM
  3. Ordered Nexus 7 from Google Play 7/16
    By sstephen17 in forum Google Nexus 7 Tablet (2012)
    Replies: 4
    Last Post: 07-18-2012, 07:46 AM
  4. ordering from google play
    By cody_21 in forum Google / Samsung Galaxy Nexus
    Replies: 8
    Last Post: 04-28-2012, 08:32 PM
  5. Odd update request from google play store
    By Maynard in forum AT&T Galaxy S II
    Replies: 6
    Last Post: 03-28-2012, 07:05 AM