03-17-2014 10:14 AM
31 12
  1. Soham Kale's Avatar
    My Nexus 7 won't connect to my home WiFi. All my other devices connect to the same WiFi and my family's devices too, but not my tablet, so im pretty sure its a problem with my device. I've tried to reboot it and forget/connect-again to my WiFi but it isn't working. This has happened ever since my 4.2 update, before it was working fine. This is another 4.2 update issue along with jerkiness and the tablet slowing down constantly. What do I do????
    george meikle likes this.
    11-23-2012 09:43 PM
  2. B. Diddy's Avatar
    Try rebooting the router as well?
    11-23-2012 09:50 PM
  3. Soham Kale's Avatar
    Tried it too... didn't work.
    11-23-2012 10:18 PM
  4. Eduardo06sp's Avatar
    Forget your Wi-Fi network, and shut down your Nexus tablet. Then try clearing the cache, then re-connect.

    Sent from my Nexus 7 using Android Central Forums
    11-24-2012 03:13 AM
  5. guyjeb's Avatar
    Tried this as well. Same Problem. The Wireless connection stays in "Saved" instead of connected.

    Now I'm trying to figure out how to backup and attempt a rollback to 4.1.2...
    11-26-2012 01:48 PM
  6. Shilohcane's Avatar
    I have been having a Wi-Fi issue at a bar that I go to all the time that worked fine on 4.1.2 and started getting connection issues with 4.2. The bar and my home has no Wi-Fi security. I fixed it at the bar one day by forgetting the Wi-Fi rebooting and doing a new scan and it connected. Then the next day at the same bar the connection issue was back and I had to get them to re-boot the Wi-Fi for it to work.

    On Thanksgiving I went over to the Wife's parents and had a new version of this Wi-Fi connection problem that looked just like what is going on in this guys video on his n7. This was different than the bar's Wi-Fi that was simple to fix. The bar's Wi-Fi issue never looked like this video but this is what I saw at may Wife's parents house and it never connected. Some people think this is a WPA issue. This YouTube video is slow to load... wait for it.

    11-26-2012 02:22 PM
  7. Karizona's Avatar
    I've tried everything suggested thus far. All other devices in the house (3 android phones, 3 laptops, 1 netbook, and hubby's cheapo android tablet) all have NO problems. This is so frustrating. If I had the option I'd return this and maybe check out the Kindle Fire HD. I'm not happy and there's no where to turn....any suggestions of who to call, email, etc?
    12-01-2012 12:34 AM
  8. Drewfield's Avatar
    I had the same problem, losing wifi after about 30 secs. Disabling background sync on Currents worked for me. See -

    12-04-2012 10:06 AM
  9. John Flowers's Avatar
    Just opened a new Google Android 4. Using with my WiFi in home the device comes up with the message: Failed to Authenticate. Over and over.Signal is strong, password is correct.
    12-18-2012 09:36 PM
  10. cognus's Avatar
    Back to the OP - I have noticed some of this also on 4.2.1. as I type this on my trusty thinkpad I have 4 bars [my home AP - multi routers one AP]. On my very humble old Optimus P509 'droid I get 3 bars - no issues. on the nexus laying on the table in EXACTLY the same location, I get 1 bar, which will 'wobble' to zero, back to 1, etc.
    This location is line-of-sight to the stronger of my routers [external antennae].

    ? I don't have google currents.
    any ideas?

    I will say I have seen worse .... my wife's galaxy S 4G seems to pick the time and place at which it decides to receive wifi.... a problem I need to work on some day - that thing is terrible about connecting to wifi. my little optimus never complains about anything. connects like a signal-vacuum

    UPDATE: more weirdness. put our ipad mini in the same spot and it gets 2-3 bars.
    On the Nexus 7 I disabled and re-enabled wifi after a power-cycle boot. here's something interesting. if I change from landscape position [sensor picks it up] to portrait mode, the signal will change to the stronger, but it will drop the connection, re-authenticate, get connected again. reverse the procedure shifting to landscape mode - sensor flips the display, signal drops, disconnects, tries to reconnect/authenticate, secures "connect" at very low signal. I tried this multiple times holding the device [handwise] in different ways thinking maybe my hand/fingers in contact had something to do with it - the hand position seemed to make no difference. landscape mode bad. portrait mode not as bad. disconnect/reconnect, etc. No wonder there is "lag" going on if its cycling the connection every few seconds.

    What CHANNEL does the Nexus 7 like?
    12-19-2012 09:09 AM
  11. philba's Avatar
    I've seen a version of this problem on several android devices. Forgetting the connection and starting from scratch seems to do the trick.

    You could try going into the router and changing the channel it uses. Are you in the US? Wifi Analyzer (highly recommended app) shows the channels each router is using and how good the signal is. You could try moving to a different channel.

    Also, you could try changing the authentication type in the router just to see if that's the problem.
    12-19-2012 10:38 AM
  12. cognus's Avatar
    wifi analyzer can help. In my case I did change the channel [from 11 to 6] but the way wifi analyzer assesses signal, it just moves the curve. in other words, it will always suggest a channel other than what you're broadcasting on, regardless of how many times you change it.

    subjectively, the change in my case made it slightly worse. and I want to stress again that my other 'good' devices are getting potent signal RIGHT ON the same square inch where the nex 7 is dropping, reconnecting, dropping. basically if I stay within 10 feet line of sight to one of my ap points, its ok. otherwise not, and especially not when held in landscape mode.

    i note that the first time I personally messed with a nexus 7 was in an officedepot. the helpfully nerdy young man attending the techstuff was very familiar with his array of devices and noted that the nexus 7 "can never connect to our wifi" - several of the other tabs shone - the lenovo 2107 was latched on like a hound... worked really well
    12-19-2012 12:42 PM
  13. Jon Warr's Avatar

    I'm having the same problem with a N7. I have two. On belongs to my wife and was bought in Germany, it connects to our WiFi here in Germany just fine.

    The other N7 belongs to her mother who is her visiting. Hers was bought in the UK, is the same device (16GB WiFi only) and even the same build number but will not connect to the WiFi.

    I've tried changing security types, resetting router, disabling security, using WPS push button method, PIN method, turning WPS off, clearing cache, setting the time zone accurately, turning off google currents sync, changing my SSID to a single word, connecting via MAC address. and NOTHING has worked. It just says "Saved, Secured with WPA..."

    It wouldn't be so frustrating if the exact same devices behaved the same! grrr!
    Raphael Weiser likes this.
    01-01-2013 11:07 AM
  14. Zina Kind's Avatar
    Okay so I was having the same problem trying to reconnect my N7 to my ATT U-Verse WiFi. I tried repeatedly with all the methods that everyone on this forum tried and nothing worked. Finally, I connected to my aunt's Comcast Internet (she lives in the same apartment complex that I do) and voila. Problem solved. Everyone of course won't have the option of connecting to a different WiFi service that I do, but I definitely believe the problem is with the way that the N7 is connecting to different ISPs after the update.
    01-16-2013 09:48 PM
  15. Nig1's Avatar
    My wife is having the same problem. She has 32bit nexus 7 that will not find our wifi - I have 16bit that has no problem, all since 4.2 update!
    Bibin Chandran likes this.
    02-16-2013 04:42 AM
  16. Julie Bradley's Avatar
    I was hoping after some time there would be a solution to this, but even after the 4.2.3 update and rolling it back to 4.1.2 still nothing has worked. I have tried EVERY method listed here and NOTHING has helped. I am also stuck in the "not able to return" club.
    02-19-2013 02:52 AM
  17. Julie Bradley's Avatar
    I bought my nexus 32g at the end of November, when the wifi was just fine, so when 4.2 release well after 30 days, you can imagine how peeved I've been after 3 months of a now useless accessory to my gadget collection.
    02-19-2013 02:54 AM
  18. mow4cash's Avatar
    Switching to b/g only helped me.
    02-19-2013 11:45 AM
  19. Ted10's Avatar
    I had the very same problem with my Nexus7 but i cured it by selecting the wifi and pressing the button on the front of my Belkin router and it fired up straight away,so have a go at that.I have also installed the latest upgrade and its working fine.
    02-21-2013 02:19 PM
  20. GKWANNABE's Avatar
    I'm guessing no actual solution has come out yet for this issue? I mean, other than try this or that, no one has a solution? Too bad Google hasn't helped in this matter.

    Nexus 7|Android Forums
    02-23-2013 12:43 PM
  21. Matthew Dallas's Avatar
    I'm guessing no actual solution has come out yet for this issue? I mean, other than try this or that, no one has a solution? Too bad Google hasn't helped in this matter.

    Nexus 7|Android Forums
    spot on champ, my n7 was soo sweet couldnt understand why people fork out for apple. Even bought a n4 out of love. Now after a n4 charger that hums and is falling apart a n7 that wont connect to wi fi and a f*cken outrageous bill from me blissfully unaware of two unconnected devices (im not much of a techy) using my mobile data. Google have cluster f*cked me.

    Im going to switch to apple all my flatties have it and it just works. Ok there maps dont and they pay more but it works and i guess now ill have to re buy apps. guts

    edit: apple dont have widgets. cant live with out widgets
    02-23-2013 05:23 PM
  22. jenluvs2sing's Avatar
    I'm connecting fine just seems like it drops down to nothing at night, though I believe that's just my craptacular DSL...
    02-23-2013 09:41 PM
  23. Ted10's Avatar
    I have managed to fix my wi-fi problem by pressing the button on the front of my router(Belkin n ) and at the same time pressing the two arrows that make a circle on my Nexus at the same time and it fires up every time.I honestly hope that this works for everybody
    02-24-2013 01:50 PM
  24. Ted10's Avatar
    Hi Julie,I hope i have the answer for you as i had the same problem.What to do is press the button on your router and at the same time press the two arrows that make a circle on your Nexus and it will fire up every time.I honestly hope this fixes it for you.All the best from bonnie Scotland
    02-24-2013 01:57 PM
  25. Ted10's Avatar
    Hi Shilohcane,it is WPA issue but to cure it just press the two arrows that form a circle(as in your picture) at the same time press the button on your router and it will fire up...ted10
    02-24-2013 02:06 PM
31 12

Similar Threads

  1. Nexus 4 cannot connect to Wifi
    By li wei in forum Google Nexus 4
    Replies: 38
    Last Post: 10-20-2015, 09:19 PM
  2. email connection error and Phone not connecting to wifi?
    By hanly2 in forum AT&T Galaxy S II
    Replies: 0
    Last Post: 02-23-2012, 05:11 PM
  3. LTE 10.1 will not connect to WIFI
    By mega350 in forum Samsung Galaxy Tab 10-inch
    Replies: 2
    Last Post: 01-05-2012, 06:59 PM
  4. X10 mini not connecting to wifi after update.
    By fayek in forum Other Sony Android Phones
    Replies: 1
    Last Post: 11-03-2011, 03:33 AM
  5. CM7-Does Not Connect To Wifi?
    By popeye in forum Barnes & Noble Nook Color
    Replies: 2
    Last Post: 09-04-2011, 08:35 AM