01-16-2013 07:51 AM
27 12
  1. Crashing_Flower's Avatar

    I have had my Nexus 7 since Christmas day, but it won't update to 4.2.1.

    When I 1st switched it on, it immediately notified me that a system update was available to version 4.2.1. The nexus powers itself off then on, the Android icon came up with a blue progress bar, but when the blue progress bar gets to about halfway, the Android icon changes to lying on it's back with a red exclamation mark above it. It stays like this for a moment, then powers off then on, and when I check in the Settings, it is still running 4.1.2.

    It has notified of the update twice more since then but the same thing has happened both times when I have tried to update. When I check for system updates in the Settings - About tablet menu, it just tells me that the system is up to date.

    I have had a look round on Google etc, and can find a lot of information about manually updating Nexus 7 to 4.2.1 but I don't have the knowledge/confidence to manually update!

    Has anyone else been having the same problem, or is there anyway of "forcing" my Nexus to show that an update is available. I did read somewhere about changing the nexus' date back a year or two, but that didn't work for me.

    Any help would be much appreciated.
    01-01-2013 01:15 PM
  2. slinkies's Avatar
    Get on Google and find the update. Zip for 4.2.1
    Stock and download it and put it on the root of ur sd card then download and install the drivers for ur tablet on ur P. C then download adb. Zip and install then plug ur tablet into ur computer and open terminal and do adb reboot recovery and from recovery do install update. Zip
    Sent from my Galaxy Nexus using Android Central Forums
    01-01-2013 01:30 PM
  3. Crashing_Flower's Avatar
    Thanks for your reply.

    Found all this while having a look around on Google etc.

    Has anyone out there manually updated their Nexus 7? I was all set to manually update this evening, then backed down from fear of doing something wrong and breaking/destroying my Nexus!
    01-01-2013 03:20 PM
  4. Paul627g's Avatar
    To each there own but from what I've read around the forums concerning 4.2.x on the N7 many have regretted updating and wish they could go back to 4.1.x
    01-01-2013 03:42 PM
  5. Crashing_Flower's Avatar
    I have also seen some users saying they ate disappointed with 4.2/4.2.1.

    TBH, I think it is just frustrating me more that when my Nexus picks up that a system update is due, it fails halfway through.

    Sent from my Nexus 7 using Android Central Forums
    01-01-2013 04:00 PM
  6. slinkies's Avatar
    I'm running 4.2.1 on my Nexus and I love it don't be scared of manual updating its so simple once the update. Zip is on root of ur sd card just reboot into recovery and hit install update. Zip and it'll do everything else on its own.

    Sent from my Galaxy Nexus using Android Central Forums
    01-01-2013 04:11 PM
  7. Crashing_Flower's Avatar
    Might give it a go tomorrow.

    I had a website which had screenshots for each step so I will start there and see where I end up!

    Sent from my Nexus 7 using Android Central Forums
    01-01-2013 05:04 PM
  8. 68laurieann's Avatar
    I had a new Nexus 7 that would not update out of the box brand new. I ended up returning mine.
    01-01-2013 08:54 PM
  9. hmackenz's Avatar
    I'm clicking "install later" on mine until I know some of the problems I have with 4.2.1 on my n10 are fixed (i.e. with 4.2.2). There are things I can do over Bluetooth with my 4.1.x n7 that I can't do on my 4.2.1 n10 or gf's 4.2.1 n7, for example.

    Sent from my Nexus 10 using Android Central Forums
    01-01-2013 11:30 PM
  10. pretext's Avatar
    Same here.

    Sent from my Nexus 7 using Tapatalk HD
    01-01-2013 11:41 PM
  11. AussieSteve's Avatar
    Had the same problem. out of the box with the message that 4.2 was available, downloaded and half way through it crashed. Have reseted the system app and have had the same thing happen three times now. Bit frustrated as it is brand new. Can someone run me through the manual update process.
    01-02-2013 02:11 AM
  12. Crashing_Flower's Avatar
    I looked at the manual updating today, following this YouTube video:

    My problem was when you have to download the Android SDK files. You need a lot of free space, and my laptop did not appreciate having so much downloaded onto it!

    Then, 10mins ago, my Nexus pops up that a system update is available. So, I hit install now, nexus rebooted, android logo appears with the blue progress bar, blue progress bar got halfway (as usual) and then the android logo falls to his back with the red exclamation above him.

    I think my only option now is to try and contact Google to find out what is happening. Failing that I will have to see about taking it back to the store - which I really don't want to do! (factory restore has been done twice and doesn't solve the problem).

    Sent from my Nexus 7 using Android Central Forums
    01-02-2013 11:12 AM
  13. mcshovel's Avatar
    You might actually be lucky. I upgraded to 4.2.1 and regretted it. It became so laggy, it was almost unusable. Out of pure frustration, I listed it on Kijiji to get rid of it. I decided to get an iPad mini. I had a buyer lined up but got cold feet. Instead of selling I rooted it, installed CyanogenMod 10 and am loving my tablet again.
    01-02-2013 11:25 AM
  14. slinkies's Avatar
    U don't need all the SDK files you just need the adb. Zip and drivers for ur tablet

    Sent from my Galaxy Nexus using Android Central Forums
    bc2k likes this.
    01-02-2013 12:39 PM
  15. devra1's Avatar
    Might give it a go tomorrow.

    I had a website which had screenshots for each step so I will start there and see where I end up!

    Sent from my Nexus 7 using Android Central Forums
    If you want a simple point & click method that does everything for you, head over to xda-developers under "Nexus 7 Android Devopment" and get Wug's Nexus Root Toolkit. Highly recommended.

    Sent from my Nexus 7 using Tapatalk HD
    Bookworm88 likes this.
    01-03-2013 05:16 AM
  16. slinkies's Avatar
    He's not trying to root he's trying to manually update to 4.2.1

    Sent from my Galaxy Nexus using Android Central Forums
    01-03-2013 07:30 AM
  17. devra1's Avatar
    I know, and the toolkit can do a lot more than just root.
    It can also manually update to the latest, or previous versions, of Android.
    01-04-2013 07:04 AM
  18. slinkies's Avatar
    Really? I had no idea sorry if my post came off rude I just used wugs root toolkit on my Galaxy Nexus to root and unlock bootloader didn't see feature for that though good to know though so if we ever get OTA 4.2.1 ill easily be able to install without waiting for it to get pushed to my device.

    Sent from my Galaxy Nexus using Android Central Forums
    01-04-2013 07:47 AM
  19. dnew123's Avatar
    I also have the exact same problem. Got N7 32gb WiFi just after Christmas with 4.1.2 on it, when it asks to update it initially looks to be working then I get the red exclamation mark and eventually it restarts and rolls back to 4.1.2.
    I don't mind trying to manually update, but I find it really strange that stock devices would have problems updating. Does anyone have any idea what reasons there could be for these failures?
    01-04-2013 10:14 PM
  20. Matt Fortunato's Avatar
    Dont no but after I unlocked the device it worked, but now I'm on cyanogen mod and I couldn't be more hapier
    01-05-2013 08:27 AM
  21. Crashing_Flower's Avatar
    I ended up exchanging mine this morning.

    Received a new device running 4.2, and as soon as I connected it to my home WiFi, it updated to 4.2.1. Very happy.

    The staff in store had never heard of the problem before, but offered an exchange straight away.

    Sent from my Nexus 7 using Android Central Forums
    01-05-2013 11:38 AM
  22. MoiKatie's Avatar
    My nexus 7 bought just before Xmas also has exact same problem. Took back to PC world and was told to try manual update but if still have no joy to return for replacement.

    Not overly bothered about 4.2.1 but just concerned problem will continue for future updates.

    Will post when/if I manage to resolve but am interested to hear others experiences.
    01-06-2013 05:03 PM
  23. Bardock434's Avatar
    I would just not update @crashing flower because I personally think android 4.1.2 is actually better.
    01-09-2013 06:34 AM
  24. MAKuttner's Avatar
    I had the same problem. For those who want to go this route, here's the Asus number if you want to send it back for repairs: http://forums.androidcentral.com/goo...nexus-7-a.html
    01-09-2013 02:21 PM
  25. wiserblond's Avatar
    I have had my Nexus 7 32gb running 4.1.2 since November and it still won't update. It isn't rooted, but I use the Nexus throughout the day and don't really want to send it to ASUS for repair. Was just now trying to access the WUGFRESH toolkit to root and manually update and unroot the Nexus at Nexus Root Toolkit v1.6.2 | WugFresh but the site is apparently down. That is www . wugfresh.com / nrt Any idea if this is a permanent thing, or an alternate URLto download the toolkit?
    01-13-2013 02:11 PM
27 12

Similar Threads

  1. my Nexus 7 won't update to 4.1.2
    By Johnnyram in forum Google Nexus 7 Tablet (2012)
    Replies: 11
    Last Post: 02-10-2013, 09:35 PM
  2. shift won't update to GB
    By PayDay99 in forum HTC EVO Shift 4G
    Replies: 5
    Last Post: 06-21-2011, 12:59 PM
  3. New NookColor won't update to 1.1.0
    By mrdunn in forum Barnes & Noble Nook Color
    Replies: 11
    Last Post: 03-10-2011, 11:41 AM
  4. Rooted 2.2 won't update to 2.3.340 & an embarrasing ?
    By insuranceguy in forum Motorola X Rooting, ROMs, and Hacks
    Replies: 15
    Last Post: 02-28-2011, 08:41 AM
  5. Won't update to 2.2.1
    By seasideclub in forum Google / HTC Nexus One
    Replies: 4
    Last Post: 11-15-2010, 10:14 PM