09-28-2016 08:30 PM
64 123
  1. Bazza1's Avatar
    As with some others, I found Dolphin to be a better bet than Chrome at getting to an authentication page by typing in a random URL.

    Once the authentication page was found on Dolphin, I made a point of saving the URL and creating a new shortcut to it on the browser's homepage. Now clicking on that brings me directly there.
    As for Chrome, a lot more of a struggle to achieve that first connection, but once there, I created a shortcut to the URL, placed on the tablet (the three dots at top right > Add to Home screen) and it gave me the same ability.

    Both browsers struggle to work well on my N7 (2012) with 5.1.1, but that's a bigger problem of Google's creation.
    08-04-2015 08:13 AM
  2. Smitrock's Avatar
    What worked for me is, I just opened the default android browser and the sign-in page came right up. That browser is good for something...

    Galaxy tab 4 8.0
    08-24-2015 08:49 AM
  3. Daniel Wilder's Avatar
    the incognito mode worked for me, thanks!
    10-23-2015 01:41 PM
  4. Kathy McKenna's Avatar
    Thanks for solving a really frustrating problem for me too!
    11-30-2015 08:18 PM
  5. i1730826's Avatar
    Try to visit clients3. Google. Com (3 words; remove spaces - can't post link bcoz of some stupid forum rules)
    12-01-2015 01:56 AM
  6. Mamaj8578's Avatar
    I had tried some of these things nope didn't work.... but as I was trying to figure out how to clear the cache on my tab S2 I stumbled across how to get in.... I clicked on user manual trying to find the connection optimizer page which is what shows up on my tab 3, it took me to the sign in page... looks like user manual is using a different browser than the one on the home screen... hope this helps someone
    12-31-2015 05:47 PM
  7. mongooos's Avatar
    I was able to get this working by doing the following:
    • Turn off WiFi
    • Restart your device
    • Turn back on WiFi
    • It should connect to open WiFi and give you new Notification
    • Clicking notification now should load the browser and give you the prompt
    02-10-2016 11:09 AM
  8. Wingcommanderbob's Avatar
    Hello, I'm new to this site. I am having the same issue with my Samsung Galaxy S6 on a hotel WiFi service. I've tried every suggestion above but with no luck. My Google Nexus 9 tablet and my girlfriend's iPhone both brought up the login page instantly. If anyone has any further ideas on a fix, I'd be really grateful. Thanks!
    02-26-2016 01:36 PM
  9. goilaswati's Avatar
    HI I tried this, refreshed my browse cache. At the network window, it shows my wifi is connected. When i try to go to the browser window and put in any URL, it just goes half way and gives me an error - 'Oops Error occured - URL does not exist or weak signal or page not found'. Please help how to resolve this. This is not happening with other people's phone. Just my phone so nothing wrong with the wifi.
    05-11-2016 04:20 PM
  10. JustWorkStupidPhone's Avatar
    Thank You!

    I was having difficulty getting my Galaxy S5 to redirect to the log-in screen for wifi. After I deleted the data in Chrome it popped right up. Thank you!
    07-29-2016 09:27 AM
  11. El Sifon's Avatar
    Have you tried using a HooToo Router to setup a private wifi hotspot. These routers are made for hotel rooms that have splash pages. I have one and it works for what you want to do.
    08-05-2016 03:27 PM
  12. 12121211's Avatar
    Go to any browser and just type and bingo you will be directed to the web login page.
    08-21-2016 12:10 PM
  13. B. Diddy's Avatar
    Go to any browser and just type and bingo you will be directed to the web login page.
    Welcome to Android Central! This isn't always the case. Although that's a common address, different routers may use completely different addresses. It's usually on a sticker on the back of the router, or in the manual.
    09-17-2016 11:46 PM
  14. perry2das's Avatar
    if you go to your browser and type in it should redirect you to the welcome page of the service provider.
    09-28-2016 08:30 PM
64 123

Similar Threads

  1. connecting to a wi-fi network that requires a login
    By epicness in forum Sprint Galaxy S II Epic 4G Touch
    Replies: 6
    Last Post: 08-05-2013, 01:28 AM
  2. Can't re-connect to a public wifi network after disconnecting?
    By Yucca Patrol in forum Google Nexus 7 Tablet (2012)
    Replies: 0
    Last Post: 08-28-2012, 07:30 PM
  3. Cannot connect to WiFi?
    By TYL3R T in forum Motorola Droid
    Replies: 8
    Last Post: 02-21-2012, 09:24 AM
  4. Replies: 16
    Last Post: 03-11-2011, 12:44 AM
  5. Replies: 7
    Last Post: 09-20-2010, 04:03 AM