1. arcoms's Avatar
    I have a stock, unrooted, 32GB Nexus 7 and it has performed flawlessly. Even after the 4.2 updates, I didn't notice all the sluggishness most complained about.

    However, over the last few days its been giving me problems. First it would do random reboots. Then it would just stop loading any kind of internet content until I turned it off and back on again. Then the most disturbing thing that started to worry me happened where if I turned it off it would get stuck on the "X" and it would have to press the power button to shut it down and try again.

    Tonight, it won't do anything at all. I've tried doing a hard reset and it doesn't work. I'm pretty desperate.

    As you can probably tell, I'm not the biggest tinkerer. I know basic trouble shooting but I'm not very advanced in doing backups or flashing ROMs or anything like that. So it really troubles me that my N7 might just be toast since I probably can't figure it out on my own. Any help would be greatly appreciated.

    Sent from my Galaxy Nexus using Android Central Forums
    01-11-2013 04:26 AM
  2. mr_nobody's Avatar
    01-11-2013 11:25 AM
  3. theresistance's Avatar
    I have made a tutorial on how to fix the problem it is here:
    08-21-2013 06:51 PM
  4. jacko566's Avatar
    Thanks a lot! Very nice of you to post that fix
    09-19-2013 06:08 PM
  5. Jim Grudzien's Avatar
    I tried this and it keeps going back to the X screen...any other solutions out there? Frustrated as Hell!!
    11-02-2013 07:40 PM
  6. Jim Grudzien's Avatar
    I tried this at least 10 times and it keeps returning to the X screen, and other solutions out there before I return it.
    11-02-2013 07:44 PM
  7. Jaydax's Avatar
    The same thing happens with my Nexus 7 (2012) The only difference being that I get four coloured blobs merging and separating instead of the X. I've been factory resetting mine when it happens. It's pretty much hit and miss as to whether it works or not but I did find one method. After you've done a factory reset shut the Nexus 7 down. leave it 10 min and start it up again.

    The fix isn't perfect. It will happen again. I begin to wonder if there is an incompatible app on my Nexus. Possible the Kindle app since that one started giving me an 'Unfortunately, Kindle has stopped working.' followed by other apps and services doing the same until my Nexus 7 shut itself down.

    I also wondered about the possibility of an Android virus, however, I have Norton Mobile anti-virus installed and that said my device was clean.
    04-16-2014 09:57 AM

Similar Threads

  1. HELP Xoom stuck on boot screen
    By luvable31 in forum Motorola Xoom
    Replies: 2
    Last Post: 06-07-2013, 05:52 PM
  2. Help Request - Stuck on Google Boot Screen
    By ohcalcutta in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 5
    Last Post: 09-17-2012, 11:48 AM
  3. Please help. Phone stuck on boot screen :(
    By aarrodri in forum Epic 4G Touch Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 07-09-2012, 10:49 PM
  4. Galaxy nexus stuck on google boot
    By lpderek in forum Sprint Galaxy Nexus
    Replies: 3
    Last Post: 06-13-2012, 10:17 AM
  5. HELP Xoom stuck on boot screen
    By luvable31 in forum Motorola Xoom 2
    Replies: 1
    Last Post: 01-22-2012, 04:33 PM
LINK TO POST COPIED TO CLIPBOARD