1. gheedsgreed's Avatar
    Originally my Nexus 7 was rooted, and when it tried to update OTA it failed. After that it was still on 4.2.1 but would no longer find the OTA update. I factory reset the device, and it found the OTA update and failed again. I wasn't able to flash it with TWRP either. I finally unrooted it and flash stock recovery, relocked. It found the OTA, tried to install, and gave me an ERROR and little droid image with the warning symbol. What do I do now? Is there a way to totally reset it more? I'm thinking about selling it off and getting a fresh device.
    02-15-2013 04:01 AM
  2. planoman's Avatar
    Use the wugs nexus took kit to flash a 4.2.1 factory image which will make your Nexus 7 just like new and then do the OTA update to 4.2.2.

    It really makes it simple.

    Sent from my Nexus 7 using Android Central Forums
    02-15-2013 11:25 AM
  3. gheedsgreed's Avatar
    flash 4.2.1 didn't work. I flashed 4.1.2, and then it was finally able to update to 4.2.2
    Thanks anyways
    02-15-2013 04:49 PM

Similar Threads

  1. Can't Update to Froyo, MTP Error
    By larrytxeast in forum AT&T Captivate
    Replies: 6
    Last Post: 12-23-2011, 03:08 AM
  2. Can't update to 2.2.2, Sprint Zone not found
    By rydehard86 in forum Samsung Transform
    Replies: 2
    Last Post: 07-27-2011, 05:32 PM
  3. Can't update to Froyo 2.2
    By bequadro in forum Verizon Droid Incredible
    Replies: 3
    Last Post: 01-30-2011, 09:40 AM
  4. How can I update to 2.2 with Unrevoked3 installed?
    By sammy123 in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 18
    Last Post: 08-17-2010, 05:45 PM
  5. Can't update to froyo/update maps, facebook on moto droid (unrooted)
    By ebj in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 6
    Last Post: 08-15-2010, 11:24 PM