1. Bokehman's Avatar
    I know quite a few people have reported Location services issues on their phones. I've been having issues on my Nexus 7 with 4.2.2.

    About a week ago I kept getting a message that said "Unfortunately, Google Play has stopped" messages. Then I noticed my Google Now always has a "Location services is off" panel. All the location services settings are ON. I should add I let my device update all the apps automatically, and I hadn't done any additional installations or mods (my device is not rooted). After checking some of the forums I tried some of the possible fixes ...

    - Deleted the cache of the Google Play store
    - Downloaded and installed Google Play 4.1.10 (tablet was still running 4.1.6)
    - Factory restored the tablet. No resolution of problem.
    - Reinstalled Google Play 4.1.10 and left it open for 5 minutes. No resolution of problem.

    I had incorrectly assumed that after the factory restore my tablet would be completely restored by the Google servers. I'm a Mac user so I guess I'm pretty used the the backup/restore function in iTunes. It took an afternoon to get things back up to speed. The Play store didn't restore all my apps. Not sure what happened there. I will need to find a proper back up solution. Anyhow, I'm getting off-topic here ...

    The map and navigation apps seems to work fine. Not sure if they need to use the location services or not. The Weather Network app (Canada) cannot find my location. Weather 1 works fine.

    Has anyone else figured out this problem with Location services? I believe I've tried all the fixes but nothing has worked and I REALLY don't want to do another factory restore.

    Thanks in advance.
    07-28-2013 10:01 AM
  2. srkmagnus's Avatar
    What type of location issues are you having? Services not finding location? After all that it looks like the Play Store force closing is no longer happening?

    Check for system updates and see if that helps. Otherwise, you can also try man apps that are aimed at improving location on devices.
    Give this app a try to test gps on the device: https://play.google.com/store/apps/d....gpstest&hl=en
    08-02-2013 02:03 PM
  3. Bokehman's Avatar
    It looks like the problem is just with Google Now. Before, whenever I would be away from the house I would get the 'local' cards (ie. restaurants, places of interest, etc ...). Now it's just that "Location services is off" card (even though all the buttons are on). OS is at 4.3. I ran the GPS app you suggested and I regularly get 10-12 satellites.
    08-05-2013 04:14 PM

Similar Threads

  1. No service issue and error with wiping cache partition
    By avakil007 in forum Legacy Android & Other OS's
    Replies: 5
    Last Post: 10-21-2013, 04:49 AM
  2. Android 4.3 nexus 4
    By Google4Lifee in forum Google Nexus 4
    Replies: 29
    Last Post: 07-31-2013, 06:54 AM
  3. Nexus 7 - 16 vs 32GB flash performance?
    By dazed1 in forum Google Nexus 7 Tablet (2013)
    Replies: 8
    Last Post: 07-30-2013, 05:51 PM
  4. Tmo is awesome
    By Scott Kenyon in forum General News & Discussion
    Replies: 4
    Last Post: 07-28-2013, 06:29 PM
  5. New Nexus 7 Turn by Turn?
    By Bryan Didier in forum Google Nexus 7 Tablet (2013)
    Replies: 10
    Last Post: 07-28-2013, 04:11 PM
LINK TO POST COPIED TO CLIPBOARD