1. ShakeSpee's Avatar
    Hi. I have Nexus 7 (2012) model, and this weekend, it auto-downloaded an update from Google. I'm not sure what went wrong, but almost 5 hours later, it was still in the boot-up process. So I shut it down by holding the power button, and restarted it. It did the same thing. Then I held down the vol. down + power to get to the factory reset, but when I did the reset, it just stayed on "formatting data" and didn't change. So finally, I shut it down again, by holding down the power button, and now, when the menu comes up, nothing happens. If I choose recovery, nothing happens, and the menu stays the same. If I choose bootloader or start, the same thing happens. Is there any fix for this?

    If there is no manual fix, can someone please give me information as to how I can contact Google? I would appreciate that.

    Thanks for reading.
    01-15-2014 02:01 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! That sounds frustrating. Try this from the Google support page: https://support.google.com/googlepla.../3337561?hl=en

    To contact Google support for a Nexus device, go to this support page, and click on "Contact Us" at the upper right: https://support.google.com/nexus/?hl=en#topic=3415518
    01-15-2014 02:45 AM
  3. rakurth's Avatar
    I also have a 2012 Nexus 7. In April 2013 I sent it in to be repaired because it was not working. Got it back about 12 days later with no information on what was repaired. Again, in November 2013 it stopped working. Again, I sent it to Asus for repair and they sent no information on what was wrong with it. I finally got the info that it was the on/off switch. NOW AGAIN, I start it up and it says "Unfortunately Launcher has stopped." Is there someway I can get my money back since obviously I have a lemon? It is out of warranty.
    01-22-2014 04:12 PM
  4. James Changstein's Avatar
    My 2012 was fully charged, restarted then went blank; I have tried hold down the button(s) as instructed elsewhere but to no avail...
    The unit just went out of warranty so sending it in for a repair won't be cost effective..
    Anyone with any other suggestions on what else I can do to bring this back to life?
    Any suggestion is greatly appreciated.

    01-24-2014 12:02 PM
  5. B. Diddy's Avatar
    Did you try the link in post #2?
    01-24-2014 06:51 PM
  6. James Changstein's Avatar
    Yes, I did and nothing worked..

    Did you try the link in post #2?
    01-24-2014 09:05 PM
  7. B. Diddy's Avatar
    You could try popping the back cover off and checking for loose connections:

    James Changstein likes this.
    01-24-2014 09:10 PM
  8. James Changstein's Avatar
    I gave it a shot and it wasn't the battery connection....

    However, I noticed that while connected to a PC via the USB cable, the computer seems to recognize the tablet when I hold down the power button for 10+ seconds.. however, screen is still pitch black. I am guessing that the screen just burnt out? But it's kind of strange how the screen showed no symptoms and would just die all of a sudden...

    Any other suggestions before I "recycle" this thing?


    You could try popping the back cover off and checking for loose connections:

    01-25-2014 04:30 PM
  9. B. Diddy's Avatar
    Sorry, not sure. I would imagine you could use similar tools, like a screwdriver with a fine head.
    01-25-2014 04:32 PM

Similar Threads

  1. Waterproof/Water resistant hard case for the Nexus 7?
    By mr_wilson3 in forum Google Nexus 7 (2013) Accessories
    Replies: 10
    Last Post: 01-13-2017, 08:52 PM
  2. Weird URL problem on Nexus 4 internet browsers...
    By Daniela Machado1 in forum Google Nexus 4
    Replies: 5
    Last Post: 04-21-2014, 02:49 PM
  3. phone wont charge
    By Mr_Lewis in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 01-15-2014, 08:17 AM
  4. Nexus 7: Touch issues
    By Mr.Mcgoo in forum Google Nexus 7 Tablet (2012)
    Replies: 0
    Last Post: 01-14-2014, 10:11 PM