05-02-2017 03:52 PM
78 123 ...
tools
  1. Donnytechmaster's Avatar
    Ok, so I recently went and tried connecting my nexus 7 (2012) to my pc, and absolutely nothing happened. No devices appeared in device manager, and my nexus 7 didn't appear under computer either. I tried putting it in PTP mode, and still nothing. I even turned on usb debugging, and tried usb 3.0 and 2.0, still nothing happened. I think it might be a problem on the pc, but I'm not sure. Any help with this issue would be appreciated.

    NOTE: I did get it to work once before, but the next time that I logged onto my pc my nexus 7 would no longer connect.
    02-14-2014 12:23 PM
  2. Lupelamenta's Avatar
    It's the cable. Same thing happens to me when I use the cable that came with the Nexus, but when I use one that came with a Archos tablet or a Monoprice mini voila totally visible.
    02-14-2014 02:02 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! It's certainly a good idea to try another microUSB cable, as mentioned above. Have you also tried rebooting both the PC and the tablet?
    02-14-2014 03:14 PM
  4. Donnytechmaster's Avatar
    Yes I have, and I just tried another cable and still nothing happened. I'm not rooted, so it's not that. It seems to be a problem with drivers, the problem is that the tablet wont send it's USB drivers to my PC so it wont register as a device. However I have no clue how to fix this.
    02-14-2014 03:39 PM
  5. B. Diddy's Avatar
    See if this helps. The page loads very slowly for me. ASUSTeK Computer Inc. -Support-
    02-14-2014 05:49 PM
  6. Donnytechmaster's Avatar
    That's the problem, there is literally nothing in device manager relating to android, or my nexus 7 at all when it is plugged in.
    02-14-2014 06:06 PM
  7. B. Diddy's Avatar
    Hmm. Ok, try these steps--the important bit is near the end, where the author talks about a windows program called USBDeview: Android USB Connection Problems Solved
    02-14-2014 07:14 PM
  8. Donnytechmaster's Avatar
    Well, I tried the solution you suggested, and it didn't work. I followed the steps, and deleted the old devices (showed 2 Nexus 7 devices) using the USBDeview program, and nothing happened again. It mentioned that I could manually install the drivers, but the problem with that is that I can't seem to find the nexus 7 drivers anywhere, not even on the ASUS website. This is becoming a real pain
    02-14-2014 08:21 PM
  9. B. Diddy's Avatar
    I've seen this problem mentioned elsewhere, but so far I haven't been able to find any generic USB driver. The Android USB driver I find on the web is for debugging, so I'm not sure if that's the one you should use. Will keep looking into it.
    02-14-2014 08:56 PM
  10. Donnytechmaster's Avatar
    Thanks, I'm decent with computers, but dealing with drivers is something totally new to me. Hopefully I will find an answer soon.

    PS: I was thinking that if I were able to somehow re-update my nexus 7 to 4.4.2 that it might fix the problem, since it seems to have something to do with my nexus software rather than my pc. Just wondering what you think about this.
    02-14-2014 09:13 PM
  11. B. Diddy's Avatar
    Interesting thought. One way to test things out might be to connect your Nexus 7 to some other computer and see if it gets recognized. If it doesn't, it may very well be an issue with the device. If it does, then I would focus back on your own computer.
    02-14-2014 09:19 PM
  12. Donnytechmaster's Avatar
    NIce idea, I will definitely try that tomorrow and get back to you with my findings.
    02-14-2014 09:29 PM
  13. B. Diddy's Avatar
    Another thought--go to the support site for your computer's manufacturer, and look for the download for the main USB driver for you specific computer model. Even if it's the version you have, try installing it.
    02-14-2014 09:34 PM
  14. Donnytechmaster's Avatar
    Only problem with that is that I built my PC so there is no website with all the drivers.
    02-14-2014 09:51 PM
  15. Donnytechmaster's Avatar
    I just confirmed that it is an issue with the tablet itself. I connected it to a different computer in the house and still got no response. The question now is how do I fix this issue since is is on the tablet? I would rather not have to re-install my OS (Don't know how either), but it may be the only option left. Please let me know if you find anything.
    02-15-2014 12:20 PM
  16. B. Diddy's Avatar
    Try doing a cache partition wipe. http://forums.androidcentral.com/sho...d.php?t=337072

    Posted via Android Central App
    02-15-2014 12:31 PM
  17. Donnytechmaster's Avatar
    I actually just tried this before you mentioned it, and it still did nothing. I am wondering about the option to "restart bootloader". Will this delete my data and files, or is it safe to do.
    02-15-2014 12:50 PM
  18. B. Diddy's Avatar
    Not sure about that. Hopefully someone else can chime in about it!
    02-15-2014 01:16 PM
  19. Donnytechmaster's Avatar
    Ok, now I'm really confused. I did a factory reset through the settings and it still does not connect! I then tried doing it again but through the bootloader, still nothing! I don't understand, shouldn't resetting it bring it back to normal? if not then is it a hardware issue rather than a software issue?
    02-15-2014 03:14 PM
  20. jdbii's Avatar
    The following steps might different depending on your version of Windows and what driver your PC loaded for your device. But idea is to uninstall the driver your PC is using and disconnect your Nexus 7 and reconnect.

    Go into Devices and Printers on your windows PC >>> Right click your Nexus 7 >>> Properties >>> Hardware >>> Properties >>> Change settings >>> Driver >>> Uninstall. >>>>> Done >>>> Then unplug Nexus 7 and replug and Windows should load the correct driver and Nexus 7 should be recognized.
    04-11-2014 11:44 AM
  21. TJC0MB0's Avatar
    I had this same issues and your solution worked! thanks!
    07-02-2014 09:08 PM
  22. gemsjams4eva's Avatar
    Ok, now I'm really confused. I did a factory reset through the settings and it still does not connect! I then tried doing it again but through the bootloader, still nothing! I don't understand, shouldn't resetting it bring it back to normal? if not then is it a hardware issue rather than a software issue?
    You may have to install the usb driver manually:
    These worked for me:

    Try the first option first and if no luck, then try the second option..

    1. 1. First, you may have to install the “usb driver software” for your device for your computer to recognise your use device (the nexus 7), this can be found at: How to flash factory image on Nexus 5, Nexus 7 and Nexus 10 to return to stock

    or follow this:

    How to solve ADB : 'Device Not Found' error in Android [SOLVED] ~ Dominant Wire

    Let me know how you get on x
    07-06-2014 09:49 AM
  23. Sentient Being's Avatar
    I found this solution to the above problem. I too was perplexed with this USB connectivity issue with my Nexus 7 2...
    This method is so simple, but it seems very elusive:

    Check the USB settings on the Nexus 7
    - Open the Nexus Settings App
    - Select Storage (It should show space used by programs, media, etc)
    - Open the menu (the 3 dot icon - in upper right corner on my model)
    - Select USB Computer Connection
    - Make sure the Media Device (MTP) is check marked by touching the check box
    This makes the Nexus 7 look like a drive when connected via USB

    You can now try connecting the Nexus 7 to the computer via the USB cable.
    07-20-2014 04:03 AM
  24. Sentient Being's Avatar
    Duplicate
    07-20-2014 04:08 AM
  25. Drawen's Avatar
    Have you tried to change the USB cable ?, it was the solution in my case
    08-08-2014 02:07 AM
78 123 ...

Similar Threads

  1. Will the nexus 5 get ota updates if my carrier is sprint
    By Deadly_Poison630 in forum Google Nexus 5
    Replies: 14
    Last Post: 02-19-2014, 11:50 AM
  2. App that blocks SMS but not calls?
    By Axic10 in forum Android Apps
    Replies: 3
    Last Post: 02-14-2014, 05:07 PM
LINK TO POST COPIED TO CLIPBOARD